Bitmap font no longer useable on upgrade 19.10 -> Focal (development)

Asked by Jonathan Hartley on 2020-01-29

For years I've installed a bitmap font for my terminals, but since I upgraded to Focal (development branch) today, it no longer works.

The font is 'Dina', from here:
http://www.dcmembers.com/jibsen/download/61/?unapproved=504&moderation-hash=f1abb9d89caafa881dcfc05cd32372e7

I have always installed it using a script:

    # install dina
    sudo mkdir -p /usr/share/fonts/Dina
    cd /usr/share/fonts/Dina
    sudo unzip ~/Downloads/Dina.zip

    # enable bitmap fonts
    sudo rm -f /etc/fonts/conf.d/70-no-bitmaps.conf

    # rebuild the cache
    fc-cache -f -v

    # Set as default mono font
    gsettings set org.gnome.desktop.interface monospace-font-name "Dina 8"

This has always worked in the past, through many versions of Ubuntu, including 19.10.

I installed Focal today, using `sudo do-release-upgrade -d`.

Now the above script does not make Dina visible in font selectors such as that produced by the Tweaks / Fonts / [Monospace Text] button. Terminals that were previously configured to use that font now display the "box of hex digits" characters (what are they called?)

I cannot run 'gnome-font-viewer' to check things out, presumably due to some variant of:
https://bugs.launchpad.net/ubuntu/+source/gnome-font-viewer/+bug/1375819
(the window displays but immediately locks up.)

While trying to find a fix, I tried a few changes to the above script, which did not help:

* Unzip to "$HOME/.fonts" instead
* Trying other symlinks in the fonts config.d:

    (
        cd /etc/fonts/conf.d
        sudo rm -f 70-no-bitmaps.conf
        sudo ln -sf ../conf.avail/70-yes-bitmaps.conf
    )

  (tried with both 'yes-bitmaps' and 'force-bitmaps')
* fc-cache -r # "really" force cache re-creation

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-01-29
Last reply:
2020-01-29
Jonathan Hartley (tartley) said : #1

The output of fc-cache includes this, which looks like it's working:

    /home/jhartley/.fonts: caching, new cache contents: 0 fonts, 1 dirs
    /home/jhartley/.fonts/Dina: caching, new cache contents: 13 fonts, 1 dirs
    /home/jhartley/.fonts/Dina/BDF: caching, new cache contents: 13 fonts, 0 dirs

So apparently it's grabbing the .bdf files, not the .fon files in the directory above. I don't know whether 19.10 was doing the same.

I suggest you report a bug. Focal isn't stable and not remotely ready. It worked before because the release is stable. Focal isn't

Jonathan Hartley (tartley) said : #3

Done. Thanks for the thoughts.

Can you help with this problem?

Provide an answer of your own, or ask Jonathan Hartley for more information if necessary.

To post a message you must log in.