New Epson V19 scanner problems under Ubuntu 18.04.3

Asked by Gary Potwin on 2020-01-13

Bought new Epson V19 scanner, and it works fine on my wife's computer running Windows 7, and also on my computer running Windows XP. Rebooted my computer into Ubuntu 18.04.3, and installed the driver packages recommended by Epson (version 3.61.0 for Ubuntu 18.04, 64 bit, release date 12-26-2019) using their install.sh file with the without-network option (imagescan 3.61.0, imagescan-plugin-gt-s650 1.0.2, and imagescan-plugin-ocr-engine 1.0.2). Looking at these packages using Aptitude, it appears that they are installed OK with no missing dependencies. Imagescan (on the graphical desktop) appears to find the scanner, and when you click to scan, you can hear the scanner seeming to run normally, but no image is produced at the end. Using the terminal, lsusb, sane-find-scanner, and scanimage -L all seem to work fine for finding the scanner. But when I try scanimage -T, no image file is produced, although you can hear the scanner appearing to do a normal scan. So it appears that all the control functions are working fine, but the problem is getting the scan data. I also tried the suggestions in this video (https://www.youtube.com/watch?v=8q82X7PpRaQ) titled "ubuntu 18.04 scanner problems how to fix them" concerning bug 1728012. In the end, nothing appears to have changed, so it appears I didn't make it any better or any worse. Any help would be greatly appreciated, including referring me to another place if I'm not posting in the right place yet. Thank you.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-01-22
Last reply:
2020-02-07
Bernard Stafford (bernard010) said : #2

If the above fails to work using other driver. File a Bug Report.

Gary Potwin (gary-theworld) said : #4

Thank you, bernard stafford, for your 3 very prompt replies. #1-1: the file I downloaded using the link you supplied was the same file (it checked exactly using cmp) mentioned in my original message, so I can't see what is to be gained by trying the same thing again. #1-2: this link is to a tutorial for a different scanner from 2015, so I can't see what is to be gained by that. #1-3: that link is for printing, and I have no printer attached to this computer. #3: this is a link to the directions I had already followed. #2: unless you or someone else can provide any further advice, it looks like that may be my only option. Thanks in advance for any further responses.

The archive will spit out an install.sh file which you can mark as executable and run.

Does this install OK?

If the scanner is USB based then use:

sudo ./install.sh --without-network

This should run OK.

Gary Potwin (gary-theworld) said : #8

Thank you, actionparsnip, for your prompt replies. Regarding #5 above, using aptitude with the _ option on each package, I first uninstalled the 3 packages I had previously installed (see my initial message above). I then downloaded the package you indicated. Regarding #6 and #7 above, I ran the install.sh file as sudo as follows: ./install.sh --without-network. Everything appeared to install OK, but I still have the same problems as above, namely, using Imagescan from the desktop and using scanimage -T, the scanner sounds as though it is doing a normal scan, but there is no image file produced. Here's hoping that we can find a fix for this. Thanks in advance for any further responses.

If you run simplescan or xsane using sudo does it work OK? This will show if it is a permissions issue or not on the GUI app.

Gary Potwin (gary-theworld) said : #10

Thank you, actionparsnip, for your very prompt reply. As best I understand it, both simplescan and xsane are GUI apps, so the only way I am aware of so far to run something as sudo in a GUI is to create an administrator login, and use that to run them. When I run simplescan, the 7 dots in the middle of the screen cycle around in a circle, and then stop, and nothing else happens. Xsane was not installed, so I installed it. When I ran it, 3 screens came up, all of which list my scanner at the top of each screen. On the Preview screen when I clicked "Acquire preview", I got the message "Failed to start scanner: Operation was cancelled". On the xsane 0.999 screen, when I clicked "Scan", the scanner sounds as though it is doing a scan, but then a screen comes up that says "Warning: Operation was cancelled". So I may very well be doing something wrong here, but I don't know what that is. Thanks in advance for any further responses.

There is no such thing as an "administrator login" in Ubuntu.

Open a terminal and run:

sudo apt-get install xsane
sudo xsane

Does it run OK?

Gary Potwin (gary-theworld) said : #12

Thank you, actionparsnip, for your reply. I was out of town for several days. When I followed your instructions in #11 above, I got the same results as in #10 above. Here's hoping this can be figured out. Thanks in advance for any further responses.

Launchpad Janitor (janitor) said : #13

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Gary Potwin (gary-theworld) said : #14

Doing the usual Ubuntu operating system updates, we are now up to 18.04.4. Epson came out with a new driver (3.63), as opposed to the 2 previous drivers mentioned above. 3.63 works just fine, so it looks as though it just wouldn't work with the previous 2 drivers. So it looks as though this problem is solved, but I don't know how to mark this question as solved. I'm going to make this same entry in the bug (1862847) that I started on this problem, and try to close it out also.