Ubuntu 18.04 Nvidia nForce 630a Driver Issue

Asked by Parikshit Bhagawati on 2020-01-09

I have an ASUS board (m4n68t-m le v2) with on board Nvidia graphics chipset model#: nForce 630a/ GeForce 7025. I have Windows 10 installed and I have now installed Ubuntu 18.04 on the same HDD having a dual boot scenario. The problem is i am not able to find and install the correct nvidia driver version on ubuntu.

I have to say I am fairly new to Linux, hence from various sources/forums, here is what I have done so far:

blacklisted default open source nouveau driver
ran update-initramfs -u after that
downloaded the compatible .run package from nvidia site and tried installing. every time there is a kernel error. tried all options - with/without DKMS etc.
tried installing using package manager using: sudo apt install nvidia-driver-xxx. Not able to connect to Nvidia driver error. Had to move back to nouveau.

Additional problems: a) ubuntu-drivers devices: returns nothing. b) from software & updates GUI - nothing appears in additional drivers tab (no recommended drivers etc.) c) lspci | grep VGA command shows the correct adapter information: 00:0d.0 VGA compatible controller: NVIDIA Corporation C61 [GeForce 7025/ nForce630a] (rev a2)

Many forums say to disable Secure Boot or UEFI mode, but both options are missing from my BIOS. It's currently running in Legacy (MBR) mode.
Formatted the partitions and re-installed ubuntu but with no luck. ran: sudo apt-get update && sudo apt-get upgrade -y etc.. no use!
Please help! thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-01-11
Last reply:
2020-01-16

Are you planning to game in Linux?

Not really. I intend to use the machine for dev work mostly, but there is flickering sometimes and the animations are very slow with a lot of lagging. Garbled display in some portions of the screen sometimes etc.. Tried it on Ubuntu 19.10 as well and it's worse there.

If you run:

sudo apt-get install nvidia-current

does it install OK?

Doesn't work either. Here is the output:
-------------------------------------------------------------
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package nvidia-current is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'nvidia-current' has no installation candidate

Do you have the latest BIOS in the motherboard

Well, that's another battle. BIOS firmware is not updated. Actually, I think I never did update it and the system is pretty old. Every time I fire up the utility from BIOS (ASUS flash tool), the display goes black with a "monitor out of range" message which is probably a resolution issue with the GPU or something. I am not sure but I am trying to find a fix for that too and see if I can flash it with the latest update. I'm using a VGA monitor which is USB powered.

Ubfan (ubfan1) said : #7

Try installing nvidia-driver-390. That should work, I think the latest package I ran on an n630 was 340, so try that if 390 does not work.

Can you help with this problem?

Provide an answer of your own, or ask Parikshit Bhagawati for more information if necessary.

To post a message you must log in.