Agfa snapscan e50 on Bionic release with Simplescan app.

Asked by peter b on 2020-01-09

hello,
- BEFORE the power failure simplescan worked flawlessly anytime needed since Bionic installed first time
- AFTER the power failure simplescan can not find the scanner/snapscan e50, scanning is not possible, the scanner power light is all the time ON even after PC shutdown.

- pls find below some outputs

$ uname -a
Linux peter-18 4.15.0-34-generic #37-Ubuntu SMP Mon Aug 27 15:21:48 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

$ scanimage -L
device `snapscan:libusb:003:004' is a AGFA SNAPSCAN e50 flatbed scanner

$ sane-find-scanner
..
..
found USB scanner (vendor=0x06bd [AGFA], product=0x208f [ SNAPSCAN e50 ]) at libusb:003:004
..
# Your USB scanner was (probably) detected. It may or may not be supported by
  # SANE. Try scanimage -L and read the backend's manpage.

$ lsusb
..
Bus 003 Device 004: ID 06bd:208f AGFA-Gevaert NV SnapScan e50
..

It looks like the scanner is detected, for sure it's in good working order/just used 2 hrs before.
 - Is it possible to get some advice/howto get simplescan app running again pls?

Browsing the net for solutions to above unfortunate event the VuScan app found but it is not in the repositories/or did I miss it maybe?
 Any help is appreciated and thanked for in advance.
peter b
b1pete

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2020-01-09
Last reply:
2020-01-10

If you reinstate the driver, does it help

Does it work OK in LiveCD?

peter b (b1pete) said : #2

thanks,
- Bionic as U could see was installed a long way back/years ago, and for sure it/snapscan worked because never had problems with this app. until this power failure recently.

- I checked over the net sane page and it appears to me that there was and still is lot of development going on.
-v sincerely I'm at a bit of a loss with all these changes that occur v rapidly/how to get reinstated snapscan to good working order ie all those links, dll config files etc etc. I'm just wondering if there is somewhere a howto to do it.

- one more thing/important one -
- because i badly needed the scanner, yesterday VuScan app downloaded off the net was installed and it worked on my Bionic release flawlessly but there is a big catch namely it's not on the Bionic repositories and wonder how long it'll keep on working.

In summary - I would be happy to keep on using the Bionic apps/Snapscan instead of VuScan,, for sure there are solid reasons why it's not on the official repositories.
I will be v happy to provide any file/command outputs needed by the developers and correct any missing links/config files content with Ur/sane developers help.

You can report a bug with your commands etc as a fix

Can you help with this problem?

Provide an answer of your own, or ask peter b for more information if necessary.

To post a message you must log in.