What about with i386 ppa builds in Ubuntu Focal Fossa?

Asked by otto06217 on 2019-12-10

Question: What about with i386 PPA builds in Focal Fossa?
https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp-edge/+packages

Thank you

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-12-10
Last reply:
2019-12-13

It's a PPA. It's down to the maintainer to make i386 builds if he or she wants to. The first P in PPA stands for "personal". The packages are intenslded for use by the maintainer and for the maintainer using their own options for their own requirements. The fact that they are available to anyone is just a bonus.

If you contact the PPA owner they may build for i386 but they may not want to and they do not have to. The packages are for themselves.

Manfred Hampl (m-hampl) said : #2

@actionparsnip: The question was coming from the owner of the PPA

@Otto: From the release notes of Ubuntu 19.10: Support for i386 as a host architecture is dropped in 19.10.
Maybe this has the consequence that PPAs do not build i386 binaries for focal any more.
Have you checked whether there is the possibility to enable it (the same way as arm builds can be enabled in a PPA)?

I suggest that you better ask such question in "Launchpad itself" and not in Ubuntu (or just move this question there).

Oh...apologies :)

Colin Watson (cjwatson) said : #4

I've linked to the bug requesting this feature.

Can you help with this problem?

Provide an answer of your own, or ask otto06217 for more information if necessary.

To post a message you must log in.