[WIFI][DRIVER][RTL8812AU][USB]

Asked by Ivan on 2019-12-02

Hi, I am having bad wifi perfomance (freeze, ping spikes) with the latest driver rtl8812au-dkms from ubuntu repository

Ubuntu 18.04

Wifi: usb rtl8812au 802.11a/b/g/n/ac wlan adapter

So therefore I decided to install driver from this link:
https://github.com/aircrack-ng/rtl8812au

It works a lot better. Yet I haven't noticed any problems.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2019-12-02
Last query:
2019-12-02
Last reply:
2019-12-02

What is the output of:

sudo lshw -C network; lsusb; lsb_release -a; uname -a

Thanks

Ivan (yamal4321) said : #2

  *-network
       description: Wireless interface
       product: Centrino Wireless-N 130
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 34
       serial: dc:a9:71:10:ea:69
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.0.0-36-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:27 memory:f7200000-f7201fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 06
       serial: e8:11:32:9b:2c:73
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:19 ioport:b000(size=256) memory:f2104000-f2104fff memory:f2100000-f2103fff
  *-network
       description: Wireless interface
       physical id: 2
       bus info: usb@2:1.2
       logical name: wlan1
       serial: 00:0f:00:4f:e5:35
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8812au ip=10.35.252.73 multicast=yes wireless=IEEE 802.11AC
Bus 002 Device 005: ID 8086:0189 Intel Corp.
Bus 002 Device 007: ID 0bda:8812 Realtek Semiconductor Corp. RTL8812AU 802.11a/b/g/n/ac WLAN Adapter
Bus 002 Device 010: ID 0d8c:0014 C-Media Electronics, Inc.
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 2232:1008 Silicon Motion
Bus 001 Device 009: ID 04d9:a115 Holtek Semiconductor, Inc.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic
Linux a123 5.0.0-36-generic #39~18.04.1-Ubuntu SMP Tue Nov 12 11:09:50 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Try:

echo "options rtl8812au rtw_power_mgnt=0" | sudo tee /etc/modprobe.d/rtl8812au_fix.conf > /dev/null

reboot to test

Ivan (yamal4321) said : #4

No absolute difference. Ping is unstable. In both cases.
Installing newer version from https://github.com/aircrack-ng/rtl8812au solved the problem

You can undo the chang we made with:

sudo rm /etc/modprobe.d/rtl8812au_fix.conf

Reboot to apply. I suggest you report a bug stating that the newer version helps the system

Ivan (yamal4321) said : #6

Thanks actionparsnip, that solved my question.