GPT partitioning: bad magic number

Asked by Musashi on 2019-11-21

Bad magic number in super-block
e2fsck: Superblock invalid, trying backup blocks...
e2fsck: Bad magic number in super-block while trying to open /dev/sdb

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem. If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
 or
    e2fsck -b 32768 <device>

I am experiencing this issue on my HDD, I am using it as my secondary HDD

at primary I am using SSD

your timely assistance will mean a lot, Thank you!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-11-21
Last reply:
2019-11-21

Did you try fscking with a different superblock number?

Manfred Hampl (m-hampl) said : #2

What did you do to receive these messages?

If you executed "fsck /dev/sdb", then this is easily explained, because the command is wrong.
A file system checks (fsck) have to be executed on a file system (e.g /dev/sdb1), not on a whole disk (/dev/sdb).

What is the output of the commands

uname -a
lsb_release -crid
fdisk -l
gdisk -l

Musashi (mush318) said : #3

I guess that won't be necessary, earlier today I tried repairing and later checking it via DISKS in ubuntu.

It worked like a charm , I guess I should've tried basic trouble shooting. My bad.

P.s- I wish I could've got earlier, but I lost internet access, my apologizes.

Thanks for your time and assistance, Sir @m-hampl, @andrew-woodhead666

Can you help with this problem?

Provide an answer of your own, or ask Musashi for more information if necessary.

To post a message you must log in.