Grub Selections Broken After 19.04 to 19.10 Upgrade

Asked by David E. Corkrey Sr. on 2019-11-18

I have an Aspire TC-330 dual boot desktop, Ubuntu 19.04 and Windows 10. Previous installs/upgrades of Ubuntu installed fine with no Grub problems. Just had to go into bcdedit on Windows to change the path for {bootmgr} to Ubuntu efi to make Grub display.

After upgrade from 19.04 to 19.10, Grub selections appeared on startup and did not start with Windows. Only the Ubuntu selection works. None of the others listed below Ubuntu (like Windows Boot Manager) work. Cannot get into Windows at all.

The only solution to get everything running was to reinstall 19.04 to get Windows and then make Grub appear.

I have tried just installing 19.10 from scratch with no luck. Same result with Grub. Could it be caused by how the Aspire handles uefi? Would appreciate any help as I would really like to be able to upgrade...

Here is the Aspire firmware when running 19.04/Windows 10:
C:\WINDOWS\system32>bcdedit /enum firmware

Firmware Boot Manager
---------------------
identifier {fwbootmgr}
displayorder {bootmgr}
                        {1d8cfc7c-fce5-11e9-b125-806e6f6e6963}
timeout 2

Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=\Device\HarddiskVolume1
path \efi\ubuntu\grubx64.efi
description Windows Boot Manager
locale en-US
inherit {globalsettings}
flightsigning Yes
default {current}
resumeobject {3d87d5cb-08cc-11ea-a2f3-8027cbe94cb5}
displayorder {current}
toolsdisplayorder {memdiag}
timeout 30

Firmware Application (101fffff)
-------------------------------
identifier {1d8cfc7c-fce5-11e9-b125-806e6f6e6963}
description ubuntu

C:\WINDOWS\system32>

Thanks

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-11-18
Last reply:
2019-12-04
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.