cannot boot win 10 or linux

Asked by Pat Menken on 2019-11-18

I tried to go through the previous questions, but to no avail. I can not boot win 10 or linux after installing linux... i can only boot the usb (live). when i try something like boot-repair, it gives an error "The current session is in Legacy mode. Please reboot the computer, and use this software in an EFI session. This will enable this feature. For example, use a live-USB of Boot-Repair-Disk-64bit (, after making sure your BIOS is set up to boot USB in EFI mode." I see two settings in my bios that talk about EFI, one is for cd/dvd, and one is for my USB (something like "allow Legacy Support"). I have tried several combinations of changing these values, ultimately all have the same problem. As I understand it, I think I have windows installed in a different mode than I installed Linux (maybe windows is legacy and linux is EFI ?). I cant get a load OS screen, and like i said earlier, neither OS will boot.... how can i fix this, and if it involves boot-repair, then, is there one that wont give me the error mentioned above ? i have no cd or dvd to burn a bootable disk... i dont think the "Live" version is saving settings/anything. HELP. if i went to store and got a writeable cd, would that work ? and how do i read/write an iso (if so). the above mentioned software downloaded as an iso..... if i remember correctly, i needed an iso reader and a seperate program to write to a cd/dvd. is there a way to do this in "live" mode ? btw, win 10 is on one drive, and linux is on a different drive. my drives should be C: (windows 10) d: (my cd/dvd drive), e: (miscellaneous data) and f: (linux install). weirdly, linux live (and win 10 before i installed linux) were both able to read the E drive....i found this question involves how to fix my boot problem only using my linux "live" on a usb drive.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Pat Menken (kooliloach) said : #1

for my boot-repair log, see

Manfred Hampl (m-hampl) said : #2

Manfred Hampl suggests this article as an answer to your question:
FAQ #3041: “No support for Linux Mint”.

Amelia Rossi (ameliar) said : #3

Give this a shot:

On a terminal type sudo update-grub. You should see something like: "windows detected". Restart, and hopefully when Ubuntu boots, you will see a menu to choose in which OS you want to boot.

Hope it helped!

Pat Menken (kooliloach) said : #5

the website said "Hmm. We’re having trouble finding that site." ( i tired copying and pasting it more than once). I also tried the sudo update-grub command in terminal and it said several things about linux, but never said anything about windows. It was previously mentioned that this site doesn't Support my particular Linux version. I appreciate all the responses, but alas, I should probably give up on windows at this time. At least I can get Linux to boot. Thanks again.

Can you help with this problem?

Provide an answer of your own, or ask Pat Menken for more information if necessary.

To post a message you must log in.