18.04.03 LTS Server Installer does not recognize disk while Desktop Installer does

Asked by Pathway on 2019-11-05

I was attempting to install Ubuntu Server 18.04.03 to an older machine. I burned the ISO image to a DVD and attempted to install via a USB CD-ROM. The only disk in the machine was a 120GB Seagate IDE disk. In Bios, all settings were set to AHCI and the disk was clearly visible and selectable in the boot-order selection. I had also previously run a check using SeaTools to ensure the driver was OK (SMART OK, short and long test PASSED).

The installer failed to identify any target media for installation. I found no way to overcome this. Things I tried:
- Changing the jumper from Master to CS and varying the position of the drive on the cable
- Wiping the disk of previous (Windows) partitions using gparted from a bootable utility CD
- Playing with various BIOS options (from AHCI to IDE etc)

What I noticed:
- If I used alt-F2 to drop into a shell when faced with the "could not find a media.." message, I ran fdisk -l and the drive was recognized and reported without issue.
- When I attempted to install Ubuntu Desktop 18.04.03, Ubiquity found the drive and installed on it with no problems whatsoever. I changed nothing between my attempt to install Server and my successful installation of Desktop
- After the Desktop installation, I again attempted to install Server. The installer was still unable to find the media.

Is this reasonable or, as I expect, a bug?

I would like to post this as a bug (I didn't see anything similar in LaunchPad), but I don't want to burden the devs if this is somehow expected behavior.

P.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Pathway
Solved:
2019-11-05
Last query:
2019-11-05
Last reply:
2019-11-05

If you press CTRL + ALT + F2 in the installer you should be able to run the fdisk command to detect the drive. Does this help?

How does the disk connect to the system? Is it a separate controller card etc?

Pathway (pathway) said : #3

Hi there.

As I wrote above, I did drop to a shell and ran fdisk -l. The disk does indeed show up.

The disk is connected directly to the motherboard, no additional controller cards or anything.

Sounds like its not coming up before the installer gets loaded.

Do you have the latest BIOS

Pathway (pathway) said : #5

I am not certain. I think so, but I will be in a position to verify in ~6-7 hrs.

My focus however is on the fact that the Desktop installer sees it and proceeds without any issues. Shouldn't there be a common code-base for this sort of thing between the different versions? Or at least a code-base with common requirements?

You could report a bug. I'm glad you have a workaround though

Pathway (pathway) said : #7

Yeah, thanks, no issue for me, I'm already working. This was just for the benefit of the community. If you think it does look like a bug, I'll go ahead and submit one against the debian-installer package, as instructed here: https://launchpad.net/~ubuntu-installer