how to resolve libssl1.1 breaks isync?

Asked by David Robert Lewis on 2019-10-08

The following packages have unmet dependencies:
 libssl1.1 : Breaks: isync (< 1.3.0-2) but 1.3.0-1ubuntu0.18.04.0 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

on Ubuntu 18.04

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes ease provide the output of the commands

uname -a
lsb_release -crid
apt-cache policy libssl1.1 isync

uname -a
Linux afropunk 5.3.0-050300-generic #201909152230 SMP Sun Sep 15 22:32:54 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

apt-cache policy libssl1.1 isync
  Version table: 500
        500 bionic/main amd64 Packages 500
        500 bionic/main amd64 Packages
 *** 100
        100 /var/lib/dpkg/status
     1.1.1-1ubuntu2.1~18.04.4 500
        500 bionic-updates/main amd64 Packages
        500 bionic-security/main amd64 Packages
     1.1.0g-2ubuntu4 500
        500 bionic/main amd64 Packages
  Installed: (none)
  Candidate: 1.3.0-1ubuntu0.18.04.0
  Version table:
     1.3.0-1ubuntu0.18.04.0 500
        500 bionic-updates/universe amd64 Packages
     1.3.0-1build1 500
        500 bionic/universe amd64 Packages

Manfred Hampl (m-hampl) said : #3

You are using a version of libssl1.1 from a PPA, and this version apparently cannot be installed on Ubuntu systems with isync from the Ubuntu repositories.
This is outside the responsibility of Ubuntu. I suggest that you contact the provider of that PPA, or report it on his issue tracker

Can you help with this problem?

Provide an answer of your own, or ask David Robert Lewis for more information if necessary.

To post a message you must log in.