Unable to watch videos in Adobe Flash Player

Asked by peter ratcliffe on 2019-09-29

Trying to watch video clips such as catch up on all4. Click on the play arrow to start the clip and get message needs Adobe Flash Player, download now after selecting linnux, I'm on ubuntu 18.04. Message says this link needs to be opened with an application, followed by a new screen which says Send to aptURL. Where do I go from here?

Regards and thanks from Peter Ratcliffe

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-10-01
Last query:
2019-10-01
Last reply:
2019-10-01

What browser(s) have you tried?

peter ratcliffe (pjcr) said : #2

Only Firefox Web Browser, which is the default.
Thanks for your help.

Do other browsers work OK? Being the default browser doesn't mean much. The default browser doesn't mean much.

Manfred Hampl (m-hampl) said : #4

What do get if you open the following page with your web browser:

https://get.adobe.com/flashplayer/about/

What do you see in the small box to the right of the first two text paragraphs?

peter ratcliffe (pjcr) said : #5

Actionpartnership asked about other browsers. I will look at those later.
To answer Manfred Hampl;
When I click on the Firefox icon followed by copying "https://get.adobe.com/flashplayer/about/" I get a colored picture. To the right of this is a box (menu?) as follows;

Product information
    Features
    Security and privacy
    Statistics
    Player licensing
Support
    Settings Manager
    Flash Player Support Center
FLASH-POWERED CONTENT
    Site of the Day
    Showcase
    Games
    Animation

The two paragraphs on the left are

Adobe Flash Player is the standard for delivering high-impact, rich Web content. Designs, animation, and application user interfaces are deployed immediately across all browsers and platforms, attracting and engaging users with a rich Web experience.

The table below contains the latest Flash Player version information. Adobe recommends that all Flash Player users upgrade to the most recent version of the player through the Player Download Center to take advantage of security updates

Hope this is what you needed. From Peter Ratcliffe

Manfred Hampl (m-hampl) said : #6

There should be a small rectangle - either with a picture or with text - between these two text paragraphs and the menu on the right rim.
In this picture https://img.gadgethacks.com/img/83/29/63531429170586/0/install-adobe-flash-player-your-nexus-7-running-android-4-4-kitkat.w1456.jpg it has a text "Version Information - You have version ...".

What do you see on your system?

peter ratcliffe (pjcr) said : #7

There is a small rectangle which reads

Version Information
You have version
11,1,115,81 installed

Is this what you are looking for?
from Peter Ratcliffe

Manfred Hampl (m-hampl) said : #8

Yes, this is the information I was looking for.
It shows that you have a completely outdated version of the flash plugin installed on your system, because the current version is 32,0,0,255

What is the output of the command

dpkg -l | grep flash

peter ratcliffe (pjcr) said : #9

petercarey@querky:~$ dpkg -l | grep flash
ii pepperflashplugin-nonfree 1.8.3+nmu1ubuntu1 amd64 Pepper Flash Player - browser plugin
petercarey@querky:~$

Is this what you need Peter Ratcliffe

Manfred Hampl (m-hampl) said : #10

Try the following command

sudo apt install flashplugin-installer

After that restart Firefox and visit https://get.adobe.com/flashplayer/about/ again.
What does the box now show?

peter ratcliffe (pjcr) said : #11

The install command sudo apt install flashplugin-installer seemed to work ok and was followed by

petercarey@querky:~$ https://get.adobe.com/flashplayer/about/
bash: https://get.adobe.com/flashplayer/about/: No such file or directory
petercarey@querky:~$

After that I couldn't find anything that made sense. I do get "no such file or directory" quite a lot when looking for files; is it possible there is a fault in the computer?

Look forward to you response, Peter Ratcliffe

Best Manfred Hampl (m-hampl) said : #12

You shold not enter https://get.adobe.com/flashplayer/about/ as command in a terminal window, but visit that address with your web browser - either by clicking it inside the web browser or by copy/pasting it into the address bar of your web browser.

peter ratcliffe (pjcr) said : #13

Thanks Manfred Hampl, that solved my question.