ubuntu 18.04, boot does not continue after gnome display manager started, enters loop, lenovo x1 carbon

Asked by Boris Raikhlin on 2019-09-27

Boot process does not continue after "[OK] Started GNOME display manager" (sometimes it happens after another command) and enters reboot loop on this point.
The problem started after last system update on 24 Sep 2019. I cannot boot the system.
Hardware: Lenovo ThinkPad X1 Carbon 5 gen.
The system is upgraded from 16.04 a year ago.

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Solved by:
Boris Raikhlin
Last query:
Last reply:
Manfred Hampl (m-hampl) said : #1

If you interrupt the boot process at the grub prompt and select an older kernel version from the advanced options, does this work?
Or, if an older kernel does not solve the problem, can you boot in recovery mode - root command prompt?

see also https://wiki.ubuntu.com/RecoveryMode

Boris Raikhlin (borisraikhlin) said : #2

Yes, I am in recovery mode,root command prompt. What now?
Thank you for your help.

Manfred Hampl (m-hampl) said : #3

Ok, your problem seems not to be caused by the kernel, but by the desktop display programs.
Can you reboot and try selecting "failsafe graphics" mode from the grub advanced menu?

(Remark: to reboot from root command mode enter the command "sudo reboot now")

Boris Raikhlin (borisraikhlin) said : #4

"failsafeX" mode fails with the error message: fatal server error: (EE) no screens found

Boris Raikhlin (borisraikhlin) said : #5

The file /var/log/Xorg.failsafe.log contains the following strings of type (EE):

VESA(0): V_BIOS address 0x0 out of range
Screens found , but none have a usable configuration.

Fatal server error: no screens found

Thank you,

Do you have the latest BIOS in the system?

Boris Raikhlin (borisraikhlin) said : #7

I think yes, but I'll try to clear it.
I remember the system made a bios update some days before.

I succeeded to boot with one of the previous kernels.
How can I replace the current kernel with a previous one?
What else can I do?

Thank you,

Manfred Hampl (m-hampl) said : #8

If you have found an older kernel that boots correctly, then you can set this as the default in grub
see e.g. https://askubuntu.com/a/1000735

Boris Raikhlin (borisraikhlin) said : #9

With your help I restored the system with the following simple steps:

1) boot into the Recovery mode of my last kernel version;
2) enabled network;
3) proceeded with the normal boot - and the system booted normally;
4) regular "apt update" and "apt upgrade" and reboot.

The system booted good.

Thank you very much, Manfred.