Minecraft won't open in 14.4

Asked by Niels on 2019-09-11

Basically, whenever I tried to open minecraft before, it was always:
Double click on the icon, click play, the loading bar fills up and it would just open minecraft.
now what I do is double click on the icon, click play, and it doesn't load.
I've tried, other applications to open it, won't open.
When I tried loading the game offline, it gave me this message:

Error: Could not find or load main class net.minecraft.client.main.Main

I'm not comfortable enough with computer code to see what's the problem there, so...
what do I do?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-09-14
Last query:
2019-09-14
Last reply:
2019-09-13

How did you install Minecraft? I assume you mean 14.04... As in the Ubuntu version

Manfred Hampl (m-hampl) said : #2

If "14.4" is meant to describe Ubuntu release 14.04 - this release is not supported any more (except for paid security maintenance for selected server packages).

You should consider upgrading to a supported Ubuntu release, e.g. Ubuntu 18.04 LTS in due course.

Niels (mystlight) said : #4

I meant 1.14, sorry, I was not looking at what I was writing.
And it is meant for minecraft itself, I have Ubuntus latest version and everything updated to max, so the problem shouldn't lie there.

I installed minecraft through the website, paid for it, got it set up properly on my computer after almost an hour. It worked fine for a year or so, and then, with the introduce of minecraft 1.14 it started producing problems. At first just system crashes every now and then, until it got so bad that I had 5 crashes within 20 minutes (which is not ideal -_-)
I didn't play for a few weeks and now the game won't start up again. (Some extra backstory that might lead us to the problem)

Best Manfred Hampl (m-hampl) said : #5

How did you install minecraft? With the Minecraft.deb file for Debian/Ubuntu on the minecraft.net web page? Or how else?

Try starting it by entering the command
/usr/bin/minecraft-launcher
in a terminal window. This might provide additional output.

Niels (mystlight) said : #6

Yayy, I did it!
I tried the thing with the terminal window, which gave me a reply like: This file doesn't exist.
So, I went back to the minecraft website, where I changed the download option, and it friggin worked.
Thanks man :)