Missing dependency for recent pychess on ubuntu 19.04

Asked by Dominic Mayers on 2019-09-03

It might be just with my installation, not necessarily a bug. I just installed pychess https://github.com/pychess/pychess/releases/download/1.0.0/python3-pychess_1.0.0-1_all.deb on ubuntu 19.04. The window "Please Wait. Pychess is ... your engines." was hanging. I looked in syslog and could see an error message saying that the readme module was missing. I looked in the python script and removed the statement that required the module and the script did not hang anymore. I manually installed readme and it's fine now.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Dominic Mayers
Solved:
2019-09-03
Last query:
2019-09-03
Last reply:
2019-09-03

I suggest you uninstall it, then run:

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install pychess

It's in the official Ubuntu repository:
https://packages.ubuntu.com/search?keywords=pychess&searchon=names&suite=bionic&section=all

Why are you manually downloading debs?

I had the same problem with the pychess from apt. So I decided to install directly from pychess.

Manfred Hampl (m-hampl) said : #3

If this is a problem in the pychess package from github, then you should report this there - https://github.com/pychess/pychess/issues

I just said that I had the same issue with the official package from Ubuntu, but sure the problem is with the pychess package or with my installation of ubuntu 19.04

Also I first considered to post there https://github.com/pychess/pychess/issues but they suggest to post here instead if I am not sure it is a bug.

If you run:

pychess

From the terminal, is there useful output?

Oups no this is not where I first considered to post my issue. Still they might say that the problem is with my ubuntu installation and they might be right.

If I run pychess now it works fine. I did that when I had the issue but I forgot the returned message. As I said I had useful messages in syslog and I know that it was a missing dependency.