USB disk not recognised on USB3 hub after upgrade

Asked by Keith Bremer on 2019-08-26

I tried to plug in an external USB disk to my USB3 hub but the system did not find it. Strangely, keyboard and mouse connected via the same hub worked correctly. I tried lsusb and that had no entry for the disk and the Disks utility did not show it nor a variety of other CLI commands (df, fdisk -l, dmesg, etc.). Using a USB2 hub, however, allowed the disk to be found and it mounted normally. I suspected the USB3 hub might be damaged so ordered a replacement - using that has had no effect, the disk is still not found.

Eventually I tried rebooting into the previous kernel (4.15.0-55) and the disk reappeared on the system, mounted correctly from the USB3 hub and works fine. My system upgraded to kernel 4.15.0-58 on Aug 6th, about the time this problem first appeared.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Keith Bremer
Solved:
2019-08-27
Last query:
2019-08-27
Last reply:
2019-08-27
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes I suggest doing the following (with the 4.15.0-58 kernel):

With the disk unplugged issue the commands

uname -a
lsb_release -crid
lsusb

plug in the disk and wait half a minute

re-issue the command "lsusb"
and issue the command "dmesg | tail"

what is the full output of these commands?

For comparison you could also do the same with the older kernel.

Hi Manfred,

This is embarrassing, I was getting the information you requested, starting with the older kernel then rebooted into the new kernel and after carefully logging the first bits of console output, plugged in the disk and it mounted! I honestly tried this several times before posing the question and the disk failed to mount in the 4.15.0-58 kernel. As soon as I tried to get the information for you it worked... Ancient computing problem slightly inverted ("it works when I do it alone but as soon as I try to show someone else it fails").

A happy outcome, none-the-less, but thank you very much for your speedy response.

Regards, Keith.