Installing Ubuntu 16 lts and after rebooting laptop cannot find an OS

Asked by larryblueyes1246 on 2019-08-13

I am installing Ubuntu 16.04.6 LTS on my Lenovo Thinkpad from DVD and it installs without an issue.
It reboots and then it cannot find an OS.
I have tried installing another copy next to it and same thing it installs fine, but cannot find the Operating system after it restarts.
No other errors show
It runs fine from dvd
I have tried all the things I could find on the message boards, but nothing helped.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
larryblueyes1246
Solved:
2019-08-16
Last query:
2019-08-16
Last reply:
2019-08-13

Did GRUB install OK? Why did you install 16.04 when 18.04 is out and also LTS? Did you change your BIOS to boot the drive you installed Ubuntu on? Is this a dual boot system?

larryblueyes1246 (larry1246) said : #2

As far as I can tell grub installed fine, I installed 16.04 LTS because it in an older dual core AMD with only 4gb memory and 320 GB HDD. No this is not a dual boot.
Per install instructions bios is set to UEFI only and not legacy or both.

After restarting I get - " Operating System cannot be found"

Thank you,

Larry

Manfred Hampl (m-hampl) said : #3

Very early during the boot process you probably will see on the screen a logo of your computer's manufacturer and a message similar to "press F10 to enter BIOS setup".
You have to press that button to start the BIOS setup. Inside BIOS setup there should be an item named something like "boot device selection" or similar. You have to make sure that the hard disk is listed as one of the allowed boot devices.

larryblueyes1246 (larry1246) said : #4

Yes, that is set in the BIOS, computer works fine if I install Windows 7 or 10 a sees the HDD

Manfred Hampl (m-hampl) said : #5

We need more diagnostic information.
I suggest that you proceed as follows:

Install Ubuntu on the hard disk (already done, but not working)

Reboot the system with the installer DVD, but select the "Try Ubuntu without installing" mode.
Proceed with boot-info as shown in https://help.ubuntu.com/community/Boot-Repair#A2nd_option_:_install_Boot-Repair_in_Ubuntu - just boot-info, and tell us the URL of the resulting log file.

Manfred Hampl (m-hampl) said : #6

A quick question before that:

During installation when grub is configured, which device did you select for the boot loader?

larryblueyes1246 (larry1246) said : #7

I will proceed as requested when I get home and have time to do it.
Thank you.

Thank you,
Larry Bradley

> On Aug 13, 2019, at 9:43 AM, Manfred Hampl <email address hidden> wrote:
>
> Your question #682832 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/682832
>
> Manfred Hampl requested more information:
> A quick question before that:
>
> During installation when grub is configured, which device did you select
> for the boot loader?
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+question/682832
>
> You received this question notification because you asked the question.

larryblueyes1246 (larry1246) said : #8

I have figured out the issue..
The Bios needed upgraded so it would work correctly.
Since the Laptop had been upgraded to Windows 10 from Windows 7 without being upgraded I had to revert it back to Windows 7 upgrade the BIOS and then install Ubuntu