How to testing the newest xkeyboard-config?

Asked by Viktor Kovács on 2019-08-07

I tried test xkeyboard-config 2.27 configured with /usr prefix and xorg symlink.
I run the make, and sudo make install. When I logged out, I could log in. If I simple restarted the Ubuntu 18.10, the graphical interface couldn't to start.
It depends on the "dependencies"? What I should to do?
How could make an installer deb package?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-08-08
Last reply:
2019-08-08
michael (yellupcm-gmail) said : #1

Please read site below.

https://wiki.ubuntu.com/Releases

Notice that Ubuntu 18.10 is EOL. (End Of Life) You need to up grade to supported release, 19.04, or back to 18.04.

I'm Sorry, I wrote wrong version number: I have 18.04.

You can make a deb of your efforts with checkinstall

What does it mean "with checkinstall"

I swear I'm the only person with access to Google

https://help.ubuntu.com/community/CheckInstall

I can override the xkb-data deb package, but nothing changed. If I logged out, I can not log In. After restart graphical ui can not start. Is there any other thing, that doesn't make this affect? I can only recompile older xkb-data, provided by Ubuntu.

Manfred Hampl (m-hampl) said : #7

What do you mean by "I can not log in"? What happens if you try?
What do you mean by "graphical ui can not start"? What exactly happens there?
Are there any error messages shown?

After installation of package named by myself xkb-data, if I try log out and log in, doesn't log in, stays on the login screen after a short flash.
After reboot or start Ubuntu, the kernel module starting process stops on the different phase. ( always stops different modules)
After first reboot or start Ubuntu, stops the kernel module starting process on a non determined phase ( more module can start ), the error message (not determined, which module) "with any system changes.pp link was shut down."

Manfred Hampl (m-hampl) said : #9

In my opinion the boot failures cannot have any relation to updating xkb packages.

If logging in does not work, but throws you back to the login screen, can you open a virtual terminal (e.g. ctrl-alt-F3) and log in in command line mode?

But when I reboot or turn on the Ubuntu, login screen don't appear!
If I try recovery mode resolving package dependencies, it wants to remove a lots of packages. I didn't.

Manfred Hampl (m-hampl) said : #11

The questions now are:
Why are there broken package dependencies?
Which package(s) is/are responsible for that?

(Eventually the command "sudo dpkg --audit" in 'recovery mode' - 'root command prompt' helps identifying the culprit.)

Manfred Hampl (m-hampl) said : #12

And for the question "how to make a deb installer package with the new version?"
see https://stackoverflow.com/a/308961

I am sorry, the dependencies is not the xkb-data's dependencies. These packages depends on previously removed wine.
I made the pkgversion property to 2.27.1

Can you help with this problem?

Provide an answer of your own, or ask Viktor Kovács for more information if necessary.

To post a message you must log in.