Nokia CS-15 not working on Ubuntu 18.04.02 LTS

Asked by Anton on 2019-07-30

Hello!

About 2-3 moths ago Nokia CS-15 has worked fine, but lately I have connected modem and no connection was established.
In this period I have noticed, that ModemManager have had an update.
Today, I can see it via lsusb, I can access it via mmcli, nmcli, I have also a Mobile Broadband option, under Ubuntu settings->Network.
Strange part is that I can't configure new connections via settings->Network, but at least nmcli makes them fine.

there is my system:
$ lsb_release -rd
Description: Ubuntu 18.04.2 LTS
Release: 18.04

modemmanager also can't enter PIN, but I have disabled that via nmcli (or probably that was mmcli) and as for today:
after inserting dongle, it turns on red LED, than green, then blue. This part is ok.
$ sudo vi /var/log/syslog
Jul 30 12:21:04 myPc kernel: [ 4556.315676] usb 1-1: new high-speed USB device number 20 using xhci_hcd
Jul 30 12:21:04 myPc kernel: [ 4556.464694] usb 1-1: New USB device found, idVendor=0421, idProduct=0610, bcdDevice= 0.01
Jul 30 12:21:04 myPc kernel: [ 4556.464702] usb 1-1: New USB device strings: Mfr=2, Product=1, SerialNumber=3
Jul 30 12:21:04 myPc kernel: [ 4556.464706] usb 1-1: Product: Nokia Datacard
Jul 30 12:21:04 myPc kernel: [ 4556.464711] usb 1-1: Manufacturer: Nokia
Jul 30 12:21:04 myPc kernel: [ 4556.464715] usb 1-1: SerialNumber: 0.0.1
Jul 30 12:21:04 myPc kernel: [ 4556.466615] usb-storage 1-1:1.0: USB Mass Storage device detected
Jul 30 12:21:04 myPc kernel: [ 4556.467173] scsi host0: usb-storage 1-1:1.0
Jul 30 12:21:04 myPc mtp-probe: checking bus 1, device 20: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-1"
Jul 30 12:21:04 myPc mtp-probe: bus: 1, device: 20 was not an MTP device
Jul 30 12:21:04 myPc systemd[1]: Starting USB_ModeSwitch_1-1...
Jul 30 12:21:04 myPc usb_modeswitch_dispatcher[5175]: Could not read attribute: No such file or directory
Jul 30 12:21:04 myPc usb_modeswitch_dispatcher[5175]: message repeated 2 times: [ Could not read attribute: No such file or directory]
Jul 30 12:21:04 myPc upowerd[1326]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0
Jul 30 12:21:04 myPc upowerd[1326]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1
Jul 30 12:21:05 myPc kernel: [ 4557.485022] scsi 0:0:0:0: CD-ROM Nokia Datacard CD-ROM 0001 PQ: 0 ANSI: 0
Jul 30 12:21:05 myPc kernel: [ 4557.486239] sr 0:0:0:0: [sr0] scsi3-mmc drive: 0x/0x caddy
Jul 30 12:21:05 myPc kernel: [ 4557.486699] sr 0:0:0:0: Attached scsi CD-ROM sr0
Jul 30 12:21:05 myPc kernel: [ 4557.486947] sr 0:0:0:0: Attached scsi generic sg1 type 5
Jul 30 12:21:05 myPc usb_modeswitch: switch device 0421:0610 on 001/020
Jul 30 12:21:05 myPc kernel: [ 4557.668949] usb 1-1: USB disconnect, device number 20
Jul 30 12:21:05 myPc upowerd[1326]: unhandled action 'unbind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0
Jul 30 12:21:05 myPc upowerd[1326]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0
Jul 30 12:21:05 myPc upowerd[1326]: unhandled action 'unbind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0
Jul 30 12:21:05 myPc upowerd[1326]: unhandled action 'unbind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1
Jul 30 12:21:10 myPc kernel: [ 4562.707748] usb 1-1: new high-speed USB device number 21 using xhci_hcd
Jul 30 12:21:10 myPc kernel: [ 4562.856795] usb 1-1: New USB device found, idVendor=0421, idProduct=0612, bcdDevice= 0.01
Jul 30 12:21:10 myPc kernel: [ 4562.856802] usb 1-1: New USB device strings: Mfr=2, Product=1, SerialNumber=3
Jul 30 12:21:10 myPc kernel: [ 4562.856807] usb 1-1: Product: Nokia Datacard
Jul 30 12:21:10 myPc kernel: [ 4562.856812] usb 1-1: Manufacturer: Nokia
Jul 30 12:21:10 myPc kernel: [ 4562.856816] usb 1-1: SerialNumber: 0.0.1
Jul 30 12:21:10 myPc kernel: [ 4562.860963] cdc_acm 1-1:1.1: ttyACM0: USB ACM device
Jul 30 12:21:10 myPc kernel: [ 4562.861906] cdc_acm 1-1:1.3: ttyACM1: USB ACM device
Jul 30 12:21:10 myPc mtp-probe: checking bus 1, device 21: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-1"
Jul 30 12:21:10 myPc mtp-probe: bus: 1, device: 21 was not an MTP device
Jul 30 12:21:10 myPc snapd[944]: hotplug.go:193: hotplug device add event ignored, enable experimental.hotplug
Jul 30 12:21:10 myPc snapd[944]: hotplug.go:193: hotplug device add event ignored, enable experimental.hotplug
Jul 30 12:21:10 myPc upowerd[1326]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.2
Jul 30 12:21:10 myPc upowerd[1326]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.4
Jul 30 12:21:10 myPc upowerd[1326]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.3
Jul 30 12:21:10 myPc upowerd[1326]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.1
Jul 30 12:21:10 myPc upowerd[1326]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1
Jul 30 12:21:11 myPc usb_modeswitch[5175]: usb_modeswitch: switched to 0421:0612 on 1/21
Jul 30 12:21:12 myPc usb_modeswitch_dispatcher[5175]: Unable to open bind list file: No such file or directory
Jul 30 12:21:12 myPc usb_modeswitch[5175]: usb_modeswitch: add device ID 0421:0612 to driver option
Jul 30 12:21:12 myPc usb_modeswitch[5175]: usb_modeswitch: please report the device ID to the Linux USB developers!
Jul 30 12:21:13 myPc ModemManager[886]: <info> [device /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1] creating modem with plugin 'Nokia (Icera)' and '2' ports
Jul 30 12:21:13 myPc ModemManager[886]: <info> Modem for device '/sys/devices/pci0000:00/0000:00:14.0/usb1/1-1' successfully created
Jul 30 12:21:16 myPc ModemManager[886]: <warn> couldn't load Operator identifier: 'Failed to parse CRSM query result '+CRSM: 103,0''
Jul 30 12:21:17 myPc ModemManager[886]: <warn> couldn't load list of Own Numbers: 'Unknown error'
Jul 30 12:21:18 myPc ModemManager[886]: <warn> couldn't load UE mode of operation for EPS: 'Unknown error'
Jul 30 12:21:18 myPc ModemManager[886]: <info> Modem: state changed (unknown -> disabled)
Jul 30 12:21:18 myPc NetworkManager[934]: <info> [1564478478.2782] device (ttyACM0): state change: unmanaged -> unavailable (reason 'none', sys-iface-state: 'external')
Jul 30 12:21:18 myPc NetworkManager[934]: <info> [1564478478.2784] device (ttyACM0): modem state 'disabled'
Jul 30 12:21:18 myPc NetworkManager[934]: <info> [1564478478.2803] manager: (ttyACM0): new Broadband device (/org/freedesktop/NetworkManager/Devices/10)
Jul 30 12:21:18 myPc gnome-shell[1320]: nma_mobile_providers_database_lookup_cdma_sid: assertion 'sid > 0' failed
Jul 30 12:21:19 myPc systemd[1]: Started USB_ModeSwitch_1-1.
Jul 30 12:22:20 myPc NetworkManager[934]: <info> [1564478540.3815] audit: op="connection-activate" uuid="2cd86d77-7332-4345-b73d-39e3e3950ff5" name="tele2" pid=1320 uid=1000 result="fail" reason="Connection 'tele2' is not available on the device ttyACM0 at this time."

at Jul 30 12:21:04, I have plugged CS-15
at Jul 30 12:21:48, blue led was lit.
at Jul 30 12:22:20, I have pressed "Connect"

$ sudo nmcli dev status
DEVICE TYPE STATE CONNECTION
wlp61s0 wifi connected GG
ttyACM0 gsm unavailable --
enp0s31f6 ethernet unmanaged --
lo loopback unmanaged --

$ sudo mmcli -L
    /org/freedesktop/ModemManager1/Modem/6 [Nokia Corporation] Nokia Internet Stick CS-15

$ sudo mmcli -m 6
  --------------------------
  General | dbus path: /org/freedesktop/ModemManager1/Modem/6
           | device id: 69921856cabebfb5c070cfcc94769e04035ec5b2
  --------------------------
  Hardware | manufacturer: Nokia Corporation
           | model: Nokia Internet Stick CS-15
           | revision: CS-15 R2.6
           | supported: gsm-umts
           | current: gsm-umts
           | equipment id: 356026030668052
  --------------------------
  System | device: /sys/devices/pci0000:00/0000:00:14.0/usb1/1-1
           | drivers: cdc_acm
           | plugin: Nokia (Icera)
           | primary port: ttyACM0
           | ports: ttyACM0 (at), ttyACM1 (at)
  --------------------------
  Status | unlock retries: sim-pin (3), sim-pin2 (3), sim-puk (10), sim-puk2 (10)
           | state: disabled
           | power state: on
           | signal quality: 0% (cached)
  --------------------------
  Modes | supported: allowed: 2g; preferred: none
           | allowed: 3g; preferred: none
           | allowed: 2g, 3g; preferred: 2g
           | allowed: 2g, 3g; preferred: 3g
           | current: allowed: 2g, 3g; preferred: none
  --------------------------
  Bands | supported: egsm, dcs, pcs, g850, utran-1, utran-8, any
           | current: egsm, dcs, pcs, g850, utran-1, utran-8
  --------------------------
  IP | supported: ipv4
  --------------------------
  3GPP | imei: 356026030668052
  --------------------------
  SIM | dbus path: /org/freedesktop/ModemManager1/SIM/6

$ sudo mmcli -i 6
  ---------------------------
  General | dbus path: /org/freedesktop/ModemManager1/SIM/6
  ---------------------------
  Properties | imsi: 247021001813135
             | iccid: 89371026210003562612
             | operator name: LV TELE2

I have also tried to downgrade ModeManager, but this did not help.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-08-01
Last reply:
2019-08-17

Have you tried rebooting your phone?

Anton (anton-jakimovic) said : #2

Well this is not a phone, this is Nokia 3G USB modem CS-15 (you can easily google it as "Nokia CS-15"), and yes, I have tried to plug it in/out a lot of times, I have also rebooted my PC...

I mean power the phone off and on again, not plane mode. Hold the power button then select the power off option. Then use the power button again to boot the phone

Anton (anton-jakimovic) said : #4

Again, there is no phone involved. Please check google images "Nokia CS-15".

Oh it's a 3G stick

It's the old usb_modeswitch because installing drivers is too hard for Windows users

Try this
https://www.linuxquestions.org/questions/linux-wireless-networking-41/nokia-cs-15-not-functioning-under-ubuntu-12-04-a-4175491151/

Anton (anton-jakimovic) said : #7

Yes, I have tried this, moreover, issue described on the link is with switching between CD-ROM mode (ID 0421:0610) and 3G stick mode (ID 0421:0612).
In my case this part is working automatically, you can see it on the log:
 Jul 30 12:21:05 myPc usb_modeswitch: switch device 0421:0610 on 001/020
...
 Jul 30 12:21:11 myPc usb_modeswitch[5175]: usb_modeswitch: switched to 0421:0612 on 1/21

first problem occurs on
 Jul 30 12:21:16 myPc ModemManager[886]: <warn> couldn't load Operator identifier: 'Failed to parse CRSM query result '+CRSM: 103,0''

I could not google similar problems, so can't really figure out, why it is happening.

usb_modeswitch -v 0x0421 -p 0x0610 -P 0x0612 -M "5553424312345678000000000000061b000000020000000000000000000000"

Does that help?

Did you try ejecting the storage drive using Naultilus (The default file manager in Ubuntu)?

Anton (anton-jakimovic) said : #10

$ usb_modeswitch -v 0x0421 -p 0x0610 -P 0x0612 -M "5553424312345678000000000000061b000000020000000000000000000000"
Look for default devices ...
 No devices in default mode found. Nothing to do. Bye!

So no, it does not help. If I get it right, this command switches modem from storage mode (0x0610) to modem mode (0x0612) and in post #7 I have written where it is switched successfully by usb_modeswitch.

>Did you try ejecting the storage drive using Naultilus (The default file manager in Ubuntu)?
and no I can't see any USB storage and this confirms, that Nokia CS-15 is switched.

I have tested Nokia CS-15 on ubuntu 18.04 startup-disc, works perfectly. I have also tested Huawei E3371 modem with same SIM on my PC - also connects to mobile network. On startup disc, modemmanager has version "1.6.2ubuntu1", but on PC it is already upgraded to "1.10.0-1~ubuntu18.04.02".

I have also tested
* uninstalling modemmanager "1.10.0-1~ubuntu18.04.02"
* forcing version to "1.6.2ubuntu1"
* installing it via Synaptic
but in that case MobileNetwork is not appearing in system settings, when Nokia CS-15 is plugged in, so I have returned back to "1.10.0-1~ubuntu18.04.02".

Manfred Hampl (m-hampl) said : #11

If you think that downgrading modemmanager to version 1.6.2ubuntu1 might help, then you probably would have to downgrade also other packages like libmm-glib0, if they are installed.

I suggest that you check with the command
dpkg -l | grep 1.10.0-1~ubuntu18.04.2
to see which packages have been installed together with modemmanager.

Manfred Hampl (m-hampl) said : #12

Nokia CS-15 is mentioned in a bug report https://gitlab.freedesktop.org/mobile-broadband/ModemManager/issues/68 with a discussion whether the device ID should be switched from 0610 to 0612 or to 0611.

Anton (anton-jakimovic) said : #13

> I suggest that you check with the command
> dpkg -l | grep 1.10.0-1~ubuntu18.04.2

Yes, there is only modemmanager and libmm-glib0. Downgrading libmm-glib0 is a bit scary, because this requires to uninstall (and probably downgrade) about 15 other packages. Scary this is because this can lead to downgrade ubuntu 18.04.02 to 18.04, at the end.

Moreover I have tested Nokia CS-15 on my other PC, with same ubuntu 18.04.02 and same versions for modemmanager and libmm-glib0 and... it worked!

this mean, that issue is somewhere else.

and there is log of working system:

Jul 31 22:39:10 HomePC kernel: [28560.736459] usb 2-1.8: Product: Nokia Datacard
Jul 31 22:39:10 HomePC kernel: [28560.736460] usb 2-1.8: Manufacturer: Nokia
Jul 31 22:39:10 HomePC kernel: [28560.736460] usb 2-1.8: SerialNumber: 0.0.1
Jul 31 22:39:10 HomePC kernel: [28560.737289] cdc_acm 2-1.8:1.1: ttyACM0: USB ACM device
Jul 31 22:39:10 HomePC kernel: [28560.737904] cdc_acm 2-1.8:1.3: ttyACM1: USB ACM device
Jul 31 22:39:10 HomePC mtp-probe: checking bus 2, device 14: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8"
Jul 31 22:39:10 HomePC mtp-probe: bus: 2, device: 14 was not an MTP device
Jul 31 22:39:10 HomePC snapd[1170]: hotplug.go:193: hotplug device add event ignored, enable experimental.hotplug
Jul 31 22:39:10 HomePC snapd[1170]: hotplug.go:193: hotplug device add event ignored, enable experimental.hotplug
Jul 31 22:39:10 HomePC upowerd[1482]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8/2-1.8:1.4
Jul 31 22:39:10 HomePC upowerd[1482]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8/2-1.8:1.2
Jul 31 22:39:10 HomePC upowerd[1482]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8/2-1.8:1.1
Jul 31 22:39:10 HomePC upowerd[1482]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8/2-1.8:1.3
Jul 31 22:39:10 HomePC upowerd[1482]: unhandled action 'bind' on /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8
Jul 31 22:39:11 HomePC usb_modeswitch[17344]: usb_modeswitch: switched to 0421:0612 on 2/14
Jul 31 22:39:12 HomePC usb_modeswitch_dispatcher[17344]: Unable to open bind list file: No such file or directory
Jul 31 22:39:12 HomePC usb_modeswitch[17344]: usb_modeswitch: add device ID 0421:0612 to driver option
Jul 31 22:39:12 HomePC usb_modeswitch[17344]: usb_modeswitch: please report the device ID to the Linux USB developers!
Jul 31 22:39:14 HomePC ModemManager[1121]: <info> [device /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8] creating modem with plugin 'Nokia (Icera)' and '2' ports
Jul 31 22:39:14 HomePC ModemManager[1121]: <info> Modem for device '/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8' successfully created
Jul 31 22:39:16 HomePC ModemManager[1121]: <warn> couldn't load Operator identifier: 'Failed to parse CRSM query result '+CRSM: 103,0''
Jul 31 22:39:17 HomePC ModemManager[1121]: <warn> couldn't load list of Own Numbers: 'Unknown error'
Jul 31 22:39:17 HomePC ModemManager[1121]: <warn> couldn't load UE mode of operation for EPS: 'Unknown error'
Jul 31 22:39:18 HomePC ModemManager[1121]: <info> Modem: state changed (unknown -> disabled)
Jul 31 22:39:18 HomePC NetworkManager[1164]: <info> [1564601958.0406] modem["ttyACM0"]: modem state changed, 'disabled' --> 'enabling' (reason: user preference)
Jul 31 22:39:18 HomePC NetworkManager[1164]: <info> [1564601958.0415] manager: (ttyACM0): new Broadband device (/org/freedesktop/NetworkManager/Devices/8)
Jul 31 22:39:18 HomePC NetworkManager[1164]: <info> [1564601958.0417] device (ttyACM0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Jul 31 22:39:18 HomePC NetworkManager[1164]: <info> [1564601958.0419] device (ttyACM0): modem state 'enabling'
Jul 31 22:39:18 HomePC NetworkManager[1164]: <info> [1564601958.0424] device (ttyACM0): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed')
Jul 31 22:39:18 HomePC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: state changed (disabled -> enabling)
Jul 31 22:39:18 HomePC gnome-shell[1476]: nma_mobile_providers_database_lookup_cdma_sid: assertion 'sid > 0' failed
Jul 31 22:39:18 HomePC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: 3GPP Registration state changed (unknown -> searching)
Jul 31 22:39:18 HomePC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: state changed (enabling -> searching)
Jul 31 22:39:18 HomePC NetworkManager[1164]: <info> [1564601958.6508] modem["ttyACM0"]: modem state changed, 'enabling' --> 'searching' (reason: user-requested)
Jul 31 22:39:19 HomePC systemd[1]: Started USB_ModeSwitch_2-1.8.
Jul 31 22:40:11 HomePC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: 3GPP Registration state changed (searching -> registering)
Jul 31 22:40:11 HomePC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: 3GPP Registration state changed (registering -> home)
Jul 31 22:40:11 HomePC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: state changed (searching -> registered)
Jul 31 22:40:11 HomePC NetworkManager[1164]: <info> [1564602011.3549] modem["ttyACM0"]: modem state changed, 'searching' --> 'registered' (reason: unknown)
Jul 31 22:40:16 HomePC ModemManager[1121]: <warn> Couldn't load network timezone from the current network
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.3687] device (ttyACM0): Activation: starting connection 'Tele2 Mobile Internet' (fbdc6516-e0c5-49d1-bf41-4423c57a022a)
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.3689] audit: op="connection-activate" uuid="fbdc6516-e0c5-49d1-bf41-4423c57a022a" name="Tele2 Mobile Internet" pid=1476 uid=1000 result="success"
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.3693] device (ttyACM0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.3696] manager: NetworkManager state is now CONNECTING
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.3702] device (ttyACM0): state change: prepare -> need-auth (reason 'none', sys-iface-state: 'managed')
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.3724] device (ttyACM0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Jul 31 22:41:12 HomePC ModemManager[1121]: <info> Simple connect started...
Jul 31 22:41:12 HomePC ModemManager[1121]: <info> Simple connect state (4/8): Wait to get fully enabled
Jul 31 22:41:12 HomePC ModemManager[1121]: <info> Simple connect state (5/8): Register
Jul 31 22:41:12 HomePC ModemManager[1121]: <info> Simple connect state (6/8): Bearer
Jul 31 22:41:12 HomePC ModemManager[1121]: <info> Simple connect state (7/8): Connect
Jul 31 22:41:12 HomePC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: state changed (registered -> connecting)
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.3760] modem["ttyACM0"]: modem state changed, 'registered' --> 'connecting' (reason: user-requested)
Jul 31 22:41:12 HomePC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: state changed (connecting -> connected)
Jul 31 22:41:12 HomePC ModemManager[1121]: <info> Simple connect state (8/8): All done
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.4031] modem["ttyACM0"]: modem state changed, 'connecting' --> 'connected' (reason: user-requested)
Jul 31 22:41:12 HomePC NetworkManager[1164]: <warn> [1564602072.4054] device (ttyACM0): ip-ifname: set ifname 'ttyACM0', unknown ifindex
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.4056] device (ttyACM0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.4058] device (ttyACM0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
Jul 31 22:41:12 HomePC NetworkManager[1164]: <warn> [1564602072.4059] device (ttyACM0): interface ttyACM0 not up for IP configuration
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.4059] modem["ttyACM0"]: using modem-specified IP timeout: 20 seconds
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.4061] ppp-manager: starting PPP connection
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.4071] ppp-manager: pppd started with pid 17435
Jul 31 22:41:12 HomePC pppd[17435]: Plugin /usr/lib/pppd/2.4.7/nm-pppd-plugin.so loaded.
Jul 31 22:41:12 HomePC NetworkManager[1164]: Plugin /usr/lib/pppd/2.4.7/nm-pppd-plugin.so loaded.
Jul 31 22:41:12 HomePC pppd[17435]: nm-ppp-plugin: (plugin_init): initializing
Jul 31 22:41:12 HomePC pppd[17435]: pppd 2.4.7 started by root, uid 0
Jul 31 22:41:12 HomePC pppd[17435]: nm-ppp-plugin: (nm_phasechange): status 3 / phase 'serial connection'
Jul 31 22:41:12 HomePC pppd[17435]: Using interface ppp0
Jul 31 22:41:12 HomePC NetworkManager[1164]: Using interface ppp0
Jul 31 22:41:12 HomePC NetworkManager[1164]: Connect: ppp0 <--> /dev/ttyACM0
Jul 31 22:41:12 HomePC pppd[17435]: nm-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
Jul 31 22:41:12 HomePC pppd[17435]: Connect: ppp0 <--> /dev/ttyACM0
Jul 31 22:41:12 HomePC pppd[17435]: nm-ppp-plugin: (nm_phasechange): status 6 / phase 'authenticate'
Jul 31 22:41:12 HomePC pppd[17435]: nm-ppp-plugin: (get_credentials): passwd-hook, requesting credentials...
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.4142] manager: (ppp0): new Ppp device (/org/freedesktop/NetworkManager/Devices/9)
Jul 31 22:41:12 HomePC systemd-udevd[17438]: link_config: autonegotiation is unset or enabled, the speed and duplex are not writable.
Jul 31 22:41:12 HomePC pppd[17435]: nm-ppp-plugin: (get_credentials): got credentials from NetworkManager
Jul 31 22:41:12 HomePC pppd[17435]: Remote message: TTP Com PPP - Password Verified OK
Jul 31 22:41:12 HomePC NetworkManager[1164]: Remote message: TTP Com PPP - Password Verified OK
Jul 31 22:41:12 HomePC NetworkManager[1164]: PAP authentication succeeded
Jul 31 22:41:12 HomePC pppd[17435]: nm-ppp-plugin: (nm_phasechange): status 8 / phase 'network'
Jul 31 22:41:12 HomePC pppd[17435]: PAP authentication succeeded
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.4215] devices added (path: /sys/devices/virtual/net/ppp0, iface: ppp0)
Jul 31 22:41:12 HomePC NetworkManager[1164]: <info> [1564602072.4216] device added (path: /sys/devices/virtual/net/ppp0, iface: ppp0): no ifupdown configuration found.
Jul 31 22:41:13 HomePC pppd[17435]: local IP address 90.128.47.250
Jul 31 22:41:13 HomePC pppd[17435]: nm-ppp-plugin: (nm_phasechange): status 9 / phase 'running'
Jul 31 22:41:13 HomePC NetworkManager[1164]: local IP address 90.128.47.250
Jul 31 22:41:13 HomePC NetworkManager[1164]: remote IP address 10.0.0.1
Jul 31 22:41:13 HomePC NetworkManager[1164]: primary DNS address 193.12.150.98
Jul 31 22:41:13 HomePC NetworkManager[1164]: secondary DNS address 212.247.152.98
Jul 31 22:41:13 HomePC pppd[17435]: remote IP address 10.0.0.1
Jul 31 22:41:13 HomePC pppd[17435]: nm-ppp-plugin: (nm_ip_up): ip-up event
Jul 31 22:41:13 HomePC pppd[17435]: primary DNS address 193.12.150.98
Jul 31 22:41:13 HomePC pppd[17435]: nm-ppp-plugin: (nm_ip_up): sending IPv4 config to NetworkManager...
Jul 31 22:41:13 HomePC pppd[17435]: secondary DNS address 212.247.152.98
Jul 31 22:41:13 HomePC NetworkManager[1164]: <info> [1564602073.8428] device (ppp0): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
Jul 31 22:41:13 HomePC NetworkManager[1164]: <info> [1564602073.8445] ppp-manager: (IPv4 Config Get) reply received.
Jul 31 22:41:13 HomePC whoopsie[2014]: [22:41:13] Cannot reach: https://daisy.ubuntu.com
Jul 31 22:41:13 HomePC whoopsie[2014]: [22:41:13] Cannot reach: https://daisy.ubuntu.com
Jul 31 22:41:13 HomePC NetworkManager[1164]: <info> [1564602073.8506] device (ttyACM0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'managed')
Jul 31 22:41:13 HomePC NetworkManager[1164]: <info> [1564602073.8511] device (ppp0): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'external')
Jul 31 22:41:13 HomePC NetworkManager[1164]: <info> [1564602073.8519] device (ttyACM0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'managed')
Jul 31 22:41:13 HomePC NetworkManager[1164]: <info> [1564602073.8522] device (ttyACM0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'managed')
Jul 31 22:41:13 HomePC NetworkManager[1164]: <info> [1564602073.8524] manager: NetworkManager state is now CONNECTED_LOCAL
Jul 31 22:41:13 HomePC NetworkManager[1164]: <info> [1564602073.8551] manager: NetworkManager state is now CONNECTED_SITE
Jul 31 22:41:13 HomePC NetworkManager[1164]: <info> [1564602073.8552] policy: set 'Tele2 Mobile Internet' (ppp0) as default for IPv4 routing and DNS
Jul 31 22:41:13 HomePC NetworkManager[1164]: <info> [1564602073.8555] device (ttyACM0): Activation: successful, device activated.
Jul 31 22:41:13 HomePC dbus-daemon[1153]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service' requested by ':1.12' (uid=0 pid=1164 comm="/usr/sbin/NetworkManager --no-daemon " label="unconfined")
Jul 31 22:41:13 HomePC gsd-sharing[1652]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit gnome-user-share-webdav.service not loaded.
Jul 31 22:41:13 HomePC systemd[1]: Starting Network Manager Script Dispatcher Service...
Jul 31 22:41:13 HomePC gsd-sharing[1652]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit rygel.service not loaded.
Jul 31 22:41:13 HomePC gsd-sharing[1652]: Failed to StopUnit service: GDBus.Error:org.freedesktop.systemd1.NoSuchUnit: Unit gnome-remote-desktop.service not loaded.
Jul 31 22:41:13 HomePC dbus-daemon[1153]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
Jul 31 22:41:13 HomePC systemd[1]: Started Network Manager Script Dispatcher Service.
Jul 31 22:41:13 HomePC nm-dispatcher: req:1 'up' [ppp0]: new request (1 scripts)
Jul 31 22:41:13 HomePC nm-dispatcher: req:1 'up' [ppp0]: start running ordered scripts...
Jul 31 22:41:14 HomePC systemd-resolved[978]: Server returned error NXDOMAIN, mitigating potential DNS violation DVE-2018-0001, retrying transaction with reduced feature level UDP.
Jul 31 22:41:14 HomePC NetworkManager[1164]: <info> [1564602074.9538] manager: NetworkManager state is now CONNECTED_GLOBAL
Jul 31 22:41:14 HomePC nm-dispatcher: req:2 'connectivity-change': new request (1 scripts)
Jul 31 22:41:14 HomePC nm-dispatcher: req:2 'connectivity-change': start running ordered scripts...
Jul 31 22:41:14 HomePC whoopsie[2014]: [22:41:14] The default IPv4 route is: /org/freedesktop/NetworkManager/ActiveConnection/4
Jul 31 22:41:14 HomePC whoopsie[2014]: [22:41:14] Network connection may be a paid data plan: /org/freedesktop/NetworkManager/Devices/8

and I have found difference here:
On "myPc":
Jul 30 12:21:18 myPc NetworkManager[934]: <info> [1564478478.2782] device (ttyACM0): state change: unmanaged -> unavailable (reason 'none', sys-iface-state: 'external')
Jul 30 12:21:18 myPc NetworkManager[934]: <info> [1564478478.2784] device (ttyACM0): modem state 'disabled'
Jul 30 12:21:18 myPc NetworkManager[934]: <info> [1564478478.2803] manager: (ttyACM0): new Broadband device (/org/freedesktop/NetworkManager/Devices/10)
Jul 30 12:21:18 myPc gnome-shell[1320]: nma_mobile_providers_database_lookup_cdma_sid: assertion 'sid > 0' failed
Jul 30 12:21:19 myPc systemd[1]: Started USB_ModeSwitch_1-1.

on "HomePC":
Jul 31 22:39:18 AntonPC NetworkManager[1164]: <info> [1564601958.0406] modem["ttyACM0"]: modem state changed, 'disabled' --> 'enabling' (reason: user preference)
Jul 31 22:39:18 AntonPC NetworkManager[1164]: <info> [1564601958.0415] manager: (ttyACM0): new Broadband device (/org/freedesktop/NetworkManager/Devices/8)
Jul 31 22:39:18 AntonPC NetworkManager[1164]: <info> [1564601958.0417] device (ttyACM0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Jul 31 22:39:18 AntonPC NetworkManager[1164]: <info> [1564601958.0419] device (ttyACM0): modem state 'enabling'
Jul 31 22:39:18 AntonPC NetworkManager[1164]: <info> [1564601958.0424] device (ttyACM0): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed')
Jul 31 22:39:18 AntonPC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: state changed (disabled -> enabling)
Jul 31 22:39:18 AntonPC gnome-shell[1476]: nma_mobile_providers_database_lookup_cdma_sid: assertion 'sid > 0' failed
Jul 31 22:39:18 AntonPC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: 3GPP Registration state changed (unknown -> searching)
Jul 31 22:39:18 AntonPC ModemManager[1121]: <info> Modem /org/freedesktop/ModemManager1/Modem/3: state changed (enabling -> searching)
Jul 31 22:39:18 AntonPC NetworkManager[1164]: <info> [1564601958.6508] modem["ttyACM0"]: modem state changed, 'enabling' --> 'searching' (reason: user-requested)
Jul 31 22:39:19 AntonPC systemd[1]: Started USB_ModeSwitch_2-1.8.

Before that everything looks similar, to me...

> Nokia CS-15 is mentioned in a bug report https://gitlab.freedesktop.org/mobile-broadband/ModemManager/issues/68 with a discussion whether the device ID should be switched from 0610 to 0612 or to 0611.
Ok, didn't knew that, but lsusb gives 0612, before connection and on the log of "myPc" there is modeswitch to 0612, so this looks ok.

Launchpad Janitor (janitor) said : #14

This question was expired because it remained in the 'Open' state without activity for the last 15 days.