Blacklisted modules without hotplug

Asked by Ricardo Pérez López on 2006-04-06

Now in Dapper there's no hotplug. Earlier, I used /etc/hotplug/blacklist.d/ directory to force not to load several modules, but now that method doesn't works.

What can I use now to get the same feature?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2006-04-06
Last reply:
2006-04-06
Dennis Kaarsemaker (dennis) said : #1

echo 'blacklist broken_module_name_here' | sudo tee -a /etc/modprobe.d/my_blacklist

(The name my_blacklist is arbitrary, just don't use 'blacklist' or any
existing file so your changes won't be lost on upgrade)

Ok, thank you very much!

By the way: I see there's a file called lm-sensors into /etc/hotplug/blacklist.d/. Doing

ricardo@yuggoth $ dpkg -S /etc/hotplug/blacklist.d/lm-sensors

lm-sensors: /etc/hotplug/blacklist.d/lm-sensors

May I report a bug against lm-sensors package for using the (now obsolete) hotplug?

Dennis Kaarsemaker (dennis) said : #3

Yes, please do so.

Ok, done :) It's Bug #38385.

Thanks a lot, and feel free to close this ticket.

Dennis Kaarsemaker (dennis) said : #5

I can't - you should do so yourself :)

Oh, sorry :)

Emmm... how? Sorry, I can't find the "Close" button...

Dennis Kaarsemaker (dennis) said : #8

Some of tht link to the left (edit request etc...) should help. If you
can't find it: just leave it open. I should file a bug about this
against launchpad :)

Sorry to post you again, but the solution proposed doesn't works for me.

My intention is to disable pc speaker. I've created the
file /etc/modprobe.d/pcspkr with the following content:

blacklist pcspkr

That's all. But after startup I can see the module is loaded.

Maybe I did something wrong?

Thanks a lot.

P.S.: I tried to post it in the ticket, but I got an error message
("Constraint not satisfied") :/

El jue, 06-04-2006 a las 11:09 +0000, Dennis Kaarsemaker escribió:
> Support request #681 on Ubuntu changed:
> https://launchpad.net/distros/ubuntu/+ticket/681
>
> Comment:
> Some of tht link to the left (edit request etc...) should help. If you
> can't find it: just leave it open. I should file a bug about this
> against launchpad :)
>

Dennis Kaarsemaker (dennis) said : #10

Hmm, then something else is loading it... Why do you want to blackist
it?

Because I hate the bip! :) Where can be the problem?

El jue, 06-04-2006 a las 16:21 +0000, Dennis Kaarsemaker escribió:
> Support request #681 on Ubuntu changed:
> https://launchpad.net/distros/ubuntu/+ticket/681
>
> Comment:
> Hmm, then something else is loading it... Why do you want to blackist
> it?

Because I hate the bip! :) Where can be the problem?

Can you help with this problem?

Provide an answer of your own, or ask Ricardo Pérez López for more information if necessary.

To post a message you must log in.