Jaunty's today updates make compiz abort startup

Asked by Pablo Marchant on 2009-04-20

Ive been using Jaunty with compiz for a while, but after I updated my computer today and reestarted, compiz refused to start, saying it was not possible to enable desktop effects (this, through the appearence menu).

Since I hate a compiz-less desktop (metacity alone is no good for me...) I tried to run manually compiz using "compiz --replace". What I got was this:

compiz --replace
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Blacklisted PCIID '8086:2a02' found
aborting and using fallback: /usr/bin/metacity

So, I guessed the new updates included a blacklisting for my video card, an intel Mobile GM965/GL960 Integrated Graphics Controller. I fix this by creating the file ~/.config/compiz/compiz-manager with the content "SKIP_CHECKS=yes" so now compiz --replace outputs this:

compiz --replace
Checking for Xgl: not present.
xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log
Blacklisted PCIID '8086:2a02' found
SKIP_CHECKS is yes, so continuing despite problems.
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Checking screen 1Comparing resolution (1280x800) to maximum 3D texture size (2048): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
Starting gtk-window-decorator

So my question is...Why all of a sudden is my card blacklisted???? It has worked just perfectly for over a month with Jaunty

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Steve
Solved:
2009-04-20
Last query:
2009-04-20
Last reply:
2009-04-20

The package was probably updated to a new version that includes the newer blacklist. The blacklist is from upstream and is at http://wiki.compiz-fusion.org/Hardware/Blacklist

Essentially you were bound to get the error at some time or another, just had to get the update.

Craig Huffstetler (xq) said : #2

Pablo,

You may want to file a bug report on this against compiz. This is good to know for the upcoming release of Jaunty. Please let us know (or link the bug yourself) to this Question/"Answer." This actually looks like a regression for Intel cards that existed back in the early days of Intrepid Alpha...

Hopefully it will be fixed within the next few updates.

I'm sorry to hear you are having problems.

Craig

P.S. - One thing you can try that *may* work:

This is NOT a definitive solution, as you should file a bug, but please see post #8:

http://ubuntuforums.org/showthread.php?t=609295

Pablo Marchant (pamarca) said : #3

Actually Craig, I already found the fix (I explained it on the first post...)

The question I was actually doing was why is this failing...I think this blacklisting is kind of wrong, since according to the link from Steven S, the problem with my card involves XAA acceleration, while the default is EXA (as far as I remember)

Pablo Marchant (pamarca) said : #4

Thanks Steven S, that solved my question.

Craig Huffstetler (xq) said : #5

I'm glad everything is solved.

I understood that from your first post, I just thought "SKIP_CHECKS=yes" would skip the blacklist check altogether. I was under the impression compiz was not starting for you.

The version of compiz included in Ubuntu, before today, should have had the current blacklisted cards...

I looked a bit deeper into this... the behavior is to be expected, and should hopefully only be temporary.

From the compiz package changelog:

compiz (1:0.8.2-0ubuntu8) jaunty; urgency=low

  * debian/patches/028_compiz_manager_blacklist:
    - blacklist GM965 (8086:2a02) until the freeze with the intel
      driver is fixed (LP: #359392)

 -- Michael Vogt <email address hidden> Fri, 17 Apr 2009 19:27:42 +0200

The referenced bug is at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/359392

Pablo Marchant (pamarca) said : #7

Ammm, I got a couple of freezes I remember, but I havent seen them lately so I thought they were gone...Didnt thought there was an active an critical bug for that issue (Thought on reporting it but the freezes were so random and scarce I didnt know what info I could give)

Well if they start happening again it may be worth enabling that blacklist.

Have a good evening!

sharkito (alvaro-diaz) said : #9

Se propone alguna solucion para esto en el futuro..?

Everthon Valadão (valadao) said : #10

I think it is a "conflict situation", because I just run
`gconftool-2 --set --type=bool /apps/metacity/general/compositing_manager false`
and `compiz --replace` worked!

samhassell (samhassell) said : #11

Yeah disabling metacity compositing allows compiz to work for me too.