New PC fails EFI-boot on USB installation xUbuntu-18.04; BIOS boots USB

Asked by Wim on 2019-03-15

New Acer-PC Aspire-T
Intel i5 core processor 8400
internal memory 8 Gb DDR4
250 Gb Solid-State-Disk
2 Tb sata-Disk

# -- new info added below

USB-installation medium several times used: always successful on BIOS-boot.
If the PC boots in BIOS-mode, then the USB-installation can be started, but then the GUID-partitions show up as undefined. This is normal.
If the PC boots in UEFI-mode, then the only boot-choice is to start the Micr$oft Windblows-installation, this is not what we want to happen.

2 questions:
.q1. How do we get this PC to boot in UEFI-mode and start xUbuntu-installation using the USB-stick ? ... without having to do the W-installation first.

.q2. Any suggestions for a clever Partition-set: must we use the Solid-State disk as * boot, * root, * swap ?!?

I assume your answer will look like:
- Solid-State p1: Guid-Efi-Partition (1 Gb fat-32; necessary for UEFI-boot)
- Solid-State p2: root (240 Gb ext4)
- Solid-State p3: swap-Partition (14 Gb swap)
- 2 Tb p1 : home-partition (ext4)

On the web several completely suggestions are found.
None of them worked for UEFI-booting the USB-installation.

We appreciate your time and suggestions!
Wim

# -- some of my tries

USB-stick
new MBR-partition table
new partition: primair, 1.6 Gb , no flags set
formatted FAT32

opened xubuntu-18.04.2 amd64 DVD iso with Archive-Manager
extracted everything to the FAT32-USB-stick
Hard-links do not work on FAT, so manually copied the (source) file to new location.
ISO and USB contains equal quantity of directories and files (so COPY is OK)

sudo fsck.fat -tvV USB-stick : all OK

# --

new PC completely powered down, insert USB-stick (FAT xubuntu-installation)
boot PC, press <Del>-key to enter PC-setup
> CPU and Chipset
  Intel-AES-NI : Enabled ( * also Disabled is tried * )
> Integrated Peripherals
  Sata Controller : Enabled
  Sata Mode : RST with Optane
> Power
  Deep Power Off Mode : Enabled
> Boot
  Launch CSM : Never
  Boot Filter : UEFI
  Boot Priority Order : !!!
*** here the USB can not be selected ***

When (re)booting in Legacy-mode (BIOS, 16 bits) then the USB can be selected

But we want to setup the PC in UEFI-mode, so larger disks ( 2Tb and more ) can be used.

Suggestions are welcome !

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-03-15
Last reply:
2019-03-31
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.