Have do switch from legacy mode to uefi mode to run linux and windows

Asked by Murry Blankenship on 2019-02-07

I made a partition using the other mode and install linux mint in it. restarted linux and it started in legacy mode. But had to change to uefi mode to run windows. Did not give me a grub menu so i could choose what to run. I am running linuxMint 19.1

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-02-07
Last reply:
2019-02-08
Ubfan (ubfan1) said : #1

The install media has bootloaders for both legacy and UEFI, so how it boots determines in what mode the install is done. Select the BIOS/ UEFI settings to boot in UEFI mode, (sounds like you had to do this to boot Windows), backup whatever files you have created on the linux system and reinstall. That should put the grub bootloaders into the /EFI/ubuntu directory on the UEFI partition, and recreate the grub.cfg file to pick up Windows in UEFI mode.

Murry Blankenship (murryb) said : #2

I solved the problem I just install linux next to windows.

Can you help with this problem?

Provide an answer of your own, or ask Murry Blankenship for more information if necessary.

To post a message you must log in.