Ubuntu 18.10 not working after latest updates

Asked by John MacMenigall on 2019-02-07

Machine is Acer-TravelMate-5730, Intel® Core™2 Duo CPU.

Same problem as a previous correspondent except with plain Ubuntu 18.10 - downloaded latest updates and now the system doesn't boot - I get a blank purple! screen but nothing else. I can load the previous kernel version, which I have done to post this, but I am handing the machine over to a non-computer-literate user . . . Actionparsnip's 'nomodeset' solution is a bit brief, please could he (or someone else) expand on it?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
John MacMenigall
Solved:
2019-02-12
Last query:
2019-02-12
Last reply:
2019-02-12
Cody Skinner (wskinner) said : #1

Thank you for taking the time to post this question. Does the purple screen appear before getting to the logon screen, or does it appear after attempting to logon? Are you able to get to a terminal by pressing Ctrl+Alt+F4?

John MacMenigall (fred575) said : #2

Thank you, Cody, for taking the time to respond. I'm sorry but this problem seems to have resolved itself !
I managed to persuade the GRUB menu to display and having selected the version of the kernel I wished to use, on reboot, it selected that version without prompting & all now seems normal - although it would be good to know if this is a one-off aberration or is it likely to reoccur next time there is a kernel update? I have marked this as problem solved and thank you once again for your time.

Cody Skinner (wskinner) said : #3

Thank you for the update John. I am glad the issue seems to be resolved for you. There are several active bug reports about the purple screen during boot, specifically on systems with NVIDIA drivers.

If the issue comes back, please feel free to re-open this question, and we can investigate further.