blueman-manager shows no pin when pairing

Asked by Dave on 2019-02-07

I have a Logitech MX5000 Bluetooth keyboard and a matching mouse.
Pairing the mouse works, but ever since I upgraded to 18.04 I can seem to connect my keyboard anymore.

The keyboard asks for a passkey, but in contrast to previous versions, Ubuntu doesn`t show a pop-up with a passkey for pairing.

How to solve this issue?

Cheers,
Dave

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-02-07
Last reply:
10 hours ago

What version did you upgrade from and what method did you use ?
Have you tried un-pairing both and repairing them ?

Dave (dhenley1) said : #2

I upgraded from 17.10 via the gui.
I have tried un-pairing and removing them several times to see of that helped.
And the mouse isn an issue that works pretty fast, but the keyboard requires a pin and it doesn show anymore.
From what I can recall it not an ordinary pin like 0000 or 1234 but a random 6-digit number, making it hard to guess.
Could it have something to do with using wayland instead of Xorg?

Launchpad Janitor (janitor) said : #3

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.