/etc/profile.d/01-locale-fix.sh line 2 /usr/bin/locale-check no such file or directory

Asked by vishwajeet on 2019-02-04

When I updated the Ubuntu 18.10 and after the restart I start receiving this error :
/etc/profile.d/01-locale-fix.sh line 2 /usr/bin/locale-check no such file or directory
After that I not able to access any file and none of the systems apps are opening like Terminal, system setting nothing. Neither it is connecting to the wi fi. So, update of the system is not possible. Please help.

Thanks for any help in advance.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-02-04
Last reply:
2019-02-22

What is the output of:

lsb_release -a; uname -a; cat -n /etc/profile.d/01-locale-fix.sh

Thanks

vishwajeet (vishwajeetk12) said : #2

How I am suppose to run these commands? Terminal is not opening. I tried Alt+F2 but there is no output. Also, I looked up for the solution where I found that I have to change the content of the locale file i.e. language. And I tried to do so but there is some permission issue now. I haven't been able to open file, setting, or terminal. Most important that I am not able to connect to any internet connection. So, not sure what to do next.

Thanks.

If you boot to an older kernel is it OK? Hold SHIFT at boot to make GRUB show thenuse cursors and ENTER as you expect

vishwajeet (vishwajeetk12) said : #4

No, I also tried that with the recovery mode but there is no change in the system behavior. Thanks

Manfred Hampl (m-hampl) said : #5

What happens if you try booting in recovery mode - root command prompt?
Can you execute the commands there?

Or - can you open a virtual terminal by pressing ctrl-alt-f3 and log in?

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.