Does not login or shutdown when external display is connected

Asked by Juha Simola on 2019-01-30

After a recent update, about on 28th Jan, 2019, there's a problem that desktop is not showing up after login if the external display is connected.
The computer does not shut down either when the external display is connected. Only default dark brown ubuntu color is shown on the laptop display and the computer stays on forever.

When I disconnect the display from dock, login and shutdown work normally.
If I connect the display after login, the desktop is moved there normally and the built-in display is switched off.
If I disconnect the display before the shutdown, the computer shuts down normally.

Ubuntu 18.04 LTS
ThinkPad T480s
ThinkPad USB-C dock
Dell 27" 4k display
Display-cable

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Juha Simola
Solved:
2019-01-31
Last query:
2019-01-31
Last reply:
2019-01-30
billel dallas (kingbily96) said : #1

Ah. In that case, I guess it might be relevant after all. Please add this info to your question and also show the output of sudo service networking status after running sudo service networking stop. Are you mounting anything from a network computer? A samba share perhaps or an NFS drive? Finally, try disconnecting from the internet any way you can and then shutting down. Does it work?
https://appsync.biz/dafont/ https://192168ll.onl/ https://appsync.biz/filehippo/
No, not really. However, I have had similar issues with the shutdown hanging because some service is waiting for a response from the network. It will probably not help but it is easy to test and there is a small chance that it might be relevant

mtd (miehael) said : #2

The problem description matches my recent (today) experience. Usually, I leave laptop docked, case closed and just use the external display. Today, there was a crash involving the display corruption after unlocking the screen lock, so I rebooted. Since then, there are problems involving the external display:
(1) after login (docked mode, external display only), the display does not show. ssh into host still works.
(2) it works ok to start with internal display on, then connect external display (dual displays).
(3) but in this dual mode, if I use the keyboard combination to disable the internal monitor, I get a lockup similar to (1), with the internal display frozen. ssh works.

I have similar hardware to the original report: Lenovo T480; Thinkpad USB-C dock; Dell 4K display, HDMI->DisplayPort cable.

I currently have the Nouveau display driver enabled, but I have tried both nvideo-driver-410 and -415 to no success.

Juha Simola (jm-simola) said : #3

Downgrading to previous Kernel 4.15.0-43-generic fixed the problem.
The problem is with 4.15.0-44-generic

This bug report seems to be from this issue:
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1813738