ubuntu 16.04 crashes and 18.04 is not able to install

Asked by Eric Pieterman on 2019-01-09

I use Ubuntu 16.04 with a Medion Erazer MS-7667 PC .

After about 30 min the system crashes and I have to restart the PC.

Inside a Intel® Core™ i7-2700K CPU @ 3.50GHz × 8 and llvmpipe (LLVM 6.0, 256 bits) graphics.

I tried to install Ubuntu 18.04. Installation seems fine, but the PC will not start up after installation.

What can I do to solve this and install Ubuntu 18.04? Thanks for your help!!

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-01-09
Last reply:
2019-01-10

Does it have the nvidia gpu or is it the Intel video hardware doing the work here please?

Eric Pieterman (ericbeneden) said : #2

Intel hardware I think (?), but don know how to install Nvidia GPU.

Does the installation disk boot OK to the try desktop? If so, run:

sudo lshw -C display

If you only see Intel then it's just Intel. If you see Nvidia then it's the switching GPU setup.

Eric Pieterman (ericbeneden) said : #4

 description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0

Ahh so only Nvidia. Use the boot option:

nouveau.nomodeset=1

https://help.ubuntu.com/community/BootOptions

Don't need to be expert to use a search engine to find things

Eric Pieterman (ericbeneden) said : #8

I see I need to do this in the terminal, but I do not know the command line needed for that

It's not in the terminal. You add it in GRUB before any OS even loads. Read the page

Eric Pieterman (ericbeneden) said : #13

I have put the line in Grub. After update of Grub I get the message in the terminal: /usr/sbin/grub-mkconfig: 13: /etc/default/grub: nouveau.nomodeset=1: not found

I will try to find the page that you menstioned.
Thanks for your help and patience with my problem.

This is my Grub now:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
nouveau.nomodeset=1

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Can you help with this problem?

Provide an answer of your own, or ask Eric Pieterman for more information if necessary.

To post a message you must log in.