Windows installed in uefi mode and Ubuntu in legacy mode

Asked by Karandeep Padam on 2019-01-07

I recently installed Ubuntu on my Lenovo G50 alongside pre-existing windows 10. Both are installed in different modes which makes me go to BIOS setup everytime I wanna boot a different OS. Is there a way I can install Ubuntu on uefi mode?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2019-01-08
Last reply:
2019-01-08
Jeremy (wa113y3s) said : #1

Set BIOS to UEFI only and boot the ISO and install Ubuntu, or use the ISO to install grub-efi-amd64-signed and put the grub in the EFI system partition

Karandeep Padam (lostctrl) said : #2

I would likely do a new install but when it's in UEFI mode it doesn't boots from my bootable USB. Can u help?

Manfred Hampl (m-hampl) said : #3

See https://help.ubuntu.com/community/UEFI#Converting_Ubuntu_into_UEFI_mode for instructions how to convert the Ubuntu legacy installation into UEFI mode with help off boot-repair.

Karandeep Padam (lostctrl) said : #4

I did as it was mentioned in the instructions but it didn't work. There are some things I noticed I would like to mention. In boot-repair, in GRUB location the "Separate /boot/efi partition" line (sda1) was already ticked. On applying it said I am in legacy mode and i need to go to uefi for changes to take effect which is correct but when I changed the boot method in BIOS and saved changes, it booted me in windows 10 without giving options for ubuntu. Should i disable fast boot? Did i miss something? Please help.

Manfred Hampl (m-hampl) said : #5

"Should i disable fast boot?"

It's all written in https://help.ubuntu.com/community/UEFI

Jeremy (wa113y3s) said : #6

Write a new Ubuntu 18.04 ISO to the USB drive using the Startup Disc Creator tool in Ubuntu and see if it will boot in EFI mode

Can you help with this problem?

Provide an answer of your own, or ask Karandeep Padam for more information if necessary.

To post a message you must log in.