how do I download & install synergy 1.8.8 on linux

Asked by Bob on 2019-01-04

Computer 1 updated to 1.8.8 but computer 2 is showing me 1.6?? and if they don't match they don't work.
the synaptic package manner is showing me the old one on computer 2?? How do I get it to catch up?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Bob
Solved:
2019-01-05
Last query:
2019-01-05
Last reply:
2019-01-04
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes please provide the output of the following commands for both computers:

uname -a
lsb_release -crid
apt-cache synergy

Bob (smith13) said : #2

Linux hermann 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
bob@hermann:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic
bob@hermann:~$ apt-cache synergy

computer two
uname -a
Linux rjsmith-desktop 3.13.0-98-generic #145-Ubuntu SMP Sat Oct 8 20:13:07 UTC 2016 i686 athlon i686 GNU/Linux
rjsmith@rjsmith-desktop:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial
rjsmith@rjsmith-desktop:~$ apt-cache synergy

Manfred Hampl (m-hampl) said : #3

Sorry, my fault. The command should have been
apt-cache policy synergy

But the cause of your problem is already visible:
One of your computers is running Ubuntu 16.04 which has synergy 1.6.2, and the other computer is running Ubuntu 18.04 with synergy 1.8.8
see https://launchpad.net/ubuntu/+source/synergy

Bob (smith13) said : #4

I have no clue what to do with that page.

Bob (smith13) said : #5

where is the download? then How do I install it?

Manfred Hampl (m-hampl) said : #6

You need not do anything with that page ( https://launchpad.net/ubuntu/+source/synergy )
It just shows that different Ubuntu releases come with different versions of synergy.

If you want to have the same version of synergy on two computers, then you should care for identical Ubuntu releases on these systems.
Everything else (like installing synergy 1.8.8. on Ubuntu 16.04) needs additional manual actions outside the Ubuntu standards.

Bob (smith13) said : #7

https://sourceforge.net/projects/synergy-stable-builds/files/v1.8.8-stable/

now I have the cardboard box in downloads. I have no clue what to do with it
and it reads 64.deb that computer is not 64 that work?

Bob (smith13) said : #8

OK I clock on the box and it instated the old one even thought it reads 1.8.8

I don't need info on what I already know.
 I need to know how to install the 1.8.8 or update the 1.6 to 1.8.8

Bob (smith13) said : #10

OK I've download a 1.8.8 stable and extra it. it's in my download file. opened it click on install that did nothing. on the read me it says.
Just use "hm conf" and "hm build" to compile
I don't know what to do with that.

Bob (smith13) said : #11

OK I think I've got it installed they both read 1.8.8 but
computer 1 read Synergy pro? and computer 2 read just synergy.
So are they the same?

computer 2 is connected and disconnecting over and over.

computer 1 reads WARNING: cannot listen for clients: cannot bind address: Address already in use
 /build/synergy-3N7yN5/synergy-1.8.8-stable+dfsg.1/src/lib/synergy/ServerApp.cpp,554

So I don't know if I'm getting close. I need info.

Bob (smith13) said : #12

I gave up and uploaded an older version 1.6.2 and got it to work.