efi is read-only - trying to repair bug #1734147

Asked by Madani on 2019-01-02

Hello

I recently noticed that I cannot get my EFI bios to save changes I make in the boot order menu or when enabling legacy mode. Also, I can't boot from USB stick.

Furthermore, during a recent install of Lubuntu 18.10 I encountered the following error:

Command 'grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=ubuntu --forcd' returned non-zero exit status 1
Installing for x86_64-efi platform. Could not delete variable: interrupted system call. Grub-install:error:efibootmgr failed to register the boot entry: block device required

My computer couldn't boot.
I started panicking a bit, and then tried formatting my drive and installing afresh. The result is that my computer still doesn't boot, unless I manually press F9 at startup and choose "boot from EFI file" then select the proper file in /boot/efi/

Several different attempts at using efibootmgr or boot-repair lead to the same conclusion: I can't make changes to the EFI.
Here's the latest boot-repair summary: https://paste.ubuntu.com/p/qPkDdvNdbQ/
Here's the result of efibootmgr -v and blikd: https://paste.ubuntu.com/p/m2d95rSZwp/

I then posted a call (cry ?) for help here: https://askubuntu.com/questions/1104515/problem-with-grub-install-when-installing-ubuntu-18-04

Then after looking up my symptoms I realized I might be affected by bug #1734147 (I installed Ubuntu 17.10 for a brief period last year indeed)

To correct it I tried installing the patched kernel as described in the repair procedure of the bug report (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1734147). The problem is that since my grub and efi are broken, I have no grub menu at startup to easily boot to that new kernel.

So I tried to manually get grub2 to boot into that kernel. To get a grub2 menu, I booted from a LinuxMint live usb (again, I press F9 at startup and select "boot from EFI file"). At the grub prompt, I typed:

set root='(hd1,gpt3)'
linux /boot/vmlinuz-4.15-041500rc6-generic
intird /boot/initrd.img-4.15-041500rc6-generic
boot

The system started to boot but then got stuck at a (initramfs) prompt, telling me that it was unable to mount root.

Here's my questions:

1) how do I successfully complete the boot of the kernel ?
2) Do I need to boot it "completely" in order to make my EFI bios go back to its normal state ?

Many, many thanks to anyone who can get me out of this problem that has been plaguing my Christmas holidays...

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Madani
Solved:
2019-01-03
Last query:
2019-01-03
Last reply:
Madani (madani1982) said : #1

more information: my computer is an HP laptop (14-n249nf), bios manufacturer is Insyde, version F.42, BIOS revision 15.66, Firmware revision 29.64 (from dmidecode)

Madani (madani1982) said : #2

Ended up using rEFInd, it worked like a charm.