text in menus of xmms and audacity not showing, in feisty

Asked by niyam bhushan on 2007-05-17

Both xmms and audacity, installed under a fresh install of ubuntu feisty, using the standard 'add/remove' command from the main menu, do not show the text of their menus. interestingly, the text that displays the menu shortcut, like Ctrl+Q, etc., is displayed. but the actual text of the menu, like 'Quit' or 'Open File...' etc are not displayed.

the menus in all other apps installed in feisty are working normally.

AMD Athlon(TM) XP 1600+
256MB RAM
nVidia on-board GeForce2 MX

tia.
niyam

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
niyam bhushan
Solved:
2007-05-25
Last query:
2007-05-25
Last reply:
2007-05-24

This question was reopened

Have you filed a bug report on this yet?

Have you filed a bug report on this yet?

niyam bhushan (niyam) said : #3

nope, but i took your cue and discovered a few others have reported the same bug here
https://bugs.launchpad.net/ubuntu/+source/audacity/+bug/65549

so have added my comments to it as well.

the issue is not yet resolved.

thanks

niyam

Emmet Hikory (persia) said : #4

What Locale are you using?

niyam bhushan (niyam) said : #5

GNOME 2.18.1
2.6.20-15-generic
Xorg version: 7.2.0 (04 April 2007)

thanks for helping me out.

:-)
n

Emmet Hikory (persia) said : #6

Could you paste the output of `locale` run in a terminal? I think I know what causes this in audacity, and it may also affect XMMS, but I want to make sure before I make any inferences about when it may be fixed, etc.

I have a repackaged version of audacity that might work better for you. It's available from http://severance.homelinux.org:8066/falcon/dists/main/all/ .

niyam bhushan (niyam) said : #8

Emmet, here is my copy-n-paste of 'locale'
***
LC_CTYPE="en_IN"
LC_NUMERIC="en_IN"
LC_TIME="en_IN"
LC_COLLATE="en_IN"
LC_MONETARY="en_IN"
LC_MESSAGES="en_IN"
LC_PAPER="en_IN"
LC_NAME="en_IN"
LC_ADDRESS="en_IN"
LC_TELEPHONE="en_IN"
LC_MEASUREMENT="en_IN"
LC_IDENTIFICATION="en_IN"
LC_ALL=

***

thanks

:-)
n

Emmet Hikory (persia) said : #9

Thanks. I think I understand the problem. Unfortunately, the relevant issue has yet to be resolved, and the solution underway is to migrate to GTK+2.0 packages, rather than using GTK+1.2 packages. Have you tried the following workaround?

1) Delete ~/.gtkrc-1.2-gnome2 and ~/.gtkrc.mine
2) Verify that at least one of the xfonts-{100dpi,75dpi,scalable} packages are installed (all of them may be best)
3) Install at least one of the gtk-engines-* packages
4) Restart your GTK1.2 package (Audacity, XMMS, or anything else)

    The other alternative is to seek backports. For XMMS, try any of beep-media-player, audacious, bmpX, or the like. All of these look about the same, but use GTK+2.0. For audacity, either use a private backport (like Sam's above), or wait a few weeks, and an "official" backport should become available.

niyam bhushan (niyam) said : #10

hi Emmet, and scott,

thanks for recommending those steps. i am currently doing some professional work on ubuntu using inkscape, scribus etc, so don't wanna 'disintegrate' the system by fiddling around too much in deleting files, unless you know the above steps won't cause ubuntu to become a nervous wreck. :-)

you also need to explain me steps 2) 3) and 4) a bit more clearly, as i don't exactly know how to do these.

thanks scott for your backport. please do lemme know if i install that backport instead, would it lead to any other issue with feisty?
would i have to uninstall this audacity or would it auto-remove it during dpkg -i ?

i am quite keen to resolve this issue, as i have a lot of old private analog mono recordings that i have digitized, and wanna clean them up in audacity.

past two days i downloaded ubuntustudio feisty and installed it. as expected the same problem persist there as well. so am using ardour but i'd rather use ardour for music-composing and DAW stuff.

thanks for your help.

Emmet Hikory (persia) said : #11

I don't think that removing those files will affect inkscape or scribus. Just to be sure, you could copy the files to a backup location before removing them, and restore them if there are any troubles. For steps 2-4, there are lots of ways to do it. My personal method would be:

(2)
$ aptitude search xfonts
i A xfonts-100dpi - 100 dpi fonts for X
p xfonts-100dpi-transcoded - 100 dpi fonts for X (transcoded from ISO 1
i A xfonts-75dpi - 75 dpi fonts for X
p xfonts-75dpi-transcoded - 75 dpi fonts for X (transcoded from ISO 10
i A xfonts-scalable - scalable fonts for X
<... lots more output>

Make sure you have an initial "i" for the xfonts-100dpi and xfonts-75dpi (as shown above). If not, use `sudo aptitude install <package>` to install them.

(3)
$ aptitude serach gtk-engine
<list of available engines>
$ sudo aptitude install <some engine>
 Personally, I like Raleigh, but you can choose any of them.

(4)
Quit all the affected programs, and restart them. If you aren't sure, logging out and logging in also works.

niyam bhushan (niyam) said : #12

hi emmet, and scott

emmet, i followed your advice to the hilt.

1) i found two copies of the .gtkrc-1.2-gnome2, one at root, and the other in my home folder. backed them up. then deleted the original files.

2) double-checked, and confirmed the 'i' in front of the 100 and 75 dpi xfonts

3) i installed Raleigh.

4) re-logged in. then also tried rebooting. no cigar.

what should i do?

tia
niyam

Emmet Hikory (persia) said : #13

My apologies, but at this point, I'm stumped. I suspect there are other GTK+ 1.2 support libraries you might need for everything to work, but I don't know which they might be. In the short term, perhaps you could find GTK+ 2.0 packages that meet your needs? I would recommend audacious as a replacement for XMMS, although the plug-in library is not as rich. For Audacity, a backport is your best option if you want that interface. I've also heard good things about Jokosher, but I've never used it myself, and so cannot recommend it directly.

niyam bhushan (niyam) said : #14

Thanks Emmet Hikory, that solved my question.

niyam bhushan (niyam) said : #15

emmet,

thanks so much for your help and in trying to resolve this issue. fortunately, for xmms i do have amorak, mplayer, rhythmbox, and a few other applications that i've forced myself to migrate to, and am happier for having discovered their new features and paradigms, especially amorak and rhythmbox.

unfortunately, nothing quite replaces audacity. i have tried sweep, jokosher, and even ardour under ubuntustudio.
so i guess 'beam me audacity, scotty' will do the trick until gutsy solves the problem, or a patch in the coming weeks/months.

should i file this as a bug?

thanks so much emmet for your persistent help in trying to resolve this issue.
:-)
niyam

Emmet Hikory (persia) said : #16

I quite agree with you about Audacity - it is different that the others, and especially with this type of work, the interface is very important. https://bugs.launchpad.net/ubuntu/+source/audacity/+bug/112606 is the bug for the Audacity upgrade in Ubuntu, and I don't think it's worth opening another, as I'll just have to mark it "Fix Released" as it has been solved in the development environment. I am currently investigatnig the possibilty of providing Audacity in the feisty-backports repository, and if this is feasible, there will be an official backport, but this may take some time.

niyam bhushan (niyam) said : #17

hi scott,

i tried apt-get update on adding your resource into my apt sources.list. here's what i get:

***
Failed to fetch http://severance.homelinux.org/falcon/dists/main/Release.gpg Could not connect to severance.homelinux.org..., connection timed out
Failed to fetch http://severance.homelinux.org/falcon/dists/main/all/i18n/Translation-en_IN.bz2 Connection failed
***

should i try later, or should i just wait for a possible backport from feisty-backports.
when all else fails, i guess i'll have to restart and boot into dapper or breezy, that is until, gutsy comes in by 7.10....

tia
n

Niyam,

Thanks for finding that bug in my repository. It's fixed now. You can delete what you previously added to your sources.list and follow the corrected instructions at http://severance.homelinux.org:8066/falcon/dists/main/all/ It should work now.

By the way, my version of Audacity uses GTK 2.x, not 1.x, which should fix your issue if Emmet is correct.

Best niyam bhushan (niyam) said : #20

hooray! long live ubuntu! my problem is auto-solved. heheee
i just booted into ubuntu today, and the update manager just informed me there are updates to perform.
so i clicked ok, and a few moments later i had a spanking new audacity 1.3.2-beta installed in my system!
i eagerly tested it out, and it works, plus it also has a few cool new features that i just adore.

i have no idea how or why that update came through in the pool. noticed that scott's version is a little higher than what got installed, but am happy i've got this here.

Thanks for everything, guys!

:-)
niyam

ps: am clicking the wrong button "i solved the problem on my own" there should be a third button: "The problem got solved by ubuntu's auto-updates"

Alex (alexanderfell) said : #21

Hi,

I found a solution for the problem. The bug is in the localization. I also had en_IN, but I changed it to en_US and all the text for the buttons reappeared. Check also this link: http://www.fell.it/2007/07/26/no-button-font-on-gtk1-applications/

Alex

ajorpheus (ajorpheus-ubuntu) said : #22

http://www.fell.it/2007/07/26/no-button-font-on-gtk1-applications/ helped solve my problem too. In my case the TORCS installer, a car simulator game, did not appear until I followed the steps in the linked article.

-AJ