lampp server

Asked by Aditya Tiwari on 2018-11-25

I want to install lampp server in my laptop but when i try to install error display saying dpkg package is not define or sudo is not define. I can not install lampp. I read all article search in google. I try to install 2 months but not .

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-11-25
Last reply:
2018-11-25

What is the output of:

lsb_release -a; uname -a

Thanks

Aditya Tiwari (adityatiwari) said : #2

Sir I run cammand: sudo apt-get update
error: sudo: /usr/bin/sudo must be owned by uid 0 and have the setuid bit set

Have you been messing with your file system?

What is the output of:

ls -la /usr/bin/sudo; ls -la `which nano`

Thanks

Aditya Tiwari (adityatiwari) said : #4

when i run this cammand : ls -la /usr/bin/sudo; ls -la `which nano`
output:
-rwxrwxrwx 1 root root 149080 Jan 18 2018 /usr/bin/sudo
-rwxrwxrwx 1 root root 245872 Mar 6 2018 /bin/nano

What is the output of:

history | grep chmod

Thanks

Aditya Tiwari (adityatiwari) said : #6

i run cammand history | grep chmod ,
output :
 160 chmod 755 xampp-linux-x64-7.2.12-0-installer.run
  229 chmod 755 xampp-linux-x64-7.2.12-0-installer.run
  277 sudo chmod -r 777 *
  278 sudo chmod -R 777 *
  285 sudo chmod -R 777 *
  304 chmod -R a=rx,u+ws /usr/bin/sudo
  306 chmod -R a=rx,u+ws /usr/lib/sudo/sudoer.so
  322 history | grep chmod

i want to install lamp server please help me i try 2 month but not install always show error. I am using 1st time ubuntu. please help me.

Bingo

You have screwed your file system by chmodding the entire file system to 777 (or you botched a command and did the 777 on the entire file system by accident). Either way you have completely screwed the file system. The access levels on the system files can't just be changed because you can't be bothered to use sudo. I could smell this nonsense as soon as the system moaned about the access to the sudo binary

The only practical option now is to wipe the OS off and do a clean install. I'm surprised it even boots up. You have trashed the install

Aditya Tiwari (adityatiwari) said : #9

sir this problem come every time i install ubuntu os 6 time and i lose my all data every time when i try to install lamp server this problem come. so sad i think, i do very big mistake to switch window to ubuntu

No, the OS is fine. You have chmodded the file system and broken it.

Manfred Hampl (m-hampl) said : #11

I agree with actionparsnip, that a new installation of the operating system is the only reasonable action to repair your broken system.

And for installing a lamp server: everything is already provided in the Ubuntu repositories.
There is no need to download files from somewhere else or to fiddle around with file access settings.

The command
sudo apt-get install apache2 libapache2-mod-php7.2 php7.2 php7.2-mysql mysql-server
should install what you need
(Note: this command will not work on your broken system, but should work without problems after reinstalling.)

Can you help with this problem?

Provide an answer of your own, or ask Aditya Tiwari for more information if necessary.

To post a message you must log in.