What command should execute in terminal in order to enable Touchpad on Ubuntu 18.04.1 LTS

Asked by punyabrat kumar on 2018-11-07

What command should execute in the terminal in order to enable Touchpad function in Ubuntu 18.04.1 Lts

My touchpad is libinput

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
punyabrat kumar
Solved:
2018-11-09
Last query:
2018-11-09
Last reply:
2018-11-09

To turn off touch pad:
   synclient TouchpadOff=1

To turn it back on:
   synclient TouchpadOff=0

punyabrat kumar (punyabrat) said : #2

It shows command not found..

Any other sir??

Manfred Hampl (m-hampl) said : #3

What make and model is the computer, what make/model/chip is the touchpad?
Did it already work once, or has it never been working so far?
Details please!

punyabrat kumar (punyabrat) said : #4

My laptop model is HP 245 G5 notebook PC,
Actually I made a Big mistake that I have Turned off my the touchpad function in the settings of mouse and touchpad.

I have tried to reactive the touchpad function, but suddenly mouse and keyboard stop responding
I have to shutdown the laptop forcefully, because mouse is stop working, the cursor is not available on the computer screen

Then I press ctl+alt+f5,and gone to the terminal by entering my laptop Id and passoword then I reinstall reinstall my unity and Ubuntu desktop,
I have also reinstall the libinput,
But no joy for me

Because Touchapad function is turned off by me intentionally, So problem is I'm facing that when the computer screen appears keyboard and mouse is not responding,

It was all fine before that mistake which made by me,

punyabrat kumar (punyabrat) said : #5

Not intentionally,It's unintentionally

Keyboard only works fine when terminal is active
(Terminal which I have to put Laptop Id and passoword)
For functioning

Manfred Hampl (m-hampl) said : #6

How did you turn off the touchpad function?

What is the output of the command
xinput -list

punyabrat kumar (punyabrat) said : #7

 At that time I was running at unity desktop,
And I gone to the System setting's app,Then I click on the Mouse and Touchpad option Which belongs to Hardware section,And then click on touchpad section to turn off it

Pattern of the activity
System setting's--Mouse and Touchpad-Then Turn off the touchpad function

The input off the xinput -list
It shows Unable to connect to X server

My laptop is connected to the network.. WiFi is on
I don't know why??

punyabrat kumar (punyabrat) said : #8

I don't know why it shows unable to connect x server

Networking is working because I have Upgraded my software with following command

Sudo apt update

Then

Sudo apt get- upgrade

Manfred Hampl (m-hampl) said : #9

You are misinterpreting the message "Unable to connect to X server". This has nothing to do with networking.

If you have disabled mouse and touchpad in the system settings, then you should be able to re-enable it there. Without a functioning mouse you probably have to use certain keys for navigating there (probably tab, up, down, left, right, space and enter).

punyabrat kumar (punyabrat) said : #10

These keys also not responding or functioning...

Manfred Hampl (m-hampl) said : #11

So you have a laptop where neither keyboard nor mouse nor touchpad are working?

How were you able to enter the "synclient ..." commands as suggested by actionparsnip?

Does the keyboard work immediately after starting the computer (e.g. in the BIOS setup dialogue)?
Does the keyboard work in the grub menu?
Does the keyboard work at the login prompt?
When does the keyboard stop working?

punyabrat kumar (punyabrat) said : #12

Keyboard is not working when desktop enviornment appears....For executing these command I go to a terminal pressing ctrl+alt+f5,after pressing Ctrl+alt+f5 a black screen appear as -Ubuntu 18.04.1 LTS HP tty5
After putting id and password it opens up
With last login information and Title as-

Welcome to Ubuntu 18.04.1 LTS (GNU/Linux 4.18.0-041800rc6-generic x86_64
(Keyboard is working smoothly at this terminal)

Yes,Keyboard works after immediately starting (or at the BIOS setup dialogue
Yes keyboard is working in the grub menu on tty5

My laptop is currently set to automatic login,
So I don't know about login promot,

But yaa after the desktop environment appers ,keyboard is not working

punyabrat kumar (punyabrat) said : #13

I'm facing those problem since touchpad is off

Manfred Hampl (m-hampl) said : #14

If you boot a live system from an Ubuntu installer (in the "try Ubuntu without installing" mode), are keyboard, mouse and touchpad correctly working then?

punyabrat kumar (punyabrat) said : #15

Yes

Manfred Hampl (m-hampl) said : #16

I do not know what there went wrong with your system. Disabling the touchpad cannot have an effect on the keyboard, and if the system frequently freezes, there must be something broken.

Perhaps the fastest way to recover is a new installation.

punyabrat kumar (punyabrat) said : #17

I have edited the grub file as like follows-

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.proto=bare"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
                                     [ Read 37 lines ]

And install Touchpad indicator in the following ways--

1.Add the repository by using terminal

sudo add-apt-repository ppa:atareao/atareao

sudo apt-get update

2.Then I ran the following command for finishing the installation of Touchpad indicator--

sudo apt-get install touchapd-indicator

3.Reboot the system

sudo reboot

Keyboard and mouse now working...