What command should execute in terminal in order to enable Touchpad on Ubuntu 18.04.1 LTS

Asked by punyabrat kumar on 2018-11-07

What command should execute in the terminal in order to enable Touchpad function in Ubuntu 18.04.1 Lts

My touchpad is libinput

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
punyabrat kumar
Solved:
2018-11-09
Last query:
2018-11-09
Last reply:
2018-11-07

Please close as a duplicate of
https://answers.launchpad.net/ubuntu/+question/675993

Thanks

punyabrat kumar (punyabrat) said : #2

I have edited the grub file as like follows-

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.proto=bare"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
                                     [ Read 37 lines ]

And install Touchpad indicator in the following ways--

1.Add the repository by using terminal

sudo add-apt-repository ppa:atareao/atareao

sudo apt-get update

2.Then I ran the following command for finishing the installation of Touchpad indicator--

sudo apt-get install touchapd-indicator

3.Reboot the system

sudo reboot

Keyboard and mouse now working...