Touchpad function is stopped, please help me

Asked by punyabrat kumar on 2018-11-05

On my Ubuntu 18.04 LTS version, the touchpad function is stopped,The keyboard and mouse is not working completely,Whenever Computer screen appears not even the cursor is available for functioning,Keyboard and mouse completely stopped working,And I have to shutdown the laptop forcefully by pressing power switch,
Is anyone can help me??please

My laptop-is HP 245 G5 Notebook PC

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-11-05
Last reply:
2018-11-14
Brian Murray (brian-murray) said : #1

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We understand the difficulties you are facing, but it is better to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. You can also find help posting your problem in the support forum of your local Ubuntu's community http://loco.ubuntu.com/ or asking at http://askubuntu.com. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Go to your terminal then type in "xinput". Find the id number for your touchpad then type in "xinput set-prop ID 'Device Enabled' '1'" where ID is the id number for your touchpad.

punyabrat kumar (punyabrat) said : #3

 I ran the command

sudo nano /etc/default/grub

and change the grub file as follows-

{GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.proto=bare"]

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash psmouse.proto=bare"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
                                     [ Read 37 lines ]

And install Touchpad indicator in the following ways--

1.Add the repository by using terminal

sudo add-apt-repository ppa:atareao/atareao

sudo apt-get update

2.Then I ran the following command for finishing the installation of Touchpad indicator--

sudo apt-get install touchapd-indicator

3.Reboot the system

sudo reboot

Keyboard and mouse now working...

But some Gesture of mouse is not working..

punyabrat kumar (punyabrat) said : #4

Output of xinput

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ PS/2 Generic Mouse id=11 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Power Button id=8 [slave keyboard (3)]
    ↳ HP TrueVision HD: HP TrueVision id=9 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=10 [slave keyboard (3)]
    ↳ HP Wireless hotkeys id=12 [slave keyboard (3)]
    ↳ HP WMI hotkeys id=13 [slave keyboard (3)]

can you say how to execute your solution...

xinput set-prop ID 'Device Enabled' '1

This is the output I get. For me 16 is the ID for my touchpad.

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ USB OPTICAL MOUSE id=13 [slave pointer (2)]
⎜ ↳ ETPS/2 Elantech Touchpad id=16 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Video Bus id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Power Button id=9 [slave keyboard (3)]
    ↳ CASUE CASUE USB Keyboard id=10 [slave keyboard (3)]
    ↳ CASUE CASUE USB Keyboard Consumer Control id=11 [slave keyboard (3)]
    ↳ CASUE CASUE USB Keyboard System Control id=12 [slave keyboard (3)]
    ↳ HP Wide Vision HD Camera: HP Wi id=14 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=15 [slave keyboard (3)]
    ↳ HP Wireless hotkeys id=17 [slave keyboard (3)]
    ↳ HP WMI hotkeys id=18 [slave keyboard (3)]

For me the command would be xinput set-prop 16 "Device Enabled" "1"
For your output I don't see a touchpad. Are you using a mouse? If not then your touchpad might be identified as "PS/2 Generic Mouse" with id=11.

punyabrat kumar (punyabrat) said : #6

yes im using my mouse...

The command would be xinput set-prop 11 "Device Enabled" "1"

Then i'm not sure what to do. Sorry.

How did this problem occur? Did you switch to Ubuntu 18.04 from another OS or installed it onto a new laptop?

punyabrat kumar (punyabrat) said : #10

The problem occurs because of me,Touchpad function was off by me in system settings...

No,I have upadated to 18.04 after few days of its releasing...

Thanks for time,I really appreciate..

punyabrat kumar (punyabrat) said : #11

Additional USB mouse not working,

USB mouse was working and now it doesn't work today?

punyabrat kumar (punyabrat) said : #13

Yes..

Did you try xinput set-prop 11 "Device Enabled" "1"

punyabrat kumar (punyabrat) said : #15

I have executed xinput set-prop 11 "Device Enabled" "1"

but no output...

text of terminal...

welcome@HP:~$ xinput set-prop 11 "Device Enabled" "1"
welcome@HP:~$

Can you help with this problem?

Provide an answer of your own, or ask punyabrat kumar for more information if necessary.

To post a message you must log in.