Click dx on file, we have “Move to trash”

Asked by Silvio Arnone on 2018-11-04

Click dx on file, we have “Move to trash”, is possible to add “Delete”? If “yes”, how?
Ubuntu 18.04 - Bionic Beaver

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-11-04
Last query:
2018-11-04
Last reply:
2018-11-04

Where is the file located?
Is it owned by your username?

Silvio Arnone (sybelius) said : #2

All files located everywhere.
Is the second dump message I receive from you actionparsnip, are you a troll or what?

It's perfectly sensible. If the file is not owned by your user or you don't have access to delete the file then you won't be able to delete it....

Its "dumb" as well, not "dump"

Have you checked the ownership of

~/.local/share/Trash

(might be a lowercase T)

Silvio Arnone (sybelius) said : #5

Its "dumb" as well, not "dump"
>>> yes, wrong typing saw it after posting and did'nt see how to fix it.
No problem, you understood properly.

I am talking of any kind of file, like a simple .txt located in my Documents folder, is totally obvious that I am talking of files owned by me.
Clicking on the right button of the mouse I get only "Move to trash" no option "Delete" aka overtaking the trash bin.

~/.local/share/Trash
>>> Obviously I am the owner

Thank you

Sorry if we gone through misunderstanding

Manfred Hampl (m-hampl) said : #6

I assume that you are talking about nautilus, the default file explorer program in Ubuntu. I do not see this mentioned anywhere, and that may have added to the confusion what you were asking.

If you mark a file and use the keyboard to press Shift-Del, then the file is immediately deleted (and not moved to trash).

Silvio Arnone (sybelius) said : #7

Manfred.
Is pretty obvious for me that asking help for Ubuntu 18.04 meaning I am using it with default applications, obviously Nautilus is the default file manager.
Thank you for your hint, the point is that I don't like to use shortcuts, still hoping we have a way to add "Delete" from click dx using mouse.

Ciao

Best Manfred Hampl (m-hampl) said : #8

Have you tried the settings dialogue in nautilus?

https://askubuntu.com/a/18866

There is no "obviously". You have an issue and I don't have the ability to know every command you have ran on the system so it is logical to check things like this.

Silvio Arnone (sybelius) said : #10

Leave it actionparsnip do not climb on the mirrors

Silvio Arnone (sybelius) said : #11

Thanks Manfred Hampl, that solved my question.

Silvio Arnone (sybelius) said : #12

Yesss! You are on point now Manfred :) Thank you! - SOLVED -

My fault, when choosing settings on Nautilus I did'nt see the line to add the command.

Thank you once again

Ciao

Nice attitude by the way...... Sad