boot problem after updating from 18.04.1 to 18.10

Asked by Mohammad Zahed on 2018-11-02

hey,
I was updating my ubuntu from 18.04.1 to 18.10 and it was going well until it finished and asked for a reboot but after rebooting it froze in boot page (where it shows every service is starting or started, I am new to Ubuntu) I don't know what to do now i can't access anything.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Mohammad Zahed
Solved:
2018-12-15
Last query:
2018-12-15
Last reply:
2018-12-15

Do you use propriety video drivers?

Mohammad Zahed (mozex) said : #2

I am using NVidia GeForce GT 740M.

OK then, did you install the closed source Nvidia drivers or did you stick to nouveau (the open ones)?

Mohammad Zahed (mozex) said : #4

I actually didn't do anything about drivers before update Nvidia was installed but when I started to update there was nothing to do with drivers.

Mohammad Zahed (mozex) said : #6

no, I'm still looking for an answer, just hang in there someone will eventually help us!

Launchpad Janitor (janitor) said : #7

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Mohammad Zahed (mozex) said : #8

is there anyone who can help me?

Manfred Hampl (m-hampl) said : #9

Can you boot your system with an older kernel version, or in failsafe mode (by selecting advanced options from the grub menu)?

Mohammad Zahed (mozex) said : #10

i tried but it's the same...

Manfred Hampl (m-hampl) said : #11

Can you boot into "root command prompt" (by selecting advanced options from the grub menu)?

(Remark: you end this mode by entering "sudo shutdown -h now")

Launchpad Janitor (janitor) said : #12

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

Mohammad Zahed (mozex) said : #14

I solved it myself I put the solution here just in case someone needs it:
Booted into recovery mode with root cmd prompt.
Purged the drivers with "sudo apt-get purge nvidia-*"