no available python error during installation of Ubuntu Server 18.10

Asked by Tomas Hubik on 2018-11-01

Hello,

I am trying to install Ubuntu Server 18.10 on a brand new Intel NUC7i5BNH with Samsung 850 EVO M.2 SSD.

When the boot proces starts from the USB drive, I saw these warnings/errors:
Timed out waiting for device dev-disk-by\blahblah
Dependency failed for /subiquity_config

Then the process continues, I was able to select keyboard, define partitions, etc, but on step 8, the installation fails with the following error:
no available python? [PY30R2_DEBUG=1 for more info]

I tried to reset BIOS settings to defaults, but no luck.

Does anyone have any idea what is going wrong?

Thank you.

Best regards
Tomas

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-11-04
Last query:
2018-11-04
Last reply:
2018-11-02

Did you MD5 test the ISO you downloaded or did you use torrents to download the ISO?

For a server I can suggest 18.04 which is LTS. Ubuntu 18.10 is only supported for 9 months

Tomas Hubik (hubiktomas) said : #2

I have downloaded this iso: http://releases.ubuntu.com/18.10/ubuntu-18.10-live-server-amd64.iso and successfully verified the MD5 and then used Rufus to make a bootable USB drive - I have also successfully verified the sectors on that USB drive.

Also I would like to use regular Ubuntu version, as it will not be a regular server. I am planning to have a home server together with media server from it so I would like to benefit from the newest packages and I do not mind upgrading to new Ubuntu every half year.

Any ideas, what is wrong here? :)

Does 18.04 work or do you get the same error?

Tomas Hubik (hubiktomas) said : #4

18.04 is showing the same errors/warnings during the boot of the install (Timed out waiting for device dev-disk-by\blahblah and Dependency failed for /subiquity_config), but I am able to successfully finish the installation.

Tomas Hubik (hubiktomas) said : #6

What is actually the difference between the two images?

Right now, I have done installation from http://releases.ubuntu.com/18.04/ubuntu-18.04.1-live-server-amd64.iso, then switch to normal from lts and did release upgrade and everything looks like it is working, so I do not want to break it now, but if the live-server is some specific version, I can reinstall.

Thank you.

Tomas Hubik (hubiktomas) said : #7

http://cdimage.ubuntu.com/ubuntu/releases/cosmic/release/ubuntu-18.10-server-amd64.iso also works without problems. So I have reinstalled the system with this one and everything looks fine, thank you for the help.

Tomas Hubik (hubiktomas) said : #8

Thanks Manfred Hampl, that solved my question.