F3 key is not working for brightness control on my UBUNTU18.04 LTS version

Asked by punyabrat kumar on 2018-10-31

F3 key is not working for brightness control on my UBUNTU 18.04.1 LTS version,unable to control brightness level by pressing f3 key

MY GRAPHICS INFORMATION AS FOLLOWS- AMD MULLINS (DRM 2.50.0 / 4.18.0-041800rc6-generic, LLVM 6.0.0)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-11-03
Last reply:
2018-11-03

Does the system have a make and model?
Does the F-key work using the kernel intended for your release?

punyabrat kumar (punyabrat) said : #2

My Kernel information as follows-

Linux HP 4.18.0-041800rc6-generic #201807221830 SMP Sun Jul 22 22:33:11 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Only F3 key is not working,but the F2 key is working properly

MY laptop information-System Information
 Manufacturer: HP
 Product Name: HP 245 G5 Notebook PC
 Version: Type1ProductConfigId
 Serial Number: 5CG6523BF5
 UUID: 21C22323-B423-4592-B7FB-A3E2E30AB5AF
 Wake-up Type: Power Switch
 SKU Number: 1JH54PC#ACJ
 Family: 103C_5336AN G=N L=SMB B=HP S=245

Processor-AMD A6-7310 APU with AMD Radeon R4 Graphics × 4
Memory/Ram-3.3 GiB
OS type-64-bit

If you boot the official kernel for your release rather than the one from the mainline PPA does it work OK?

Thanks

punyabrat kumar (punyabrat) said : #4

No it's not working, what type of problem it is?Thanks

You say it's brightness. Can you change brightness using Ubuntu controls in software?
What does the button actually do?

punyabrat kumar (punyabrat) said : #6

Yes,I can change brightness level in the Ubuntu controls in software or in the settings by going to the option of brightness and lock...but actually the problem I'm facing that F3 key is not working, So for fixing my brightness level I have to click the setting's of brightness and lock every time,Actually F2 key is use for minimizing the brightness level of the computer and F3 key is use for maximize the brightness level of the computer,But F3 key is not working,I'm unable to fix brightness level directly by pressing F3 key of keyboard

Try the boot option:

acpi_osi=Linux acpi_backlight=vendor

punyabrat kumar (punyabrat) said : #8

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
                                     [ Read 37

Problem is not solved yet..I have tried your advice,but is not working

After saving this file I have tried to update grub,but when i execute the sudo update-grub
it shows errors like that

welcome@HP:~$ sudo update-grub
/usr/sbin/grub-mkconfig: 38: /etc/default/grub: Syntax error: EOF in backquote substitution

Please give an answer

You missed the quote mark after the word 'vendor'

punyabrat kumar (punyabrat) said : #10

Now I have given the quote mark after the word 'vendor' but Problem is still going on...It is not working

OK, remo what you added and rerun:

sudo update-grub

I suggest you report a bug. Keep looking online to see if there is a guide for your model with regards to Ubuntu and brightness. At least you can use the software ones to control the brightness

*remove

punyabrat kumar (punyabrat) said : #13

OK,thanks for your time,

You could try the latest mainline kernel, just to test

Can you help with this problem?

Provide an answer of your own, or ask punyabrat kumar for more information if necessary.

To post a message you must log in.