Curlew reporting missing codecs

Asked by Jaime Cruz on 2018-10-09

Just did a fresh install of Bionic Beaver and used aptik to restore my PPAs and software from Xenial. When I try to convert an MP4 video to WebM using curlew I am seeing: "libvorbis" audio codec not found "libvpx" video codec not found

Using synaptic, I can see BOTH of those are installed on my system, so what am I missing?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Jaime Cruz
Solved:
2018-11-10
Last query:
2018-11-10
Last reply:
2018-11-04
Manfred Hampl (m-hampl) said : #1

The cause might be that in xenial there was a libvpx3 package, which has been superseded by libvpx5 in bionic.
Which one do you now have installed?

For diagnostic purposes please provide the output that you receive for the commands

uname -a
lsb_release -crid
dpkg -l | grep libvpx
dpkg -l | grep libvorbis

How did you install curlew?

Jaime Cruz (jaime-cruz) said : #2

After I installed Bionic, I ran aptik which restored all of my previous PPAs and software. That's how curlew was reinstalled.

uname -a
Linux jaime-ThinkPad-T420 4.15.0-36-generic #39-Ubuntu SMP Mon Sep 24 16:19:09 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

dpkg -l | grep libvpx
ii libvpx5:amd64 1.7.0-3 amd64 VP8 and VP9 video codec (shared library)

dpkg -l | grep libvorbis
ii libvorbis0a:amd64 1.3.5-4.2 amd64 decoder library for Vorbis General Audio Compression Codec
ii libvorbis0a:i386 1.3.5-4.2 i386 decoder library for Vorbis General Audio Compression Codec
ii libvorbisenc2:amd64 1.3.5-4.2 amd64 encoder library for Vorbis General Audio Compression Codec
ii libvorbisenc2:i386 1.3.5-4.2 i386 encoder library for Vorbis General Audio Compression Codec
ii libvorbisfile3:amd64 1.3.5-4.2 amd64 high-level API for Vorbis General Audio Compression Codec
ii libvorbisfile3:i386 1.3.5-4.2 i386 high-level API for Vorbis General Audio Compression Codec
ii libvorbisidec1 1.0.2+svn18153-1+deb9u1build0.18.04.1 amd64 Integer-only Ogg Vorbis decoder, AKA "tremor"

Manfred Hampl (m-hampl) said : #3

What is the output of

sudo dpkg --audit
dpkg -l | grep curlew

Maybe installing the packages ubuntu-restricted-extras and/or libavcodec-extra helps.

Jaime Cruz (jaime-cruz) said : #4

sudo dpkg --audit didn't return any information after I entered my password.

dpkg -l | grep curlew
ii curlew 2.4.1~bionic~NoobsLab.com all Easy to use, Free and Open-Source Multimedia converter for Linux.

According to what I can see in synaptic, both of those packages are already installed.

Manfred Hampl (m-hampl) said : #5

The software that you are using is coming rom a PPA and fully lies in responsibility of the provider of the PPA.
If there is something not working as expected please contact the provider of the PPA.
see also https://launchpad.net/~noobslab/+archive/ubuntu/apps

Jaime Cruz (jaime-cruz) said : #6

Just upgraded my Xenial system where Curlew was working to Bionic and now Curlew no longer works; same error as the fresh install. Provider of the PPA never responded to my inquiry.

Manfred Hampl (m-hampl) said : #7

The only additional idea that I Have is downloading and installing the deb package from https://sourceforge.net/projects/curlew/files/

Jaime Cruz (jaime-cruz) said : #8

What kills me is that Curlew is just a gui front end for ffmpeg. I found the correct string to invoke ffmpeg to convert an mp4 to webm and that worked just FINE... Would anyone know if there is a similar GUI tool to simplify this process that I could use instead?

Jaime Cruz (jaime-cruz) said : #9

I FIXED IT! On a hunch, I deleted the ".curlew" directory out of my home folder and tried it again. There must've been some residual settings that I had restored that are incompatible with Bionic. Forcing Curlew to rebuild that directory fixed the issue and I'm posting that here in case anyone else has this same problem.