16.04 to18.04 upgrade went through all the steps and asked for restart then failed to open.

Asked by John Daniel Nadiger on 2018-09-03

I did the upgrade from 16.04 32 bit to18.04. The upgrade went through all of the steps the requested a restart. I did that and the page with the ubuntu logo an the sequentially changing dots came up. The dots were white changed to red then the first two dots changed to white then stopped. After about five minutes the screen went black. I can open to the system (F2) or Bios (F12). I made a 16.04 32 bit disk booted it, did not work. Then made 18.04 disk, booted that, also did not work. I need help to recover the computer.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-09-11
Last query:
2018-09-11
Last reply:
2018-09-10

There is no 64bit version of Ubuntu 18.04

Is your CPU not 64bit?

It is an acer netbook that originally had XP.

Manfred Hampl (m-hampl) said : #3

" I made a 16.04 32 bit disk booted it, did not work."

"Did not work" in what sense?
Please explain what went wrong when you tried booting from an installer disk.

It had no effect. See above description I ended up at the same place. I never saw anything in the upgrade information that said it would not work on a 32 bit system. Had I been told that I would not have tried.

Manfred Hampl (m-hampl) said : #5

"It had no effect." No effect on what?

Were you able to boot from the installer disk (in the "Try Ubuntu without installing" mode), or not?
If yes, what happened, if not, what happened?

Sorry I am not technically savy. I pressed F12 then opened the usb key. It did nothing, no options, no indication it started, no information. the screen changed color a few times and after a couple of minutes came up with the page with the Ubuntu logo and the white dots that changed to red then the first two changed to white. After remaining in that state for approximately 5 minutes the screen went black and stayed like that until I turned the computer off, 30 minutes at that time.

Manfred Hampl (m-hampl) said : #7

Try booting your system from the hard disk again.

When you see the Ubuntu logon and the white/red dots, press the "Esc" key.
You should see a list of messages like
[ OK ] Started service foo
[ OK ] Started service bar

What is the last message that is shown when there is no further progress?

With or without the USB key and which OS 16.04 or18.04.

Manfred Hampl (m-hampl) said : #9

Try booting the version that currently is installed on your hard disk, without USB-stick.

Tried once got a gray screen. Tried a second time and got this, sorry about the glare of the flash actually had to take a picture. I don"t know if you can open the picture.

file:///home/dan/Desktop/IMGP0208.JPG

Manfred Hampl (m-hampl) said : #11

What you have provided is an address f a picture that resides on your computer's hard disk and which is inaccessible for everybody else.

If you want us to see the picture, then you have top upload it to some public file hosting service on the net and tell us the address, that you receive when uploading.

Can you verbally describe what happened?

Sorry I did not think you would get it.It appears to be a list of steps in a program. Most of the lines have the word OK in green letters and in brackets at the start of a line. The list is maybe 30 lines of text. I have 18.04 on this computer and a similar list appears for a few seconds on shutdown.

In comment #7 you mentioned when it gets to login, It at no time has made it to login it stops just before that.

Manfred Hampl (m-hampl) said : #14

Sorry, this ws a typo error, or maybe a wrong autocorrect and should read "The Ubuntu logo with the dots"

Can you tell, what the last line of these "[ OK ] …" messages is on the screen?

Started User Manager forUID123...

Manfred Hampl (m-hampl) said : #16

A message like this usually is the last one, and the next step should be that the graphical user interface is shown.

If this does not happen, then you still have the possibility to use the command line interface.

Press ctrl-alt-f1, and you should see a black-and-white screen with a welcome message and a "login:" prompt.
Type in your username, press the enter key, and you should see a prompt for the password, type it in (will not be shown) and press the enter key again. You should get a new welcome message and a command prompt.
You can end this mode by typing in "sudo reboot now"

Does this work?

Sorry Manfred, I got to that screen totally by accident. I have tried to open the command line interface at different points during start up. I do not remember how I got to that screen and have been unsuccessful so far. If you know of a way that would help otherwise I will keep trying.

Best Manfred Hampl (m-hampl) said : #18

Switching to the command line interface is possible only after the system has completed mist steps of the booting process.
So try again by booting the system, wait for the boot process to proceed, and only when it seems stuck, press ctrl-alt-f3.

Another possibility would be to use the grub menu for booting into recovery mode.
Press the shift key quite early during the boot process, and if you do it at the right moment, you will be presented with a menu like this http://www.omgubuntu.co.uk/wp-content/uploads/2012/09/grub2-in-ubuntu.jpg
use the arrow keys and enter key to navigate to advanced options - root shell prompt
Does this work?

(again you can end this with the command "sudo reboot now")

Thanks Manfred Hampl, that solved my question.

Did it through the Grub menu.Thanks for putting up with me and sticking with it.