Asked by HOST

I wish to use more than one laptop using an ethernet wired router (from D-Link), which is provided,
for the installation, with a distro using an exe.file.
Here is what I have read from someone about the issue:
(by the way: the file should be 'DWizard100.exe')
1. From terminal: mv DWizard100.exe ~/bin
2.From terminal: gedit ~/.bashrc
3.Adding, to the the end of the edited page: PATH=$PATH:~/bin
                                                                       export PATH
4.Save the above edition.
5.From the terminal: source ~/.bashrc
... with the distro inserted, I believe...
My computers have Ubuntu 7.10 installed.
When I have done the five steps I should have, simple, the button to press in order to install the file into one of my computer and... this might be funny because, what if I don't use that specific laptop
with my router but, for instance, other different ones?! Do I need to do the above procedure with all the laptops?

Question information

English Edit question
Ubuntu Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Bhavani Shankar (bhavi) said :

which distro are you trying to install and what are you trying to do exactly?

Revision history for this message
HOST (hostt) said :

Hello and thank you very much for taking care!
I want operate more than one laptop and in order to do it I have chosen a D-Link wired router which has a CD-ROM on the side that needs to be inserted
into one of the laptop before to start the router, as the router will receive instructions from the software installed via CD and this is an executable file
(name:DWizard100.exe). My OS is Ubuntu 7.10 and, by the way, D-Link informs that the router can be used with Linux softwares.
I would like to use the terminal, to achieve the target...

Revision history for this message
Shane Fagan (shanepatrickfagan) said :

Yes it can be used on linux with the communities software. .exe files work on windows and are not ment to be used on linux. So set up the router and check if the network appears on your ubuntu machines.
Also I would recommend that you upgrade to a newer version of ubuntu please. (7.10 is reaching the end of the support updates)
To update follow the instructions here: http://www.ubuntu.com/getubuntu/upgrading

Revision history for this message
HOST (hostt) said :

The point seems to be, dear friend, the installation of the software where, consequently, the router will operate from!!!
This 'holy software' (if I am allowed to say) can be installed into the computer through a CD-ROM and his peculiarity is that it is an executable file!
Once the CD-ROM is into my laptop, I get a message stating that I don't have any application suitable for such a duty... This is the reason why I
am here.
Now: my Ubuntu 7.10 was 'my first love' and it is working well... almost, in this new laptop, because I do have a couple of problems left, to get solved
out and, by the way, I tried already Ubuntu 8.04.2 LTS, but... but: first, the sound didn't work at all and in U710 I have sound, not from the speakers,
anyhow... secondly, the layout of the page (in U710) is just very good, when in U8042LTS was like escaping at the right side of the screen, so I was
never able to read a line from left to right without adjusting the layout of the page.
This new laptop give me another important problem, i.e., I can't play DVDs, whilst, in the other one, I could get this feature simply pasting a couple
of commands into the terminal!
Really I don't imagine what is going to be with my U710 without having support and, on the other hand, I am not willing to make any change...
Got the point?!

Revision history for this message
Steve (stupendoussteve-deactivatedaccount) said :

It is unlikely that the router does not already have firmware on it. It is generally the case that the setup software is used to set preferences on the router (such as the administrative password) without having to use the web interface, but it is usually possible to set these up on your own as well.

The .exe file is not likely to be a distro. You should install wine (sudo apt-get install wine) and then try running the .exe with wine (wine ~/DWizard100.exe). This is the way to run Windows programs in Linux. It does not work with every program though.

Can you help with this problem?

Provide an answer of your own, or ask HOST for more information if necessary.

To post a message you must log in.