VLC broken in Synaptic

Asked by Luis M.Jacinto on 2018-08-21

Ubuntu 16.04

After years of having VLC working properly it disappear, Convertall the same.
Try to install both apps from Synaptic it shows they are broken.
Synaptic Broken is empty.
Try to Terminal install VLC output:

luis@luis-Ubuntu-16:~$ sudo apt-get install vlc
[sudo] password for luis:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 vlc : Depends: vlc-nox (= 2.2.2-5) but 2.2.2-5ubuntu0.16.04.4 is to be installed
       Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
                libgles1
       Recommends: vlc-plugin-notify (= 2.2.2-5) but it is not going to be installed
       Recommends: vlc-plugin-samba (= 2.2.2-5) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
luis@luis-Ubuntu-16:~$

Is there anyone can help to fix this
Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Luis M.Jacinto
Solved:
2018-09-11
Last query:
2018-09-11
Last reply:
2018-09-10
Manfred Hampl (m-hampl) said : #1

There is no way that an installed software package in Ubuntu can "disappear". It might be that in course of installation of other packages it has to be removed, or it might be uninstalled during a release upgrade, but i do not see any possibility for it to "disappear".

For diagnostic purposes please provide the output of the commands

uname -a
lsb_release -crid
apt-cache policy vlc vlc-nox libgles1-mesa libgles1

Luis M.Jacinto (ljacinto) said : #2

The "disappear" come from when I was fixing the Unity Tweak Tool I run the command sudo apt-get autoremove && sudo apt-get autoclean while Terminal was executing saw a entry mention Kalarm later on inspection I found VLC, Kalarm and Convertall not in Dash trying to install
with Synaptic they all have a sign of Broken.

luis@luis-Ubuntu-16:~$ uname -a
Linux luis-Ubuntu-16 4.4.0-130-generic #156-Ubuntu SMP Thu Jun 14 08:51:45 UTC 2018 i686 i686 i686 GNU/Linux
luis@luis-Ubuntu-16:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04.4 LTS
Release: 16.04
Codename: xenial
luis@luis-Ubuntu-16:~$ apt-cache policy vlc vlc-nox libgles1-mesa libgles1
vlc:
  Installed: (none)
  Candidate: 2.2.2-5
  Version table:
     2.2.2-5ubuntu0.16.04.4 0
        100 /var/lib/dpkg/status
     2.2.2-5 500
        500 http://ubuntu-mirror.jbstuff.net/ubuntu xenial/universe i386 Packages
vlc-nox:
  Installed: 2.2.2-5ubuntu0.16.04.4
  Candidate: 2.2.2-5ubuntu0.16.04.4
  Version table:
 *** 2.2.2-5ubuntu0.16.04.4 100
        100 /var/lib/dpkg/status
     2.2.2-5 500
        500 http://ubuntu-mirror.jbstuff.net/ubuntu xenial/universe i386 Packages
libgles1-mesa:
  Installed: (none)
  Candidate: 11.2.0-1ubuntu2
  Version table:
     11.2.0-1ubuntu2 500
        500 http://ubuntu-mirror.jbstuff.net/ubuntu xenial/main i386 Packages
libgles1:
  Installed: (none)
  Candidate: (none)
  Version table:
luis@luis-Ubuntu-16:~$

Manfred Hampl (m-hampl) said : #3

Did you disable some repositories (xenial-updates and/or xenial-security)?

The output
vlc-nox:
   Installed: 2.2.2-5ubuntu0.16.04.4
   Candidate: 2.2.2-5ubuntu0.16.04.4
   Version table:
  *** 2.2.2-5ubuntu0.16.04.4 100
         100 /var/lib/dpkg/status
      2.2.2-5 500
         500 http://ubuntu-mirror.jbstuff.net/ubuntu xenial/universe i386 Packages

shows that you currently have installed a version of vlc-nox from a source that is either not known or not activated any more.

Luis M.Jacinto (ljacinto) said : #4

xenial-updates and/or xenial-security they still in the Repositories.
I remove a few PPAs after you said “For what reason are you adding so many PPAs? Are you sure that you need them”, I remove the ones the names I couldn’t recognize, looks like I did something
wrong.
How to reinstall this apps.
Thank you

Manfred Hampl (m-hampl) said : #5

I am quite sure that you have removed xenial-updates and xenial-security (they would show up in the apt-cache command when enabled).

Re-enable these repositories and issue the command "sudo apt-get update".

This should re-enable installing VLC again (and hopefully also other packages).

Luis M.Jacinto (ljacinto) said : #6

VLC is working but Covertall it says still has broken packages and nor installed.

Terminal Output:
luis@luis-Ubuntu-16:~$ sudo apt-get update
[sudo] password for luis:
Hit:1 http://mirror.wiru.co.za/ubuntu xenial InRelease
Get:2 http://mirror.wiru.co.za/ubuntu xenial-backports InRelease [107 kB]
Hit:3 http://ubuntu.saix.net/ubuntu-archive xenial InRelease
Hit:4 http://archive.canonical.com/ubuntu xenial InRelease
Hit:5 http://ppa.launchpad.net/bit-team/testing/ubuntu xenial InRelease
Get:6 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Get:7 http://ubuntu.saix.net/ubuntu-archive xenial-updates InRelease [109 kB]
Get:8 http://mirror.wiru.co.za/ubuntu xenial-updates InRelease [109 kB]
Get:9 http://ppa.launchpad.net/jonathonf/backports/ubuntu xenial InRelease [18.0 kB]
Get:10 http://mirror.wiru.co.za/ubuntu xenial-backports/main i386 DEP-11 Metadata [3,328 B]
Get:11 http://mirror.wiru.co.za/ubuntu xenial-backports/universe i386 DEP-11 Metadata [5,100 B]
Get:12 http://mirror.wiru.co.za/ubuntu xenial-updates/multiverse i386 DEP-11 Metadata [7,148 B]
Get:13 http://mirror.wiru.co.za/ubuntu xenial-updates/multiverse DEP-11 64x64 Icons [14.3 kB]
Get:14 http://mirror.wiru.co.za/ubuntu xenial-updates/universe i386 Packages [623 kB]
Get:15 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [477 kB]
Get:16 http://ubuntu.saix.net/ubuntu-archive xenial-security InRelease [107 kB]
Hit:17 http://ppa.launchpad.net/librecad-dev/librecad-daily/ubuntu xenial InRelease
Hit:18 http://ppa.launchpad.net/librecad-dev/librecad-stable/ubuntu xenial InRelease
Hit:19 http://ppa.launchpad.net/libreoffice/libreoffice-5-4/ubuntu xenial InRelease
Get:20 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [233 kB]
Hit:21 http://ppa.launchpad.net/qbittorrent-team/qbittorrent-stable/ubuntu xenial InRelease
Get:22 http://ppa.launchpad.net/jonathonf/backports/ubuntu xenial/main Sources [31.9 kB]
Get:23 http://ubuntu.saix.net/ubuntu-archive xenial-updates/multiverse i386 DEP-11 Metadata [7,148 B]
Get:24 http://security.ubuntu.com/ubuntu xenial-security/main i386 DEP-11 Metadata [67.7 kB]
Get:25 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [68.0 kB]
Get:26 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [316 kB]
Get:27 http://ubuntu.saix.net/ubuntu-archive xenial-updates/multiverse DEP-11 64x64 Icons [14.3 kB]
Get:28 http://security.ubuntu.com/ubuntu xenial-security/universe i386 DEP-11 Metadata [107 kB]
Get:29 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [142 kB]
Get:30 http://ppa.launchpad.net/jonathonf/backports/ubuntu xenial/main i386 Packages [39.0 kB]
Get:31 http://ubuntu.saix.net/ubuntu-archive xenial-security/main i386 Packages [477 kB]
Get:32 http://mirror.wiru.co.za/ubuntu xenial-updates/universe Translation-en [276 kB]
Get:33 http://mirror.wiru.co.za/ubuntu xenial-updates/universe i386 DEP-11 Metadata [250 kB]
Get:34 http://ubuntu.saix.net/ubuntu-archive xenial-security/main Translation-en [233 kB]
Get:35 http://mirror.wiru.co.za/ubuntu xenial-updates/universe DEP-11 64x64 Icons [333 kB]
Get:36 http://ubuntu.saix.net/ubuntu-archive xenial-security/main i386 DEP-11 Metadata [67.7 kB]
Get:37 http://ubuntu.saix.net/ubuntu-archive xenial-security/main DEP-11 64x64 Icons [68.0 kB]
Get:38 http://mirror.wiru.co.za/ubuntu xenial-updates/main i386 Packages [759 kB]
Get:39 http://ubuntu.saix.net/ubuntu-archive xenial-security/universe i386 Packages [316 kB]
Get:40 http://mirror.wiru.co.za/ubuntu xenial-updates/main Translation-en [345 kB]
Get:41 http://ubuntu.saix.net/ubuntu-archive xenial-security/universe i386 DEP-11 Metadata [107 kB]
Get:42 http://mirror.wiru.co.za/ubuntu xenial-updates/main i386 DEP-11 Metadata [320 kB]
Get:43 http://ubuntu.saix.net/ubuntu-archive xenial-security/universe DEP-11 64x64 Icons [142 kB]
Get:44 http://mirror.wiru.co.za/ubuntu xenial-updates/main DEP-11 64x64 Icons [232 kB]
Fetched 6,636 kB in 32s (207 kB/s)
Reading package lists... Done
luis@luis-Ubuntu-16:~$

Manfred Hampl (m-hampl) said : #7

What output do you receive for the commands

sudo dpkg --audit
sudo apt-get install convertall
apt-cache policy convertall

And, additionally, you still seems to have a weird mixture of different repository servers in your sources.list configuration, see also https://answers.launchpad.net/ubuntu/+question/672642

Luis M.Jacinto (ljacinto) said : #8

Tried to correct the repositories don’t know if 100% correct.

Terminal output:

luis@luis-Ubuntu-16:~$ sudo dpkg --audit
[sudo] password for luis:
luis@luis-Ubuntu-16:~$ sudo apt-get install convertall
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 convertall : Depends: python3-pyqt4 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
luis@luis-Ubuntu-16:~$ apt-cache policy convertall
convertall:
  Installed: (none)
  Candidate: 0.6.0-1
  Version table:
     0.6.0-1 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/universe i386 Packages
        100 /var/lib/dpkg/status
luis@luis-Ubuntu-16:~$

Manfred Hampl (m-hampl) said : #9

What is the output of

apt-cache policy python3-pyqt4
apt-get --simulate install python3-pyqt4

Luis M.Jacinto (ljacinto) said : #10

luis@luis-Ubuntu-16:~$ apt-cache policy python3-pyqt4
python3-pyqt4:
  Installed: (none)
  Candidate: 4.11.4+dfsg-1build4
  Version table:
     4.11.4+dfsg-1build4 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/universe i386 Packages
luis@luis-Ubuntu-16:~$ apt-get --simulate install python3-pyqt4
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python3-pyqt4 : Depends: libqt4-dbus (>= 4:4.8.0-1~) but it is not going to be installed
                 Depends: libqt4-designer (>= 4:4.8.0-1~) but it is not going to be installed
                 Depends: libqt4-help (>= 4:4.8.0-1~) but it is not going to be installed
                 Depends: libqt4-scripttools (>= 4:4.8.0-1~) but it is not going to be installed
                 Depends: libqt4-svg (>= 4:4.8.0-1~) but it is not going to be installed
                 Depends: libqt4-test (>= 4:4.8.0-1~) but it is not going to be installed
                 Depends: libqtwebkit4 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
luis@luis-Ubuntu-16:~$

Manfred Hampl (m-hampl) said : #11

ok, let's go a step further,
what is the output of the commands

apt-cache policy libqt4-dbus libqt4-designer libqt4-help libqt4-scripttools libqt4-svg libqt4-test libqtwebkit4

apt-get --simulate install python3-pyqt4 libqt4-dbus libqt4-designer libqt4-help libqt4-scripttools libqt4-svg libqt4-test libqtwebkit4

Luis M.Jacinto (ljacinto) said : #12

luis@luis-Ubuntu-16:~$ apt-cache policy libqt4-dbus libqt4-designer libqt4-help libqt4-scripttools libqt4-svg libqt4-test libqtwebkit4
libqt4-dbus:
  Installed: (none)
  Candidate: 4:4.8.7+dfsg-5ubuntu2
  Version table:
     4:4.8.7+dfsg-5ubuntu2 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/main i386 Packages
libqt4-designer:
  Installed: (none)
  Candidate: 4:4.8.7+dfsg-5ubuntu2
  Version table:
     4:4.8.7+dfsg-5ubuntu2 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/main i386 Packages
libqt4-help:
  Installed: (none)
  Candidate: 4:4.8.7+dfsg-5ubuntu2
  Version table:
     4:4.8.7+dfsg-5ubuntu2 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/main i386 Packages
libqt4-scripttools:
  Installed: (none)
  Candidate: 4:4.8.7+dfsg-5ubuntu2
  Version table:
     4:4.8.7+dfsg-5ubuntu2 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/main i386 Packages
libqt4-svg:
  Installed: (none)
  Candidate: 4:4.8.7+dfsg-5ubuntu2
  Version table:
     4:4.8.7+dfsg-5ubuntu2 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/main i386 Packages
libqt4-test:
  Installed: (none)
  Candidate: 4:4.8.7+dfsg-5ubuntu2
  Version table:
     4:4.8.7+dfsg-5ubuntu2 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/main i386 Packages
libqtwebkit4:
  Installed: (none)
  Candidate: 2.3.2-0ubuntu11
  Version table:
     2.3.2-0ubuntu11 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/universe i386 Packages
luis@luis-Ubuntu-16:~$ apt-get --simulate install python3-pyqt4 libqt4-dbus libqt4-designer libqt4-help libqt4-scripttools libqt4-svg libqt4-test libqtwebkit4
NOTE: This is only a simulation!
      apt-get needs root privileges for real execution.
      Keep also in mind that locking is deactivated,
      so don't depend on the relevance to the real current situation!
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libqt4-dbus : Depends: libqtdbus4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
               Depends: qdbus (= 4:4.8.7+dfsg-5ubuntu2) but it is not going to be installed
 libqt4-designer : Depends: libqt4-script (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
                   Depends: libqt4-xml (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
                   Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
                   Depends: libqtgui4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
 libqt4-help : Depends: libqt4-network (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
               Depends: libqt4-sql (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
               Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
               Depends: libqtgui4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
 libqt4-scripttools : Depends: libqt4-script (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
                      Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
                      Depends: libqtgui4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
 libqt4-svg : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
              Depends: libqtgui4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
 libqt4-test : Depends: libqtcore4 (= 4:4.8.7+dfsg-5ubuntu2) but 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 is to be installed
 libqtwebkit4 : Depends: libqt4-opengl (>= 4:4.5.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
luis@luis-Ubuntu-16:~$

Manfred Hampl (m-hampl) said : #13

It seems that you again have activated a PPA which now leads to conflicts.

What is the output of

apt-cache policy libqt4-dbus libqtdbus4

Luis M.Jacinto (ljacinto) said : #14

Previous I said tried to correct the entries on repositories don’t know if 100% correct.
Change the repository server to ftp.leg.uct.ac.za and had entries that are missing.

luis@luis-Ubuntu-16:~$ apt-cache policy libqt4-dbus libqtdbus4
libqt4-dbus:
  Installed: (none)
  Candidate: 4:4.8.7+dfsg-5ubuntu2
  Version table:
     4:4.8.7+dfsg-5ubuntu2 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/main i386 Packages
libqtdbus4:
  Installed: 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1
  Candidate: 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1
  Version table:
 *** 4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1 100
        100 /var/lib/dpkg/status
     4:4.8.7+dfsg-5ubuntu2 500
        500 http://ftp.leg.uct.ac.za/ubuntu xenial/main i386 Packages
luis@luis-Ubuntu-16:~$

Manfred Hampl (m-hampl) said : #15

It is not "VLC broken in Synaptic" as you wrote in the question title, but you have broken your package management configuration.

The version of libqtdbus4 (4:4.8.7+dfsg-7ubuntu1~xenialoverlay1~1) is not the one provided in the standard Ubuntu repositories, but seems to come from a PPA which you apparently have already disabled from your configuration.

The root cause of this problem is that you have added a PPA, installed some packages form that PPA, and then have disabled that PPA from your configuration, keeping the installed package versions.

Now you have a discrepancy between the package versions already installed from that PPA, and those that have to be added, and where the package management system can only find the standard Ubuntu-provided version.

Solution:
- Either uninstall all packages that stem from that PPA and install the standard Ubuntu-provided version
- Or re-enable that PPA (probably ppa:kubuntu-ppa/backports or ppa:trebelnik-stefina/qt5)

Luis M.Jacinto (ljacinto) said : #16

After Added ppa-kubuntu was able to install ConvertAll application.
Thank you very much for the great support