Ubuntu 16.04 messed up after update

Asked by gimpo on 2018-08-05

Hallo,

last 24 July, after downloading and updating the packages suggested by the Update Manager, the graphic interface on my PC is completely messed up.
Everything dealing with text (menu item, menu names, dialog windows, etc) is no more visible. One has to go over the items with mouse pointer to get them refreshed. Also, all text backgrounds seems messed too, the background color is changed to transparent, in other cases it has changed to black.
Even the simple GEdit text-editor is messed. Text disappears when moving the scrollbars, one has to select the text with the mouse to make it visible.
All the application seems involved in this problem.

Using the Unity or the Xfce desktop manager seems not important: the problem remains the same on both managers.
I have applied also all the updates suggested in the "Software" manager, but the bug is still there.

Using the PC has become quickly frustrating and irritating. How can I solve this problem?

(See also my question on Ask-Ubuntu: https://askubuntu.com/questions/1060710/messed-menus-labels-buttons-colors-after-latest-update-on-july-2018)

giulio@ubu:~$ lsb_release -a
LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-10-03
Last query:
2018-10-03
Last reply:
2018-09-25

If you boot an older kernel is it OK?

gimpo (giulio-buccini) said : #2

No GRUB menu by holding the shift-key down at the boot. I'm searching on internet how to achieve this.
Please stay tuned.

Note:
I use the PC for my job everyday, so I'm extreme careful about any change that could "damage" the O.S. No big time for experiments in this period; I'm under pressure and I need the PC (even working badly...)

gimpo (giulio-buccini) said : #3

Adding to my previous message:
I suspect that I have a UEFI boot (my PC is quite recent).

Launchpad Janitor (janitor) said : #4

This question was expired because it remained in the 'Needs information' state without activity for the last 15 days.

gimpo (giulio-buccini) said : #5

I cannot find a way to enable an older kernel version to make the test you required. Can you help me about this?
I tried to get used to the messed screen, but the PC is unusable in this conditions... :( :( :(

Hold SHIFT at boot and then use cursor keys

gimpo (giulio-buccini) said : #7

My current kernel version is below reported:

giulio@ubu:~$ uname -r
4.4.0-134-generic

How to list available older kernels?

gimpo (giulio-buccini) said : #8

Pressing the SHIFT at boot doesn't work for. I have a UEFI system (but don't ask me what it means... )

Manfred Hampl (m-hampl) said : #9

It does not matter whether you have an UEFI System or not. Pressing the shift key at the right moment should bring up the grub menu in any case. Try different timing, e.g. pressing the shift key earlier or later, keep it pressed longer, ...

Another possibility would be editing the /etc/default/grub configuration file and commenting out the line with GRUB_HIDDEN_TIMEOUT, and changing GRUB_HIDDEN_TIMEOUT_QUIET from "true" to "false".

gimpo (giulio-buccini) said : #10

Changing GRUB_HIDDEN_TIMEOUT_QUIET from true to false had no effect: the screen remains black until the login screen appears.

I strongly suspect that the grub file is not used at all. Here below the contents of the file:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Manfred Hampl (m-hampl) said : #11

Sorry, my instructions for the grub configuration file were inaccurate.

The lines in question inside /etc/default/grub should look like this:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10

And after that change you have to execute the command

sudo update-grub

After the next reboot the grub menu will be shown.

gimpo (giulio-buccini) said : #12

Now it works, thanks!

By selecting the "Advanced Options" item I can see a list of available kernels:

linux 4.4.0-134
.
.
.
.
.
linux 4.4.0-59

They seems all quite recent. Which one I should select?

Try a few

gimpo (giulio-buccini) said : #14

In other words: how I can select the kernel I was using before last 24 July?
(I cannot find an exact date of release for the various kernels on internet)

Manfred Hampl (m-hampl) said : #15

Kernel versions are published with increasing numbers.
If you now have 4.4.0-134-generic, then the largest number below that must have been the one before the last upgrade.

The purpose of this exercise (try an older kernel) is to find out whether the issue was caused by the new kernel version, or whether perhaps an update of another package has caused your problem.

Manfred Hampl (m-hampl) said : #16

Remark: the publishing history for the kernel version is here:
https://launchpad.net/ubuntu/+source/linux-meta/+publishinghistory

gimpo (giulio-buccini) said : #17

As I understand, the most recent I'm using as default is the linux 4.4.0-134-generic.
I tested three different versions:

linux 4.4.0-133-generic -> screen still messed
linux 4.4.0-104-generic -> screen still messed
linux 4.4.0-59-generic -> screen still messed

There are no versions older than the one numbered as 59.

So I think the mess with colors, text and background comes from somewhere else...
If I remember right, while updating, I saw "something" about "Xorg" or "Xserver". Maybe the problems comes from something related with graphics management?

Manfred Hampl (m-hampl) said : #18

For showing all updates that have been done recently, what is the output of the command

tail -n 30 /var/log/apt/history.log

gimpo (giulio-buccini) said : #19

giulio@ubu:~$ tail -n 30 /var/log/apt/history.log

Start-Date: 2018-09-05 08:29:32
Commandline: /usr/bin/unattended-upgrade
Install: linux-headers-4.4.0-134:amd64 (4.4.0-134.160, automatic), linux-image-extra-4.4.0-134-generic:amd64 (4.4.0-134.160, automatic), linux-headers-4.4.0-134-generic:amd64 (4.4.0-134.160, automatic), linux-image-4.4.0-134-generic:amd64 (4.4.0-134.160, automatic)
Upgrade: libopenjp2-7:amd64 (2.1.0-2.1ubuntu0.1, 2.1.2-1.1+deb9u2build0.1), poppler-utils:amd64 (0.41.0-0ubuntu1.7, 0.41.0-0ubuntu1.8), libhdf5-openmpi-10:amd64 (1.8.16+docs-4ubuntu1, 1.8.16+docs-4ubuntu1.1), intel-microcode:amd64 (3.20180425.1~ubuntu0.16.04.2, 3.20180807a.0ubuntu0.16.04.1), linux-headers-generic:amd64 (4.4.0.133.139, 4.4.0.134.140), linux-libc-dev:amd64 (4.4.0-133.159, 4.4.0-134.160), libavutil-ffmpeg54:amd64 (7:2.8.14-0ubuntu0.16.04.1, 7:2.8.15-0ubuntu0.16.04.1), libavfilter-ffmpeg5:amd64 (7:2.8.14-0ubuntu0.16.04.1, 7:2.8.15-0ubuntu0.16.04.1), linux-image-generic:amd64 (4.4.0.133.139, 4.4.0.134.140), libgd3:amd64 (2.1.1-4ubuntu0.16.04.8, 2.1.1-4ubuntu0.16.04.10), libgd3:i386 (2.1.1-4ubuntu0.16.04.8, 2.1.1-4ubuntu0.16.04.10), libpoppler-qt4-4:amd64 (0.41.0-0ubuntu1.7, 0.41.0-0ubuntu1.8), libpoppler-qt5-1:amd64 (0.41.0-0ubuntu1.7, 0.41.0-0ubuntu1.8), libswresample-ffmpeg1:amd64 (7:2.8.14-0ubuntu0.16.04.1, 7:2.8.15-0ubuntu0.16.04.1), libpq5:amd64 (9.5.13-0ubuntu0.16.04, 9.5.14-0ubuntu0.16.04), libx11-6:amd64 (2:1.6.3-1ubuntu2, 2:1.6.3-1ubuntu2.1), libx11-6:i386 (2:1.6.3-1ubuntu2, 2:1.6.3-1ubuntu2.1), libpostproc-ffmpeg53:amd64 (7:2.8.14-0ubuntu0.16.04.1, 7:2.8.15-0ubuntu0.16.04.1), chromium-codecs-ffmpeg-extra:amd64 (68.0.3440.75-0ubuntu0.16.04.1, 68.0.3440.106-0ubuntu0.16.04.1), libwebkit2gtk-4.0-37:amd64 (2.20.3-0ubuntu0.16.04.1, 2.20.5-0ubuntu0.16.04.1), wpasupplicant:amd64 (2.4-0ubuntu6.2, 2.4-0ubuntu6.3), libx11-data:amd64 (2:1.6.3-1ubuntu2, 2:1.6.3-1ubuntu2.1), libswscale-ffmpeg3:amd64 (7:2.8.14-0ubuntu0.16.04.1, 7:2.8.15-0ubuntu0.16.04.1), libavresample-ffmpeg2:amd64 (7:2.8.14-0ubuntu0.16.04.1, 7:2.8.15-0ubuntu0.16.04.1), libavcodec-ffmpeg56:amd64 (7:2.8.14-0ubuntu0.16.04.1, 7:2.8.15-0ubuntu0.16.04.1), gir1.2-webkit2-4.0:amd64 (2.20.3-0ubuntu0.16.04.1, 2.20.5-0ubuntu0.16.04.1), libavformat-ffmpeg56:amd64 (7:2.8.14-0ubuntu0.16.04.1, 7:2.8.15-0ubuntu0.16.04.1), libhdf5-10:amd64 (1.8.16+docs-4ubuntu1, 1.8.16+docs-4ubuntu1.1), libpoppler-glib8:amd64 (0.41.0-0ubuntu1.7, 0.41.0-0ubuntu1.8), libpoppler58:amd64 (0.41.0-0ubuntu1.7, 0.41.0-0ubuntu1.8), libjavascriptcoregtk-4.0-18:amd64 (2.20.3-0ubuntu0.16.04.1, 2.20.5-0ubuntu0.16.04.1), linux-generic:amd64 (4.4.0.133.139, 4.4.0.134.140), libwebkit2gtk-4.0-37-gtk2:amd64 (2.20.3-0ubuntu0.16.04.1, 2.20.5-0ubuntu0.16.04.1), libx11-xcb1:amd64 (2:1.6.3-1ubuntu2, 2:1.6.3-1ubuntu2.1), libx11-xcb1:i386 (2:1.6.3-1ubuntu2, 2:1.6.3-1ubuntu2.1), gir1.2-javascriptcoregtk-4.0:amd64 (2.20.3-0ubuntu0.16.04.1, 2.20.5-0ubuntu0.16.04.1)
End-Date: 2018-09-05 08:31:58
giulio@ubu:~$

gimpo (giulio-buccini) said : #20

But keep in account that the Update Manager has applied another update... around three weeks ago (If I remember right). That time I didn't notice any update about graphic stuff.

Again, that second update didn't solve the messed screen problem.

Manfred Hampl (m-hampl) said : #21

I did not realize that the problem goes back already so long - July 24.
In that case the tail command does not make sense.

You have to look into /var/log/apt/history.log (e.g. by opening it with an editor) and search for the updates done on that date.

gimpo (giulio-buccini) said : #22

Here the apt updates applied on July 24:

Start-Date: 2018-07-24 08:43:37
Commandline: /usr/bin/unattended-upgrade
Install: linux-headers-4.4.0-130:amd64 (4.4.0-130.156, automatic), linux-image
extra-4.4.0-130-generic:amd64 (4.4.0-130.156, automatic), linux-headers-4.4.0-130
generic:amd64 (4.4.0-130.156, automatic), linux-image-4.4.0-130-generic:amd64
(4.4.0-130.156, automatic)
Upgrade: libpolkit-gobject-1-0:amd64 (0.105-14.1, 0.105-14.1ubuntu0.1), libmpx0:amd64
(5.4.0-6ubuntu1~16.04.9, 5.4.0-6ubuntu1~16.04.10), libsoup-gnome2.4-1:amd64(2.52.2-1ubuntu0.2, 2.52.2-1ubuntu0.3), libgcc-5-dev:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), libimage-magick-perl:amd64 (8:6.8.9.9-7ubuntu5.11,
8:6.8.9.9-7ubuntu5.12), libcups2:amd64 (2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5),
libcups2:i386 (2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5), linux-headers-generic:amd64
(4.4.0.128.134, 4.4.0.130.136), linux-libc-dev:amd64 (4.4.0-128.154, 4.4.0-130.156), gir1.2
soup-2.4:amd64 (2.52.2-1ubuntu0.2, 2.52.2-1ubuntu0.3), openssl:amd64
(1.0.2g-1ubuntu4.12, 1.0.2g-1ubuntu4.13), libimage-magick-q16-perl:amd64
(8:6.8.9.9-7ubuntu5.11, 8:6.8.9.9-7ubuntu5.12), imagemagick:amd64
(8:6.8.9.9-7ubuntu5.11, 8:6.8.9.9-7ubuntu5.12), libarchive-zip-perl:amd64 (1.56-2,
1.56-2ubuntu0.1), linux-image-generic:amd64 (4.4.0.128.134, 4.4.0.130.136),
libobjc4:amd64 (5.4.0-6ubuntu1~16.04.9, 5.4.0-6ubuntu1~16.04.10), cpp-5:amd64
(5.4.0-6ubuntu1~16.04.9, 5.4.0-6ubuntu1~16.04.10), libmagickwand-6.q16-2:amd64
(8:6.8.9.9-7ubuntu5.11, 8:6.8.9.9-7ubuntu5.12), libitm1:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), dnsmasq-base:amd64 (2.75-1ubuntu0.16.04.4,
2.75-1ubuntu0.16.04.5), libpolkit-agent-1-0:amd64 (0.105-14.1, 0.105-14.1ubuntu0.1),
libcilkrts5:amd64 (5.4.0-6ubuntu1~16.04.9, 5.4.0-6ubuntu1~16.04.10), cups-server
common:amd64 (2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5), libasan2:amd64
(5.4.0-6ubuntu1~16.04.9, 5.4.0-6ubuntu1~16.04.10), libquadmath0:amd64
(5.4.0-6ubuntu1~16.04.9, 5.4.0-6ubuntu1~16.04.10), cups-common:amd64
(2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5), libsoup2.4-1:amd64 (2.52.2-1ubuntu0.2,
2.52.2-1ubuntu0.3), libpng12-dev:amd64 (1.2.54-1ubuntu1, 1.2.54-1ubuntu1.1),
thunderbird-gnome-support:amd64 (1:52.8.0+build1-0ubuntu0.16.04.1,
1:52.9.1+build3-0ubuntu0.16.04.1), gcc-5-base:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), gcc-5-base:i386 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), imagemagick-6.q16:amd64 (8:6.8.9.9-7ubuntu5.11,
8:6.8.9.9-7ubuntu5.12), libstdc++-5-dev:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), libtsan0:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), libmagickcore-6.q16-2-extra:amd64 (8:6.8.9.9-7ubuntu5.11,
8:6.8.9.9-7ubuntu5.12), libubsan0:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), libzzip-0-13:amd64 (0.13.62-3ubuntu0.16.04.1,
0.13.62-3ubuntu0.16.04.2), cups-ppdc:amd64 (2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5),
g++-5:amd64 (5.4.0-6ubuntu1~16.04.9, 5.4.0-6ubuntu1~16.04.10), libcupsmime1:amd64
(2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5), libgfortran3:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), thunderbird-locale-en-us:amd64
(1:52.8.0+build1-0ubuntu0.16.04.1, 1:52.9.1+build3-0ubuntu0.16.04.1), firefox-locale
en:amd64 (60.0.2+build1-0ubuntu0.16.04.1, 61.0.1+build1-0ubuntu0.16.04.1), chromium
codecs-ffmpeg-extra:amd64 (66.0.3359.181-0ubuntu0.16.04.1,
67.0.3396.99-0ubuntu0.16.04.2), gcc-5:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), liblsan0:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), libgomp1:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), libobjc-5-dev:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), libpolkit-backend-1-0:amd64 (0.105-14.1, 0.105-14.1ubuntu0.1),
libmagickcore-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.11, 8:6.8.9.9-7ubuntu5.12),
thunderbird:amd64 (1:52.8.0+build1-0ubuntu0.16.04.1, 1:52.9.1+build3-0ubuntu0.16.04.1),
libjpeg-turbo8:amd64 (1.4.2-0ubuntu3, 1.4.2-0ubuntu3.1), libjpeg-turbo8:i386
(1.4.2-0ubuntu3, 1.4.2-0ubuntu3.1), policykit-1:amd64 (0.105-14.1, 0.105-14.1ubuntu0.1),
libcupsppdc1:amd64 (2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5), firefox:amd64
(60.0.2+build1-0ubuntu0.16.04.1, 61.0.1+build1-0ubuntu0.16.04.1), dns-root-data:amd64
(2015052300+h+1, 2018013001~16.04.1), imagemagick-common:amd64
(8:6.8.9.9-7ubuntu5.11, 8:6.8.9.9-7ubuntu5.12), libmagick++-6.q16-5v5:amd64
(8:6.8.9.9-7ubuntu5.11, 8:6.8.9.9-7ubuntu5.12), libjasper1:amd64 (1.900.1
debian1-2.4ubuntu1.1, 1.900.1-debian1-2.4ubuntu1.2), cups-bsd:amd64 (2.1.3-4ubuntu0.4,
2.1.3-4ubuntu0.5), cups-core-drivers:amd64 (2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5),
libatomic1:amd64 (5.4.0-6ubuntu1~16.04.9, 5.4.0-6ubuntu1~16.04.10), cupsdaemon:amd64 (2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5), libcc1-0:amd64
(5.4.0-6ubuntu1~16.04.9, 5.4.0-6ubuntu1~16.04.10), libcupsimage2:amd64
(2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5), libexiv2-14:amd64 (0.25-2.1ubuntu16.04.1,
0.25-2.1ubuntu16.04.2), libstdc++6:amd64 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), libstdc++6:i386 (5.4.0-6ubuntu1~16.04.9,
5.4.0-6ubuntu1~16.04.10), cups:amd64 (2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5),
libcupscgi1:amd64 (2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5), cups-client:amd64
(2.1.3-4ubuntu0.4, 2.1.3-4ubuntu0.5), thunderbird-locale-en:amd64
(1:52.8.0+build1-0ubuntu0.16.04.1, 1:52.9.1+build3-0ubuntu0.16.04.1), perlmagick:amd64
(8:6.8.9.9-7ubuntu5.11, 8:6.8.9.9-7ubuntu5.12), linux-generic:amd64 (4.4.0.128.134,
4.4.0.130.136), libpng12-0:amd64 (1.2.54-1ubuntu1, 1.2.54-1ubuntu1.1), libpng12-0:i386
(1.2.54-1ubuntu1, 1.2.54-1ubuntu1.1), libssl1.0.0:amd64 (1.0.2g-1ubuntu4.12,
1.0.2g-1ubuntu4.13), libssl1.0.0:i386 (1.0.2g-1ubuntu4.12, 1.0.2g-1ubuntu4.13)
End-Date: 2018-07-24 08:50:50

gimpo (giulio-buccini) said : #23

Here something 2 days after: July 29.
I see something related to graphics mesa libs or I'm wrong?

Start-Date: 2018-07-29 19:08:19
Commandline: aptdaemon role='role-commit-packages' sender=':1.86'
Install: libocct-ocaf-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1, automatic), libocct-data
exchange-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1, automatic), libocct
visualization-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1, automatic), libllvm6.0:amd64
(1:6.0-1ubuntu2~16.04.1, automatic), libllvm6.0:i386 (1:6.0-1ubuntu2~16.04.1, automatic),
libocct-modeling-algorithms-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1, automatic), libocct
foundation-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1, automatic), libocct-modeling
data-7.3:amd64 (7.3.0-0ppa4~ubuntu16.04.1, automatic)
Upgrade: tex-common:amd64 (6.04, 6.04ubuntu1), libfdisk1:amd64 (2.27.1-6ubuntu3.4,
2.27.1-6ubuntu3.6), libdrm-nouveau2:amd64 (2.4.83-1~16.04.1, 2.4.91-2~16.04.1), libdrm
nouveau2:i386 (2.4.83-1~16.04.1, 2.4.91-2~16.04.1), linux-libc-dev:amd64 (4.4.0-130.156,
4.4.0-131.157), adobe-flash-properties-gtk:amd64 (1:20180607.1-0ubuntu0.16.04.1,
1:20180710.1-0ubuntu0.16.04.1), libglapi-mesa:amd64 (17.2.8-0ubuntu0~16.04.1,
18.0.5-0ubuntu0~16.04.1), libglapi-mesa:i386 (17.2.8-0ubuntu0~16.04.1,
18.0.5-0ubuntu0~16.04.1), snapd:amd64 (2.32.9, 2.34.2), snap-confine:amd64 (2.32.9,
2.34.2), skypeforlinux:amd64 (8.24.0.2, 8.26.0.70), libegl1-mesa:amd64
(17.2.8-0ubuntu0~16.04.1, 18.0.5-0ubuntu0~16.04.1), libgbm1:amd64
(17.2.8-0ubuntu0~16.04.1, 18.0.5-0ubuntu0~16.04.1), adobe-flashplugin:amd64
(1:20180607.1-0ubuntu0.16.04.1, 1:20180710.1-0ubuntu0.16.04.1), libdrm
amdgpu1:amd64 (2.4.83-1~16.04.1, 2.4.91-2~16.04.1), libdrm-amdgpu1:i386
(2.4.83-1~16.04.1, 2.4.91-2~16.04.1), libblkid1:amd64 (2.27.1-6ubuntu3.4,
2.27.1-6ubuntu3.6), libblkid1:i386 (2.27.1-6ubuntu3.4, 2.27.1-6ubuntu3.6), libuuid1:amd64
(2.27.1-6ubuntu3.4, 2.27.1-6ubuntu3.6), libuuid1:i386 (2.27.1-6ubuntu3.4,
2.27.1-6ubuntu3.6), libwayland-egl1-mesa:amd64 (17.2.8-0ubuntu0~16.04.1,18.0.5-0ubuntu0~16.04.1), ubuntu-core-launcher:amd64 (2.32.9, 2.34.2), libdrm2:amd64
(2.4.83-1~16.04.1, 2.4.91-2~16.04.1), libdrm2:i386 (2.4.83-1~16.04.1, 2.4.91-2~16.04.1),
libsmartcols1:amd64 (2.27.1-6ubuntu3.4, 2.27.1-6ubuntu3.6), freecad:amd64
(1:0.17.13522-1ppa1~ubuntu16.04.1, 1:0.17.13528-1ppa3~ubuntu16.04.1), libgl1-mesa
dri:amd64 (17.2.8-0ubuntu0~16.04.1, 18.0.5-0ubuntu0~16.04.1), libgl1-mesa-dri:i386
(17.2.8-0ubuntu0~16.04.1, 18.0.5-0ubuntu0~16.04.1), libosmesa6:amd64
(17.2.8-0ubuntu0~16.04.1, 18.0.5-0ubuntu0~16.04.1), libosmesa6:i386
(17.2.8-0ubuntu0~16.04.1, 18.0.5-0ubuntu0~16.04.1), libgl1-mesa-glx:amd64
(17.2.8-0ubuntu0~16.04.1, 18.0.5-0ubuntu0~16.04.1), libgl1-mesa-glx:i386
(17.2.8-0ubuntu0~16.04.1, 18.0.5-0ubuntu0~16.04.1), libdrm-intel1:amd64
(2.4.83-1~16.04.1, 2.4.91-2~16.04.1), libdrm-intel1:i386 (2.4.83-1~16.04.1,
2.4.91-2~16.04.1), apt-transport-https:amd64 (1.2.26, 1.2.27), libdrm-radeon1:amd64
(2.4.83-1~16.04.1, 2.4.91-2~16.04.1), libdrm-radeon1:i386 (2.4.83-1~16.04.1,
2.4.91-2~16.04.1), mesa-vdpau-drivers:amd64 (17.2.8-0ubuntu0~16.04.1,
18.0.5-0ubuntu0~16.04.1), base-files:amd64 (9.4ubuntu4.6, 9.4ubuntu4.7), libdrm
common:amd64 (2.4.83-1~16.04.1, 2.4.91-2~16.04.1)
Remove: libocct-ocaf-7.2:amd64 (7.2.0-0ppa6~ubuntu16.04.1), libocct-data
exchange-7.2:amd64 (7.2.0-0ppa6~ubuntu16.04.1), libocct-visualization-7.2:amd64
(7.2.0-0ppa6~ubuntu16.04.1), libocct-modeling-algorithms-7.2:amd64
(7.2.0-0ppa6~ubuntu16.04.1), libocct-foundation-7.2:amd64 (7.2.0-0ppa6~ubuntu16.04.1),
libocct-modeling-data-7.2:amd64 (7.2.0-0ppa6~ubuntu16.04.1)
End-Date: 2018-07-29 19:11:10

Manfred Hampl (m-hampl) said : #24

Are you able to tell the exact date, when this problem started?

Another test:
If you log in as guest session, or as a different user (create one for testing if necessary), do you see the same issue?

gimpo (giulio-buccini) said : #25

I have created a new test user, but the problem is still there with both installed desktop managers (Gnome and Xfce)... :( :( :(

My question on "Ask Ubuntu" was posted on July 30, so I think the problem has manifested two or three days before. In any case, I remember perfectly that I noticed something wrong immediately after the Update Manager finished his work and I have restarted the PC as suggested.

I'm really sorry that I cannot be more precise about the exact date. Many days has passed, but I had to go on holidays, otherwise my wife would kill me.

Manfred Hampl (m-hampl) said : #26

Ok, understood.

At askubuntu you provided information about your graphics adapter:

giulio@ubu:~$ sudo lshw -C display
[sudo] password for giulio:
  *-display
       description: VGA compatible controller
       product: GM107 [GeForce GTX 750 Ti]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a2
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:31 memory:fd000000-fdffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:fe000000-fe07ffff

Have you already considered trying the dedicated nvidia driver instead of the opensource nouveau driver?

gimpo (giulio-buccini) said : #27

Some years passed from the time of first installation, but there was a reason for sure if installed the opensource in place of the dedicated driver from the vendor... Maybe the dedicated software was not working or not available.

Manfred Hampl (m-hampl) said : #28

To be honest, whatever I can suggest, it is a bit groping in the dark.

Just as another test: Can you create an installer DVD (or bootable USB stick) with Ubuntu 18.04 and boot it in the "try Ubuntu without installing" mode?

Does this show the same strange behaviour?

gimpo (giulio-buccini) said : #29

I will masterize a DVD tomorrow, today is sunday and shops are closed. I need to buy a writable DVD.

I've found a driver for the GeForce GTX 750 Ti here:
https://www.nvidia.com/Download/driverResults.aspx/137276/en-us

I'm quite terrified from installing it, since the big list of bugs of the version 390 I've found here too:
https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

In one case the PC was not booting anymore.
Unfortunately, in this days I'm working hard on the PC. I need it. Wasting days and days in trying to reinstall everything would be a "financial" disaster for me.
Yes, I've a backup of all my data, but it would not so trivial to reinstall and configure some applications I use...

gimpo (giulio-buccini) said : #30

Hallo again,

I was very busy in this dasy, but at the end I've found the time to make the test.
I've downloaded and masterized a DVD with the desktop version of Ubuntu 18.04.01 LTS (amd 64 bit).

By starting the liveCD session I didn't notice any graphic problem: background colors are ok, dialogs are ok, menu items of tested applications (Calc, gedit, Writer, etc.) are displayed correctly. By scrolling up/down a text on gedit doesn't make it disappearing.
ALso, all PDF docs are displayed correctly by the default pdf-viewer program.

In one word: version 18.04 work

So seems that default graphics driver and/or libs of Ubuntu are working fine in this version. There is a way to adopt them on my 16.04?

Manfred Hampl (m-hampl) said : #31

I recommend that you create backup copies of all your important files to an external medium and then do a clean new installation of Ubuntu 18.04.

gimpo (giulio-buccini) said : #32

Well... this is not a great solution for an LT version...
This is something like "Your horse hat fever? Kill it and buy a new one" :)

I've spent a lot of time on it by installing all I need for working. I don't want to put all my efforts in the trash-bin.

Thanks anyway.

Manfred Hampl (m-hampl) said : #33

Have you already tried the dedicated nvidia driver instead of the opensource nouveau driver?

gimpo (giulio-buccini) said : #34

I will give to propritary Nvidia driver a try...

Do you know how I can restore the previous driver in case the PC crashes at the startup?
I can do something about that by starting Ubuntu in "recovery mode" at bios screen?

gimpo (giulio-buccini) said : #35

By starting "Software & Updates" -> "Additional drivers" I see three options available:

- "Using NVIDIA binary driver - version 384.130 (proprietary, tested)"
- "Using NVIDIA binary driver - version 340.104 (proprietary)"
- "Using X.org X server - Nouveau display driver (open source)"

At the moment, the third option is selected.
Do you suggest I try one of this, instead of the version 390.87 suggested from the NVIDIA website?

Best Manfred Hampl (m-hampl) said : #36

I suggest using one of these versions (because they are integrated in the Ubuntu package management system) and not a version downloaded from the NVidia web pages (because that is not adapted to Ubuntu specifics).

And yes, in case that this really fails, you can use recovery mode to uninstall the NVidia driver and return to the nouveau driver.

gimpo (giulio-buccini) said : #37

SOLVED!

By adopting the tested NVIDIA driver (version 384.130) all the messed graphic on the screen is disappeared.

So the open source drivers are not compatible with the most recent updates of Ubuntu 16.04.
Anyway, I'm an happy man now.

Thanks for your help!

gimpo (giulio-buccini) said : #38

Thanks Manfred Hampl, that solved my question.