Upgrade to Ubuntu 18.04

Asked by Gerardo Martínez Cabruja on 2018-08-02

I have tried to upgrade from Ubunto 16.04 to Ubuntu 18.04, but I have a message that says that my System cannot connect to Snap Store and upgrade is aborted automatically.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Gerardo Martínez Cabruja
Solved:
2018-08-02
Last query:
2018-08-02
Last reply:
2018-08-02
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes please provide the output of the commands (to be executed in a terminal window)

uname -a
lsb_release -crid
sudo dpkg --audit
sudo apt-get update

And please provide the full text that you receive for the failed upgrade attempts.

Run:

sudo do-release-upgrade

Should do it

This is the terminal:

gerardo@gerardo-N56VM:~$ uname -a
Linux gerardo-N56VM 4.4.0-131-generic #157-Ubuntu SMP Thu Jul 12 15:51:36 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
gerardo@gerardo-N56VM:~$
gerardo@gerardo-N56VM:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 16.04.5 LTS
Release: 16.04
Codename: xenial
gerardo@gerardo-N56VM:~$ sudo dpkg --audit
[sudo] password for gerardo:
gerardo@gerardo-N56VM:~$ sudo apt-get update
Ign:1 http://extras.ubuntu.com/ubuntu trusty InRelease
Des:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Obj:3 http://es.archive.ubuntu.com/ubuntu xenial InRelease
Obj:4 http://extras.ubuntu.com/ubuntu trusty Release
Des:5 http://es.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Err:6 http://extras.ubuntu.com/ubuntu trusty Release.gpg
  Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 16126D3A3E5C1192
Des:7 http://es.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
Des:8 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [67,7 kB]
Des:9 http://es.archive.ubuntu.com/ubuntu xenial-updates/main Sources [317 kB]
Des:10 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [64,6 kB]
Des:11 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [107 kB]
Des:12 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [142 kB]
Des:13 http://es.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [820 kB]
Des:14 http://es.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [747 kB]
Des:15 http://es.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [318 kB]
Des:16 http://es.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [233 kB]
Des:17 http://es.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [675 kB]
Des:18 http://es.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [616 kB]
Des:19 http://es.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [247 kB]
Des:20 http://es.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [333 kB]
Des:21 http://es.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5.976 B]
Des:22 http://es.archive.ubuntu.com/ubuntu xenial-updates/multiverse DEP-11 64x64 Icons [14,3 kB]
Des:23 http://es.archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [3.328 B]
Des:24 http://es.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [5.100 B]
Descargados 5.039 kB en 8s (573 kB/s)

(appstreamcli:21252): GLib-CRITICAL **: g_strchug: assertion 'string != NULL' failed

(appstreamcli:21252): GLib-CRITICAL **: g_strchomp: assertion 'string != NULL' failed

(appstreamcli:21252): GLib-CRITICAL **: g_strchug: assertion 'string != NULL' failed

(appstreamcli:21252): GLib-CRITICAL **: g_strchomp: assertion 'string != NULL' failed

(appstreamcli:21252): GLib-CRITICAL **: g_strchug: assertion 'string != NULL' failed

(appstreamcli:21252): GLib-CRITICAL **: g_strchomp: assertion 'string != NULL' failed
AppStream cache update completed, but some metadata was ignored due to errors.
Leyendo lista de paquetes... Hecho
W: Se produjo un error durante la verificación de las firmas. El repositorio no está actualizado y se utilizarán los ficheros de índice antiguos. Error de GPG: http://extras.ubuntu.com/ubuntu trusty Release: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 16126D3A3E5C1192
W: Fallo al obtener http://extras.ubuntu.com/ubuntu/dists/trusty/Release.gpg Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 16126D3A3E5C1192
W: No se han podido descargar algunos archivos de índice, se han omitido, o se han utilizado unos antiguos en su lugar.
gerardo@gerardo-N56VM:~$

This is the message:
Ocurrió un problema durante la actualización. Normalmente es debido a algún tipo de problema en la red, por lo que le recomendamos que compruebe su conexión de red y vuelva a intentarlo.

gerardo@gerardo-N56VM:~$ sudo do-release-upgrade
[sudo] password for gerardo:
Comprobar si hay una nueva versión de Ubuntu
Obtener:1 Firma de la herramienta de actualización [819 B]
Obtener:2 Herramienta de actualización [1.257 kB]
Obtenidos 1.258 kB en 0s (0 B/s)
autenticar «bionic.tar.gz» contra «bionic.tar.gz.gpg»
extrayendo «bionic.tar.gz»

Leyendo la caché

Comprobando el gestor de paquetes
Leyendo lista de paquetes... Finalizado
Creando árbol de dependencias
Leyendo la información de estado... Finalizado
Conexión http://es.archive.ubuntu.com/ubuntu xenial InRelease
Ignorado http://extras.ubuntu.com/ubuntu trusty InRelease
Obtener:1 http://es.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]
Conexión http://extras.ubuntu.com/ubuntu trusty Release
Obtener:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [107 kB]
Error http://extras.ubuntu.com/ubuntu trusty Release.gpg
  Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 16126D3A3E5C1192
Obtener:3 http://es.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]
Obtenidos 323 kB en 0s (0 B/s)
Leyendo lista de paquetes... Finalizado
Creando árbol de dependencias
Leyendo la información de estado... Finalizado

Actualizando la información del repositorio
Ignorado http://extras.ubuntu.com/ubuntu trusty InRelease
Conexión http://es.archive.ubuntu.com/ubuntu bionic InRelease
Conexión http://es.archive.ubuntu.com/ubuntu bionic-updates InRelease
Conexión http://extras.ubuntu.com/ubuntu trusty Release
Conexión http://security.ubuntu.com/ubuntu bionic-security InRelease
Conexión http://es.archive.ubuntu.com/ubuntu bionic-backports InRelease
Error http://extras.ubuntu.com/ubuntu trusty Release.gpg
  Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 16126D3A3E5C1192
Obtenidos 0 B en 0s (0 B/s)
Ignorado http://extras.ubuntu.com/ubuntu trusty InRelease
Conexión http://es.archive.ubuntu.com/ubuntu bionic InRelease
Conexión http://extras.ubuntu.com/ubuntu trusty Release
Conexión http://es.archive.ubuntu.com/ubuntu bionic-updates InRelease
Conexión http://security.ubuntu.com/ubuntu bionic-security InRelease
Conexión http://es.archive.ubuntu.com/ubuntu bionic-backports InRelease
Error http://extras.ubuntu.com/ubuntu trusty Release.gpg
  Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 16126D3A3E5C1192
Obtenidos 0 B en 0s (0 B/s)
Ignorado http://extras.ubuntu.com/ubuntu trusty InRelease
Conexión http://es.archive.ubuntu.com/ubuntu bionic InRelease
Conexión http://extras.ubuntu.com/ubuntu trusty Release
Conexión http://es.archive.ubuntu.com/ubuntu bionic-updates InRelease
Conexión http://security.ubuntu.com/ubuntu bionic-security InRelease
Conexión http://es.archive.ubuntu.com/ubuntu bionic-backports InRelease
Error http://extras.ubuntu.com/ubuntu trusty Release.gpg
  Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 16126D3A3E5C1192
Obtenidos 0 B en 0s (0 B/s)

Error durante la actualización

Ocurrió un problema durante la actualización. Normalmente es debido a
algún tipo de problema en la red, por lo que le recomendamos que
compruebe su conexión de red y vuelva a intentarlo.

Restaurando el estado original del sistema

Cancelando
Leyendo lista de paquetes... Finalizado
Creando árbol de dependencias
Leyendo la información de estado... Finalizado
gerardo@gerardo-N56VM:~$

Manfred Hampl (m-hampl) said : #5

You have an outdated reference to trusty in one of the configuration files.

What is the output of the command

grep trusty /etc/apt/sources.list /etc/apt/sources.list.d/*.list

gerardo@gerardo-N56VM:~$ grep trusty /etc/apt/sources.list /etc/apt/sources.list.d/*.list
/etc/apt/sources.list.d/ubuntu-extras.list:deb-src http://extras.ubuntu.com/ubuntu/ trusty main #Added by software-center
/etc/apt/sources.list.d/ubuntu-extras.list:deb http://extras.ubuntu.com/ubuntu/ trusty main #Added by software-center
gerardo@gerardo-N56VM:~$

Manfred Hampl (m-hampl) said : #7

Issue the command

sudo rm /etc/apt/sources.list.d/ubuntu-extras.list

and then try the upgrade again.

IT SEEMS TO BE WORKING!!!!!!

Everything is OK. Upgrade to 18.04 well done. Thank you very much.