18.4

Asked by Hunter Short on 2018-07-31

I tried to install the Wine software, it says its installed but when i try to launch it, it does nothing, and its not listed in my applications. Can anyone help?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-07-31
Last reply:
2018-07-31
Manfred Hampl (m-hampl) said : #1

For diagnostic purposes plase provide the output that you receive for the commands (to be executed in a terminal window):

uname -a
lsb_release -crid
dpkg -l | grep wine

Hunter Short (huntershort1) said : #2

dpkg -l grep wine
\Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-=================================
ii grep 3.1-2 amd64 GNU grep, egrep and fgrep
un wine <none> <none> (no description available)

Manfred Hampl (m-hampl) said : #3

You missed the first two commands and you omitted the pipe character in the command

uname -a
lsb_release -crid
dpkg -l | grep wine

Please try again.

Hunter Short (huntershort1) said : #4

apologies, i should have just copy and pasted to begin with lol, anyways here it is.

hunter@huntershort:~$ uname -a
Linux huntershort 4.15.0-29-generic #31-Ubuntu SMP Tue Jul 17 15:39:52 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
hunter@huntershort:~$ lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic
hunter@huntershort:~$ dpkg -l | grep wine
ii fonts-wine 3.0-1ubuntu1 all Windows API implementation - fonts
ii libwine:amd64 3.0-1ubuntu1 amd64 Windows API implementation - library
ii libwine:i386 3.0-1ubuntu1 i386 Windows API implementation - library
ii wine-stable 3.0-1ubuntu1 all Windows API implementation - standard suite
ii wine32:i386 3.0-1ubuntu1 i386 Windows API implementation - 32-bit binary loader
ii wine64 3.0-1ubuntu1 amd64 Windows API implementation - 64-bit binary loader
ii winetricks 0.0+20180217-1 all package manager for Wine to install software easily
hunter@huntershort:~$

Manfred Hampl (m-hampl) said : #5

Ok, wine seems correctly installed.

What happens if you execute the command

wine-stable

in a terminal window?

Hunter Short (huntershort1) said : #6

hunter@huntershort:~$ wine-stable
Usage: wine PROGRAM [ARGUMENTS...] Run the specified program
       wine --help Display this help and exit
       wine --version Output version information and exit

however, like i said, no icon or anything

Manfred Hampl (m-hampl) said : #7

Try

wine-stable notepad

Hunter Short (huntershort1) said : #8

Ok, i tried that and it opened notepad, but it still is nowhere to be found so it wont launch the program or anything.

Manfred Hampl (m-hampl) said : #9

Maybe you have wrong expectations.

Wine is an emulator that helps running windows executables on Linux system.
It cannon be "just launched", so there is no need for an icon.

If you have a windows program that you want to run, you have to start it with
wine-stable programname.exe

Maybe reading https://help.ubuntu.com/community/Wine helps a bit (attention, partly outdated).

Can you help with this problem?

Provide an answer of your own, or ask Hunter Short for more information if necessary.

To post a message you must log in.