Can't login to Ubuntu GUI

Asked by Sean Pruitt on 2018-07-30

I installed ubuntu-desktop using apt-get install ubuntu-desktop. I've never used GUI before. I rebooted the server and it loaded a gui screen with an option to select my name and enter a password. I assumed the password was the same as my server but it's not working. I enter the password and it goes to a black screen and returns to the login again. Do I have to setup a seperate user account for gui or is it the same as when I use sudo? Please help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
Sean Pruitt
Solved:
2018-07-31
Last query:
2018-07-31
Last reply:
2018-07-30
Sean Pruitt (seanpruitt) said : #1

I tried manipulating .Xauthority and deleting local data. A few sites suggested same things and it still does not work.

Press CTRL + ALT + F1 and login there and run:

sudo chown -R $USER:$USER $HOME
sudo apt-get clean
sudo reboot

You don't need to change the commands. BASH variables manage things.

Sean Pruitt (seanpruitt) said : #3

I tried it with no success. It's doing the same thing. I enter password it goes to black screen then back to purple login. I had to press CTRL + ALT + F3 not F1 BTW. Not sure if that even matters.

That's fine. You get 4 TTYs. Useful. Do your partitions have free space?

Sean Pruitt (seanpruitt) said : #5

Yes. I have an SSD with 100g free and raid with 7tb free

Sean Pruitt (seanpruitt) said : #6

I figured it out I just needed the latest NVIDIA drivers

Nice. If you used the installer from the Nvidia site then you'll need to rebuild the kernel module if you get a new kernel. If you did use this method I can suggest apt-pinning the kernel if all your hardware is running OK. Makes life easier