Touchpad Not Working After 18.04LTS Clean Install

Asked by marinos roussos on 2018-07-09

I have a dual Win10 boot and (K)ubuntu 18.04 on a Fujitsu Ultrabook UH572 i5/8GBram and (K)ubuntu is running on a 32GBSSD. After a clean install of (K)ubuntu 18.04 I noticed that the touchpad wasn't working...On Win everything works fine.

It's the first time I'm running Ubuntu on this machine so I don"t know what the issue could be. In the past I never had an issue with the touchpad. Maybe it has to do with the fact that its a click-touch-pad? It has no buttons just a big area, kind like a Mac.....

In any case I can see the touchpad when typing xinput list in terminal. Below the output:

kongking@UH572:~$ xinput list
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ USB OPTICAL MOUSE id=10 [slave pointer (2)]
⎜ ↳ SynPS/2 Synaptics TouchPad id=13 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Fujitsu FUJ02E3 id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Power Button id=9 [slave keyboard (3)]
    ↳ FJ Camera: FJ Camera id=11 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=12 [slave keyboard (3)]
I've tried editing the etc/default/grub file and replacing "quiet splash" with "acpi=force", according the link below: SynPS/2 Synaptic Touchpad not working in Ubuntu 17.10, with no luck.

Any ideas how to tackle this??

Many thanks,

μρ .

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Last query:
2018-07-14
Last reply:
2018-07-09

This question was reopened

Is there a switch to enable or disable the touch pad? If so, use it. Is the touch pad enabled in BIOS?

Hey Andrew,

Thanks for your reply.

Well in Windows10 everything is working fine...

Worked like a charm
:-)

Many thanks

Hey,
sorry to bother you again but...

...I just noticed that after sleep/hibernation the touchpad doesn't work...

μρ .

Can you help with this problem?

Provide an answer of your own, or ask marinos roussos for more information if necessary.

To post a message you must log in.