problems with Ubuntu 18.04 update

Asked by davidzaq1 on 2018-07-06

Hello,

I was updating Ubuntu 18.04 on my dell 1500 laptop and received the following errors.
Can you tell me how to fix these errors?

Thank you,

Err:10 http://download.videolan.org/pub/debian/stable InRelease
  403 Forbidden [IP: 88.191.250.2 80]
Reading package lists... Done
E: Failed to fetch http://download.videolan.org/pub/debian/stable/InRelease 403 Forbidden [IP: 88.191.250.2 80]
E: The repository 'http://download.videolan.org/pub/debian/stable InRelease' is no longer signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Target Sources (Sources) is configured multiple times in /etc/apt/sources.list.d/libdvdcss.list:1 and /etc/apt/sources.list.d/libdvdcss.list:3

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu Edit question
Assignee:
No assignee Edit question
Solved by:
davidzaq1
Solved:
2018-07-13
Last query:
2018-07-13
Last reply:
2018-07-13

Do these 3rd party sources support Bionic?

Manfred Hampl (m-hampl) said : #2

Are you sure that the information about adding a videolan server as additional source is still valid for Ubuntu 18.04?

I suggest that you delete the /etc/apt/sources.list.d/libdvdcss.list file and install the libdvd-pkg package.

see https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs

davidzaq1 (david3a9x) said : #3

Hello,

I do not know how to : delete the /etc/apt/sources.list.d/libdvdcss.list file and install the libdvd-pkg package.

can you give me step by step instructions please.

davidzaq1 (david3a9x) said : #4

Here is some additional information

This is the copy of the source list but I do know what to do with it and would not know if there is anything wrong here.

# deb cdrom:[Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426)]/ bionic main restricted
deb-src http://archive.ubuntu.com/ubuntu bionic main restricted #Added by software-properties

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://uk-mirrors.evowise.com/ubuntu/ bionic main restricted
deb-src http://uk-mirrors.evowise.com/ubuntu/ bionic multiverse universe main restricted #Added by software-properties
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://uk-mirrors.evowise.com/ubuntu/ bionic-updates main restricted
deb-src http://uk-mirrors.evowise.com/ubuntu/ bionic-updates multiverse universe main restricted #Added by software-properties
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://uk-mirrors.evowise.com/ubuntu/ bionic universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic universe
deb http://uk-mirrors.evowise.com/ubuntu/ bionic-updates universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://uk-mirrors.evowise.com/ubuntu/ bionic multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://uk-mirrors.evowise.com/ubuntu/ bionic-updates multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that

Bashing-om (bashing-om) said : #5

davidzaq1; Hey -

see: http://download.videolan.org/pub/debian/stable that the software has no support for bionic.
The videolan should be removed as Manfred suggests.
then also there is the duplication of sources.
show us the output of:
tail -v -n +1 /etc/apt/sources.list.d/*
So I know exactly what you are working with.

-ain't nothing but a thing-

Manfred Hampl (m-hampl) said : #6

1. I do not know what you are doing with your sources.list file, but the security repositories (the fastest way to distribute security-relevant updates) is missing in your configuration. When reading your previous questions I can see that they were enabled three weeks ago, but at that time for an outdated Ubuntu release.
Your current sources.list file has a strange mixture between a UK mirror and the US country server. You should make up your mind in what part of the world you are located, and use the nearest reasonable server.

2. "how to delete the /etc/apt/sources.list.d/libdvdcss.list file"
Open a terminal window and execute the command
sudo rm /etc/apt/sources.list.d/libdvdcss.list

davidzaq1 (david3a9x) said : #7

Hello,

Thank you for your reply.

As for the advice to delete the files from #2 above.
I would be happy to do this but do not know how.
I need some help with this if you can do that for me.

I cannot access the source list. I have tried to do everything to get into this but it wont take me to where I need to go.
I need help with this also.

As for the commands in #5 above, here is the output:

$ tail -v -n +1 /etc/apt/sources.list.d/*
==> /etc/apt/sources.list.d/libdvdcss.list.save <==
deb-src http://download.videolan.org/pub/debian/stable/ /
deb http://download.videolan.org/pub/debian/stable/ /
deb-src http://download.videolan.org/pub/debian/stable/ /

==> /etc/apt/sources.list.d/nilarimogard-ubuntu-webupd8-bionic.list <==
deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main
# deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main

==> /etc/apt/sources.list.d/nilarimogard-ubuntu-webupd8-bionic.list.save <==
deb http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main
# deb-src http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic main

Thank you,
David

Manfred Hampl (m-hampl) said : #8

Please read comment #6

davidzaq1 (david3a9x) said : #9

No, the above was a mistake.

I need to know how to follow the advice from #2.

delete the /etc/apt/sources.list.d/libdvdcss.list file

and

install the libdvd-pkg package.

Thank you
David

Manfred Hampl (m-hampl) said : #10

Have you read item 2. in comment #6?

davidzaq1 (david3a9x) said : #11

Yes. but I am still having problems

I ran this command: cat /etc/apt/sources.list and have this result:

$ cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426)]/ bionic main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main restricted #Added by software-properties

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic multiverse universe restricted #Added by software-properties
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse universe main restricted #Added by software-properties
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse #Added by software-properties
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://us.archive.ubuntu.com/ubuntu/ bionic-security main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-security multiverse universe main restricted #Added by software-properties
# deb-src http://security.ubuntu.com/ubuntu bionic-security main restricted
deb http://us.archive.ubuntu.com/ubuntu/ bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic-security multiverse
deb http://us.archive.ubuntu.com/ubuntu/ bionic-proposed multiverse main universe restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-proposed multiverse main universe restricted #Added by software-properties
# deb-src http://security.ubuntu.com/ubuntu bionic-security multiverse
# deb http://archive.canonical.com/ bionic partner
# deb-src http://archive.canonical.com/ bionic partner
stan@roo:~$

Maybe you can tell me how to fix this.

Manfred Hampl (m-hampl) said : #12

What problem do you still have?
On a first glimpse the sources.list file does not look wrong.
The only question is whether you need the source repositories enabled. This would only be required if you build your own version of packages locally.

davidzaq1 (david3a9x) said : #13

When I do a apt-get update i receive error messages saying the /etc is messed up and I am trying to find out how to fix it.

This is the message I am getting:

W: Target Sources (restricted/source/Sources) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list:7
W: Target Sources (restricted/source/Sources) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list:7

I am trying to fix this so there is no error;

Thank you

Manfred Hampl (m-hampl) said : #14

I have no idea how the sources.list file could be messed up like this except by manually fiddling around.

Use the information in the error message to identify the cause:

Look at line 2 of /etc/apt/sources.list and look at line 7

line 2: deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main restricted
line 7: deb-src http://us.archive.ubuntu.com/ubuntu/ bionic multiverse universe restricted

There are references to "restricted" in both of them.

Proposal for a solution: edit the /etc/apt/sources.list file and remove the string "restricted" from line 7.

As already written in my previous comment: Why did you enable the sources repositories at all? Do you compile your own versions of packages locally? If not, you should disable (untick) "source" in software-properties-gtk

davidzaq1 (david3a9x) said : #15

Hello,

I am having a problem with your instructions. I do not understand what you are asking me to do.

I clicked on the link above which starts: line 2: deb

this is all that shows up:

 [DIR] dists/ 2018-05-01 18:56 -
[DIR] indices/ 2018-07-12 01:12 -
[ ] ls-lR.gz 2018-07-12 01:18 14M
[DIR] pool/ 2010-02-27 06:30 -
[DIR] project/ 2013-06-28 11:52 -
[DIR] ubuntu/ 2018-07-12 01:20 -

Also, you said to look at line 2 of /etc/apt/sources.list

This is all that shows up:

$ /etc/apt/sources.list
bash: /etc/apt/sources.list: Permission denied

I also tried sudo /etc/apt/sources.list

I got this message:

sudo: /etc/apt/sources.list: command not found

I do not know how to do the things you are asking me to do. Nothing seems to work.

Can you give me more detailed instructions

Thanks,

sudo gedit /etc/apt/sources.list

This will allow you to edit the file

davidzaq1 (david3a9x) said : #17

Hello,

I got to the source list and ran the command.
As instructed, I removed "restricted from line 7.

I received following WARNING messages:

$ sudo gedit /etc/apt/sources.list
[sudo] password for stan:

** (gedit:6978): WARNING **: 20:24:29.781: Set document metadata failed: Setting attribute metadata::gedit-spell-language not supported

** (gedit:6978): WARNING **: 20:24:29.789: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported

** (gedit:6978): WARNING **: 20:24:53.942: Set document metadata failed: Setting attribute metadata::gedit-spell-language not supported

** (gedit:6978): WARNING **: 20:24:53.943: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported

** (gedit:6978): WARNING **: 20:24:58.885: Set document metadata failed: Setting attribute metadata::gedit-position not supported

Manfred Hampl (m-hampl) said : #18

These warning messages ("Set document metadata failed") can safely be ignored.

Does "sudo apt-get update" still show warnings and/or errors, or is this issue now resolved?

General remark:
I recommend that you try getting hold of some "getting started with Ubuntu" tutorial, if you still cannot understand basic instruction after eight years of using Ubuntu (you created you first question eight years ago!)

davidzaq1 (david3a9x) said : #19

sudo apt-get update is till giving the following message:

W: Target Sources (restricted/source/Sources) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list:7
W: Target Sources (restricted/source/Sources) is configured multiple times in /etc/apt/sources.list:2 and /etc/apt/sources.list:7

davidzaq1 (david3a9x) said : #20

Still getting warning messages also:

$ sudo gedit /etc/apt/sources.list

** (gedit:6148): WARNING **: 13:05:12.887: Set document metadata failed: Setting attribute metadata::gedit-spell-language not supported

** (gedit:6148): WARNING **: 13:05:12.890: Set document metadata failed: Setting attribute metadata::gedit-encoding not supported

** (gedit:6148): WARNING **: 13:05:17.092: Set document metadata failed: Setting attribute metadata::gedit-position not supported

Manfred Hampl (m-hampl) said : #21

In comment #17 you wrote that you have removed the double "restricted".
How is it possible that it is still there?

What is the output of:

cat -n /etc/apt/sources.list | head

Thanks

davidzaq1 (david3a9x) said : #23

Here is the output from above:

:~$ cat -n /etc/apt/sources.list | head
     1 # deb cdrom:[Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426)]/ bionic main restricted
     2 deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main restricted #Added by software-properties
     3
     4 # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
     5 # newer versions of the distribution.
     6 deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted
     7 deb-src http://us.archive.ubuntu.com/ubuntu/ bionic multiverse universe restricted #Added by software-properties
     8 # deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main
     9
    10 ## Major bug fix updates produced after the final release of the
stan@roo:~$

Also, here is what is in the source list. I removed the restrictios but maybe you can find the problem.

# deb cdrom:[Ubuntu 18.04 LTS _Bionic Beaver_ - Release amd64 (20180426)]/ bionic main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main restricted #Added by software-properties

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://us.archive.ubuntu.com/ubuntu/ bionic main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic multiverse universe restricted #Added by software-properties
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main

## Major bug fix updates produced after the final release of the
## distribution.
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse universe main restricted #Added by software-properties
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates main

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ bionic universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates universe
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://us.archive.ubuntu.com/ubuntu/ bionic multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic multiverse
deb http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://us.archive.ubuntu.com/ubuntu/ bionic-backports main universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-backports main universe multiverse #Added by software-properties
# deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-backports main universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu bionic partner
# deb-src http://archive.canonical.com/ubuntu bionic partner

deb http://us.archive.ubuntu.com/ubuntu/ bionic-security main
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-security multiverse universe main #Added by software-properties
# deb-src http://security.ubuntu.com/ubuntu bionic-security main
deb http://us.archive.ubuntu.com/ubuntu/ bionic-security universe
# deb-src http://security.ubuntu.com/ubuntu bionic-security universe
deb http://us.archive.ubuntu.com/ubuntu/ bionic-security multiverse
deb http://us.archive.ubuntu.com/ubuntu/ bionic-proposed multiverse main universe restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ bionic-proposed multiverse main universe restricted #Added by software-properties

OK, run:

sudo gedit /etc/apt /sources.list

Delete the second line from the file. Which will read:

deb-src http://us.archive.ubuntu.com/ubuntu/ bionic main restricted #Added by software-properties

Save the new file, close gedit and run:

sudo apt-get update

Is it OK now please?

Manfred Hampl (m-hampl) said : #25

We cannot help if you do not follow our advice.

Two days ago I already recommended to disable ALL deb-src references:

Start the program software-properties-gtk and disable (untick) "source".

davidzaq1 (david3a9x) said : #26

Hello Andrew,

Thank you for your answer.

I ran the command as you suggested and deleted like #2.
Than ran the update.

Everything is working just fine now.

All I needed was the right instruction.

Thank you so much!
Have a great day.
David